kolourPaint download [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

kolourPaint download [SOLVED]

Post by chazb » Tue Nov 13, 2018 5:05 am

Lm17 Quana, Cinamon

I had this program for a long while and then i dickered with Home folder in anticipation of 18/3, and now the program wont open. So I delete it to re-install it.. I have tried to install it graphically and using the command line, not at the same time, but in either case the program won't open. It is a KDE program, but I would think it would still work in a Gnome environment, as it has in the past.
Can anyone help me with this?
Last edited by chazb on Fri Nov 16, 2018 4:16 am, edited 1 time in total.

User avatar
Pierre
Level 17
Level 17
Posts: 7706
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: kolourPaint download

Post by Pierre » Tue Nov 13, 2018 5:09 am

the program KolourPaint should be available to install in Package Manager AKA synaptic.

is it installable with that ? does it create an Menu Tree link ?.
can you run that KolourPaint from Terminal ?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Tue Nov 13, 2018 12:21 pm

Via Terminal

Code: Select all

rm $HOME/.kde/share/config/kolourpaintrc
apt install kolourpaint4

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Wed Nov 14, 2018 12:57 am

administrollaattori wrote:
Tue Nov 13, 2018 12:21 pm
Via Terminal

Code: Select all

rm $HOME/.kde/share/config/kolourpaintrc
apt install kolourpaint4
Tried synaptic and treid your code, I click it and nothing happens. It is like somewhere deep in the system some sub-routeen is keeping it from opening.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Wed Nov 14, 2018 2:03 am

chazb wrote:
Wed Nov 14, 2018 12:57 am
administrollaattori wrote:
Tue Nov 13, 2018 12:21 pm
Via Terminal

Code: Select all

rm $HOME/.kde/share/config/kolourpaintrc
apt install kolourpaint4
Tried synaptic and treid your code, I click it and nothing happens. It is like somewhere deep in the system some sub-routeen is keeping it from opening.
Any error messages when opening Kolourpaint via Terminal?

Code: Select all

kolourpaint

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Wed Nov 14, 2018 3:34 am

administrollaattori wrote:
Wed Nov 14, 2018 2:03 am
chazb wrote:
Wed Nov 14, 2018 12:57 am

Any error messages when opening Kolourpaint via Terminal?

Code: Select all

kolourpaint
I didn't know I could do that, I learn something new everyday. But here is the result,,,,,,

Code: Select all

charles@charles-Inspiron-1526 ~ $ kolourpaint
kolourpaint: error while loading shared libraries: /usr/lib/i386-linux-gnu/libattica.so.0.4: invalid ELF header
Also,,,,,,

Code: Select all

charles@charles-Inspiron-1526 ~ $ dpkg -L libattica-dev
dpkg-query: package 'libattica-dev' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
What is an ELF header, is it something I can access on my computer?
So I looked at the result and went poking around on the net and found that found a site that shows me how to install libattica-dev as I apparently don't have it. But I am not sure this would solved the problem.
I just noticed though when I originally acquired KolourPaint, I was using an Inspiron 1526, and now I am using an Inspiron 1525, but I have also discovered that LinuxMint doesn't seem to be architecture dependent. Unlike Microsoft.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Wed Nov 14, 2018 6:21 am

Install dependencies

Code: Select all

apt install libc6 libkdecore5 libkdeui5 libkio5 libkprintutils4 libqimageblitz4 libqtcore4 libqtgui4 libstdc++6

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Thu Nov 15, 2018 12:29 am

administrollaattori wrote:
Wed Nov 14, 2018 6:21 am
Install dependencies

Code: Select all

apt install libc6 libkdecore5 libkdeui5 libkio5 libkprintutils4 libqimageblitz4 libqtcore4 libqtgui4 libstdc++6
A lot of stuff there, I got some of it but not all of it,,,,,,,,

Code: Select all

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libstdc++-4.8-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-8ubuntu1 is to be installed
                     Conflicts: libstdc++6-4.6-doc but 4.6.4-6ubuntu2 is to be installed
                     Conflicts: libstdc++6-4.7-doc but 4.7.3-12ubuntu1 is to be installed
 libstdc++6-4.6-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-8ubuntu1 is to be installed
 libstdc++6-4.6-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-8ubuntu1 is to be installed
 libstdc++6-4.7-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-8ubuntu1 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-6ubuntu2 is to be installed
 libstdc++6-4.7-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-8ubuntu1 is to be installed
                      Conflicts: libstdc++6-4.6-doc but 4.6.4-6ubuntu2 is to be installed
 libstdc++6-4.8-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-8ubuntu1 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-6ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.7-dbg but 4.7.3-12ubuntu1 is to be installed
 libstdc++6-4.8-dbg-armhf-cross : Conflicts: libstdc++6-4.7-dbg-armhf-cross but 4.7.3-11ubuntu1cross1.85 is to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all

charles@charles-Inspiron-1526 ~ $ kolourpaint
kolourpaint: error while loading shared libraries: /usr/lib/i386-linux-gnu/libattica.so.0.4: invalid ELF header

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Thu Nov 15, 2018 1:04 am

So I tried my idea of installing lidattica-dev and that didn't work either. Still getting,,,,Invalid ELF header,,,,,.

Code: Select all

charles@charles-Inspiron-1526 ~ $ kolourpaint
kolourpaint: error while loading shared libraries: /usr/lib/i386-linux-gnu/libattica.so.0.4: invalid ELF header

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Thu Nov 15, 2018 3:37 am

chazb wrote:
Thu Nov 15, 2018 12:29 am

Code: Select all

E: Unable to correct problems, you have held broken packages.
To see what packages are held

Code: Select all

dpkg --get-selections | grep hold
Do you use some PPAs?

Code: Select all

inxi -r

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Thu Nov 15, 2018 4:03 am

administrollaattori wrote:
Thu Nov 15, 2018 3:37 am
chazb wrote:
Thu Nov 15, 2018 12:29 am

Code: Select all

E: Unable to correct problems, you have held broken packages.
To see what packages are held

Code: Select all

dpkg --get-selections | grep hold
Do you use some PPAs?

Code: Select all

inxi -r
I don't have any PPA's and dpkg didn't work,,,,,,,

Code: Select all

charles@charles-Inspiron-1526 ~ $ dpkg --get-selections | grep hold
charles@charles-Inspiron-1526 ~ $ dpkg --get-selections | grep hold
charles@charles-Inspiron-1526 ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://reflection.oss.ou.edu/linuxmint/repos qiana main upstream import
           deb http://extra.linuxmint.com qiana main
           deb http://mirror.zol.co.zw/ubuntu trusty main restricted universe multiverse
           deb http://mirror.zol.co.zw/ubuntu trusty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ trusty partner
           Active apt sources in file: /etc/apt/sources.list.d/openjdk-r-ppa-trusty.list
           deb http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty main
           deb-src http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
           deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Thu Nov 15, 2018 4:10 am

You have some OpenJDK PPA

Code: Select all

 Active apt sources in file: /etc/apt/sources.list.d/openjdk-r-ppa-trusty.list
           deb http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty main
           deb-src http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty main
Disable that PPA via Software Sources and then run

Code: Select all

apt update
sudo apt-get -f install
apt install --reinstall kolourpaint4

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Thu Nov 15, 2018 4:36 am

administrollaattori wrote:
Thu Nov 15, 2018 4:10 am
You have some OpenJDK PPA

Code: Select all

 Active apt sources in file: /etc/apt/sources.list.d/openjdk-r-ppa-trusty.list
           deb http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty main
           deb-src http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty main
Disable that PPA via Software Sources and then run

Code: Select all

apt update
sudo apt-get -f install
apt install --reinstall kolourpaint4
Result,,,,,

Code: Select all

charles@charles-Inspiron-1526 ~ $ kolourpaint
kolourpaint: error while loading shared libraries: /usr/lib/i386-linux-gnu/libattica.so.0.4: invalid ELF header

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Thu Nov 15, 2018 5:02 am

Code: Select all

apt install --reinstall libattica0.4

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Thu Nov 15, 2018 4:19 pm

administrollaattori wrote:
Thu Nov 15, 2018 5:02 am

Code: Select all

apt install --reinstall libattica0.4
First, I want to Thank You. this fixed the problem.

Second, I want to pick your brain, i.e. understand your thinking. Earlier in this thread I installed Libatica-dev which I assumed contained what i needed of Libetica, but apparently not. What was your thinking that caused you to instruct me to, reinstall, Libatica0,4.

Third, Is there a Option I can use with kolourpaint in the terminal to show the correct path, string, etc. for opening the file? I had a similar with Thunderbird not opening on another thread. I didn't know at the time the time that I could just type "Thunderbird" in terminal and see why it wasn't opening. Knowing the correct path for opening a file would be useful, to know. I finally got to the point that i uninstalled Thunderbird and installed it again, and it worked, not knowing that all had to do is "reinstalled" it, saving a lot of time and head ache. This has been a very useful thread for learning.

I will mark the thread solvede when I get your reply

User avatar
ricardogroetaers
Level 2
Level 2
Posts: 74
Joined: Sat Oct 27, 2018 3:06 am
Location: Rio de Janeiro, Brasil

Re: kolourPaint download [SOLVED]

Post by ricardogroetaers » Fri Nov 16, 2018 4:41 am

Just one remark:
I have Mint 17.3 Xfce and installed "kolourpaint " by "synaptic " directly from the official Mint repositories.
https://i.imgur.com/Pjn3SJv.png
In "Xfce " It is recommended that in "session and Startup " you enable "Launch KDE services when starting ".
In "Cinamon " There must be something like that.

User avatar
chazb
Level 4
Level 4
Posts: 266
Joined: Wed Nov 30, 2016 2:56 am
Location: Oklahoma

Re: kolourPaint download

Post by chazb » Thu Nov 29, 2018 2:34 am

administrollaattori wrote:
Thu Nov 15, 2018 5:02 am
S I have Upgraded to LM 18.3 Sylvia, Xfce.
Used synaptic to install Kolourpaint, but I couldn't find the Icon any wear so I imported the Icon from LM 17 and it will load but when I click it, though gives me a warning that it is untrusted softwear and three options to; load anyway, make executable, or close. How do I get the system to trust the software?

User avatar
administrollaattori
Level 15
Level 15
Posts: 5667
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: kolourPaint download

Post by administrollaattori » Thu Nov 29, 2018 2:43 pm

chazb wrote:
Thu Nov 29, 2018 2:34 am
administrollaattori wrote:
Thu Nov 15, 2018 5:02 am
S I have Upgraded to LM 18.3 Sylvia, Xfce.
Used synaptic to install Kolourpaint, but I couldn't find the Icon any wear so I imported the Icon from LM 17 and it will load but when I click it, though gives me a warning that it is untrusted softwear and three options to; load anyway, make executable, or close. How do I get the system to trust the software?
Load anyway once, so it should be trusted. :wink:

Post Reply

Return to “Newbie Questions”