Issue downgrading mono due to dependancies

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
BigAngry
Level 1
Level 1
Posts: 20
Joined: Thu May 11, 2017 6:10 pm

Issue downgrading mono due to dependancies

Post by BigAngry » Fri Nov 16, 2018 8:16 pm

I'm trying to downgrade my version of mono to 5.4 but am getting an issue. I need to do this because later versions cause serious issues for an application I'm using. I've followed the instructions here, but have no clue how to get around this issue. https://www.mono-project.com/docs/getti ... all/linux/

Code: Select all

dre@dre-desktop ~ $ sudo apt install mono-devel=5.4.1.7-0xamarin5+ubuntu1404b1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-devel : Depends: libmono-cecil-private-cil (< 5.4.1.8) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: mono-mcs (= 5.4.1.7-0xamarin5+ubuntu1404b1) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: mono-roslyn (= 5.4.1.7-0xamarin5+ubuntu1404b1) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: mono-gac (= 5.4.1.7-0xamarin5+ubuntu1404b1) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: mono-xbuild (= 5.4.1.7-0xamarin5+ubuntu1404b1) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: libmono-cil-dev (= 5.4.1.7-0xamarin5+ubuntu1404b1) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: libmono-2.0-dev (< 5.4.1.7-0xamarin5+ubuntu1404b1.1~) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
              Depends: ca-certificates-mono (= 5.4.1.7-0xamarin5+ubuntu1404b1) but 5.16.0.179-0xamarin1+ubuntu1404b1 is to be installed
E: Unable to correct problems, you have held broken packages.

Post Reply

Return to “Newbie Questions”