need help running Plex Media Server (failed to execute... x-www-browser)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
ginahoy
Level 3
Level 3
Posts: 188
Joined: Sun May 28, 2017 3:15 pm

need help running Plex Media Server (failed to execute... x-www-browser)

Post by ginahoy » Thu Nov 22, 2018 2:29 pm

When I attempt to run Plex Media Server, I get this error: "failed to execute... x-www-browser"
I don't use PMS very often so I don't know what changes I made to my system that could have caused this. One possibility is a recent manual upgrade to my browser (Firefox v55 to v56).
.
Screenshot_2018-11-22_11-17-50.png
Screenshot_2018-11-22_11-17-50.png (15.2 KiB) Viewed 131 times
Linux Mint 18.2 Xfce x64 | ASRock Z270 Extreme4 | Core i7 7700K | Cryorig H7 cooler| 32GB DDR4 2400| modded legacy Evercase LE4252 | EVGA 450W B3 | Samsung 850 EVO SSD

Neil Edmond
Level 6
Level 6
Posts: 1036
Joined: Thu Dec 26, 2013 10:19 am
Location: N.E. AR USA

Re: need help running Plex Media Server (failed to execute... x-www-browser)

Post by Neil Edmond » Thu Nov 22, 2018 9:21 pm

What happens if you just enter "localhost:32400/manage" in your browser address bar?

ginahoy
Level 3
Level 3
Posts: 188
Joined: Sun May 28, 2017 3:15 pm

Re: need help running Plex Media Server (failed to execute... x-www-browser)

Post by ginahoy » Thu Nov 22, 2018 10:23 pm

Neil Edmond wrote:
Thu Nov 22, 2018 9:21 pm
What happens if you just enter "localhost:32400/manage" in your browser address bar?
That works. It launches PMS in Firefox. Thanks!
I created a bookmark, which resolves the problem. But how do I repair the launcher command?
Linux Mint 18.2 Xfce x64 | ASRock Z270 Extreme4 | Core i7 7700K | Cryorig H7 cooler| 32GB DDR4 2400| modded legacy Evercase LE4252 | EVGA 450W B3 | Samsung 850 EVO SSD

User avatar
smurphos
Level 12
Level 12
Posts: 4067
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: need help running Plex Media Server (failed to execute... x-www-browser)

Post by smurphos » Fri Nov 23, 2018 1:45 am

Double check you've got Firefox set as your web browser in preferred applications. How exactly did you manually upgrade? And why are you using a version of Firefox missing 17 months worth of security patches?
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

ginahoy
Level 3
Level 3
Posts: 188
Joined: Sun May 28, 2017 3:15 pm

Re: need help running Plex Media Server (failed to execute... x-www-browser)

Post by ginahoy » Fri Nov 23, 2018 5:44 am

smurphos wrote:
Fri Nov 23, 2018 1:45 am
Double check you've got Firefox set as your web browser in preferred applications. How exactly did you manually upgrade? And why are you using a version of Firefox missing 17 months worth of security patches?
Yes, Mozilla Firefox is listed as my preferred browser under Settings Manager / Preferred Applications.

I followed instructions found elsewhere in this forum to manually upgrade Firefox. I'm sticking with v56 for the time being so I don't have to give up all the add-ons I've come to rely on.
Linux Mint 18.2 Xfce x64 | ASRock Z270 Extreme4 | Core i7 7700K | Cryorig H7 cooler| 32GB DDR4 2400| modded legacy Evercase LE4252 | EVGA 450W B3 | Samsung 850 EVO SSD

Post Reply

Return to “Newbie Questions”