Can't print! What have I forgotten?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 19
Joined: Mon Nov 12, 2018 7:00 am

Can't print! What have I forgotten?

Post by DaveMcSu2 »

Hello again!!

I have given up for now on my attempts to get OpenOffice Writer running on Mint. They do not seem to get along for some reason.
So I have been using Libre Office Writer that came with the Mint 19 installation.

I just tried printing a couple of pages and nothing happens. The printer just sits there looking at me and I can't figure out what I have forgotten to do.

The printer has power, plenty of paper and a USB cable connects to the laptop. (Am running Mint19 Cinnamon).

What is strange is that when I tell Libre Office Writer to print, there's no error message. It seems to think that everything has gone according to plan.

Clearly I have forgotten to install / run something, but without an error message telling me what it is looking for I am not sure where to begin. I understand that the issue may be with Libre Office rather than with Mint itself but I have to start somewhere and figured I'd ask you folks first.

Thank you for reading!!!

Level 5
Level 5
Posts: 630
Joined: Mon Apr 01, 2013 12:33 pm

Re: Can't print! What have I forgotten?

Post by turtlebay »

Check your printer's settings and under Properties click 'print test page'. If nothing prints you need to change the driver where it says 'make and model'. Keep testing and changing make and model until it works.

User avatar
Level 10
Level 10
Posts: 3403
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: Can't print! What have I forgotten?

Post by lsemmens »

Make and model of printer might help us a bit more. HPLIP drivers ensure that I can print and scan with my HP printer across the network,
Fully mint Household
Out of my mind - please leave a message

Level 1
Level 1
Posts: 19
Joined: Mon Nov 12, 2018 7:00 am

Re: Can't print! What have I forgotten?

Post by DaveMcSu2 »

I can't find the printer in the list.
Printer is a fairly modern one, Epson ET2750.
It is a USB one.
When I click add printer it appears on the list of printers I can add so it is clearly communicating with the computer. There's even it's name "Epson ET2750" and a little picture of it. When I go forward to the bit where you choose drivers I can select Epson but ET2750 model does not appear in the list.
I have googled for drivers for the printer but just get lots of adverts from people selling the printer.
Does anyone have experience with this printer on Mint?

Level 1
Level 1
Posts: 37
Joined: Tue Apr 14, 2015 6:18 am

Re: Can't print! What have I forgotten?

Post by erikjan »

Sometimes my printer does not print because it got "offline" somehow. Perhaps your printer is offline too, and there is nothing wrong. Just set it online again. Have look at "properties" of your printer and choose "policies" or something like this. (My system language is not English.)

Good luck.

Erik Jan

User avatar
Level 5
Level 5
Posts: 806
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: Can't print! What have I forgotten?

Post by kato181 »

Hi DaveMcSu2,
I run openoffice on my mint 19 with no problems at all.
But it DOES run in conflict with libreoffice, so if you want openoffice to work you have to completely remove libreoffice, as stated in the notes that come with openoffice.
To get your ET-2750 printer to work, i presume its a 3-in-1 then you have to download from Epson website the latest linux drivers if you want the scanner to work, go to epson website and download the following files..
1.makesure you get the file that says Imagescan - bundle -unbuntu-18.04-1.38.x8
you will then have two folders...
1.Core: - it contains the following file: imagescan-bundle-ubuntu-18.04-1.3.38.x8
2.Plugins: it contains the following file: imagescan-plugin-networkscan_1.1.1-1 epson4ubuntu18.04_i386.deb
RUN them in order 1 then 2
The amd64 is the same setup but with different files.
Then EDIT the imagescan.conf by doing...
then sudu su nano /etc/imagescan/imagescan.conf
then add these lines at the very beginning
net.udi = %esci:networkscan://(the printers ip (for example (this port number MUST be used)
net.vendor = Epson
net.model = ET-2750 = Scanner
then save
then reboot, The final information is that only Image Scan and Vuescan will work.

Next step it to go to the hosts file and edit it..
nano /etc/hosts
on the first line put....

printers ip eg ( localhost (your comuter name like) Tara

Then save and reboot now tour printer and scanner should work
To remove Libreoffice
sudo apt-get remove libreoffice-core
sudo apt-get remove libreoffice-common
sudo apt-get remove --purge libreoffice-core
then sudo apt update.

To install OpenOffice do the following::
put the folder DEBS in your work directory get root
cd /your name/home/Work/DEBS
sudo dpkg -i *.deb and wait to finish.
then do
cd desktop-integration
sudo dpkg *.deb
then sudo apt update
Reboot and you should be right to go.

Post Reply

Return to “Newbie Questions”