PC doesn't start - [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
52ROSt
Level 4
Level 4
Posts: 425
Joined: Mon Apr 14, 2014 10:01 am

PC doesn't start - [SOLVED]

Post by 52ROSt » Fri Jan 04, 2019 9:45 am

LM 19.0 Cinnamon 64bit

While working with the USB Formater my the apps hang up several times. I had to kill a few applications using xkill.
Thereafter I made a logout.
As it seems that the logout did not run well, I just switch of power (power button 10sec).

Restarting the machine again the normal login screen does not show up.
Already the first LM logo appears very dark and the following terminal display is also very dark.
I can increase brightness and work with the terminal.

I could loggin and used

Code: Select all

sudo shutdown -r now
Machine starts up again in terminal. Logged in again and used

Code: Select all

startx
Last 3 lines shown in the terminal are:

Code: Select all

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
myname@mymachine:~$
How can I get back to normal start up?

Your help is highly appreciated!

UPDATE:
I remember that before the problem started I tried to make a snapshot using TimeShift. This program stopped with the message that there is not enough space available.
Could it be that deleting the last snapshot could be the solution?
How can I find the last snapshot?
How can I delete the last snapshot?

Next I started LM 19.0 Cinnamon in recovery mode and selected "Free Space". This brougth me
- 71.8kB free space
- In a normal boot I can reach the Cinnamon login screen again

Selecting "Cinnamon (Default)" or "Cinnamon (Software Rendering)" and entering my passwort it just brings me back to entering the password. However, it does not show the message "Invalid password, please try again".

The same happens when I use the on screen keyboard.

I appreciate your help a lot!
Last edited by 52ROSt on Mon Jan 14, 2019 9:24 pm, edited 1 time in total.

User avatar
trytip
Level 11
Level 11
Posts: 3721
Joined: Tue Jul 05, 2016 1:20 pm

Re: PC doesn't start

Post by trytip » Sat Jan 05, 2019 5:26 pm

where did you choose to install the backups for timeshift? did you boot with a linux mint live and check to see if you are running out of space on your drives?
if you ran out of space doesn't that mean you do have some snapshots available for restore?

in your mint live open timeshift set it up to where you location is for the snapshots and see what it gives you
Image

User avatar
52ROSt
Level 4
Level 4
Posts: 425
Joined: Mon Apr 14, 2014 10:01 am

Re: PC doesn't start

Post by 52ROSt » Mon Jan 07, 2019 2:12 am

@trytip
Thanks for trying to help me.

The PC is only installed.
I only ran a datarecovery program on an at least half empty SD card. 3 recovery files are in Documents.
The HHD of my PC has 500GB.
For Root I used about 38 GB and Home is the rest.
I initiated TimeShift during installation. As far as I remember, the storage of the TimeShift snapshot were originaly made into Root, I later changed /Home and subdirectory because /Home has about 450GB.

I will create a new LifeUSB Stick and see where TimeShift is.

BTW, can LM be installed again without reformating the HD? Could this be a possibility to repair the installation and keep the settings or at least most of them?

User avatar
52ROSt
Level 4
Level 4
Posts: 425
Joined: Mon Apr 14, 2014 10:01 am

Re: PC doesn't start

Post by 52ROSt » Mon Jan 14, 2019 9:02 am

I gave up on restarting the machine and reinstalled it. The installation was at the very beginning and I moved the few data into an external storage.

For me this entire post can be deleted to avoid garbage in the system.

User avatar
trytip
Level 11
Level 11
Posts: 3721
Joined: Tue Jul 05, 2016 1:20 pm

Re: PC doesn't start

Post by trytip » Mon Jan 14, 2019 10:49 am

so sorry for not responding, i don't pay attention some times. well you fixed it by making reinstall. you can go up to your first comment and click the edit button and make the title [SOLVED] at the end or beginning
in my very first installations 2010 mandriva they make you install in /root /home /swap partitions so i always the learn to make partitions before i install
with linux mint and ubuntu they don't make you use these partitions, everything is installed in one partition /root so when system breaks and you reinstall the normal operation in all linux is to format the /root before install so if your home folder is in one partition with the /root everything is lost
timeshift will undo things if they are bad like no start or shutdown
Image

User avatar
52ROSt
Level 4
Level 4
Posts: 425
Joined: Mon Apr 14, 2014 10:01 am

Re: PC doesn't start - [SOLVED]

Post by 52ROSt » Mon Jan 14, 2019 9:32 pm

@trytip

Thanks for getting back. I appreciate the help I get here in the LM forum very much. However I am also aware that all the answers are given by volunteers. Thus don't worry. I myself worked for a few year in the LibreOffice support forum. Here in LM I cannot do support....

Solved - done.

Even in Mint I use the 3 partitions /root, /swap and /home. With a 500GB drive I normally take 32-38GB for /root, double the RAM for /swap and use the rest for /home. I do this especially to protect my home partition if something happens and there are files which are not backed up externally.

Post Reply

Return to “Newbie Questions”