[Solved] Can't change mouse sensitivity.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Fri Feb 01, 2019 6:15 pm

[Solved] Can't change mouse sensitivity.

Post by lolakkalol »

Hi!, I just installed mint 19.1 Tessa and found out that my mouse sensitivity was not to my liking. I tried to change it in the "Mouse and Touchpad" settings, there it listed 2 devices with the exact same name (Name: "Logitech Gaming Mouse G402"). After that I tried to change the Acceleration and sensitivity on both the devices and nothing changed.
I then went onto the terminal. I used xinput --list and saw that there where 3 devices with the same name as my mouse. The result of the command:

Code: Select all

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G402              	id=11	[slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G402              	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Rift Sensor: CV1 External Camer         	id=9	[slave  keyboard (3)]
    ↳ Oculus Rift Audio                       	id=10	[slave  keyboard (3)]
    ↳ CHICONY USB NetVista Full Width Keyboard	id=13	[slave  keyboard (3)]
    ↳ Logitech Gaming Mouse G402              	id=14	[slave  keyboard (3)]
I tried to look at the properties of the devices every value was 0. I used xinput -list-props 11 and got this:

Code: Select all

Device 'Logitech Gaming Mouse G402':
	Device Enabled (148):	1
	Coordinate Transformation Matrix (150):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (285):	0
	libinput Natural Scrolling Enabled Default (286):	0
	libinput Scroll Methods Available (287):	0, 0, 1
	libinput Scroll Method Enabled (288):	0, 0, 0
	libinput Scroll Method Enabled Default (289):	0, 0, 0
	libinput Button Scrolling Button (290):	2
	libinput Button Scrolling Button Default (291):	2
	libinput Middle Emulation Enabled (292):	0
	libinput Middle Emulation Enabled Default (293):	0
	libinput Accel Speed (294):	0.000000
	libinput Accel Speed Default (295):	0.000000
	libinput Accel Profiles Available (296):	1, 1
	libinput Accel Profile Enabled (297):	1, 0
	libinput Accel Profile Enabled Default (298):	1, 0
	libinput Left Handed Enabled (299):	0
	libinput Left Handed Enabled Default (300):	0
	libinput Send Events Modes Available (270):	1, 0
	libinput Send Events Mode Enabled (271):	0, 0
	libinput Send Events Mode Enabled Default (272):	0, 0
	Device Node (273):	"/dev/input/event3"
	Device Product ID (274):	1133, 49278
	libinput Drag Lock Buttons (301):	<no items>
	libinput Horizontal Scroll Enabled (302):	1
If I changed the value for "Accel Speed" nothing happens. But if i change "Device Enabled" to 0, the mouse stops working (Big surprise i know but it says something).

I have no idea where to go from here and would love some help. :D

Here is my inxi -Fxz results:

Code: Select all

  Host: Yeagord Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Xfce 4.12.3 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
  Type: Desktop Mobo: ASRock model: Z77 Extreme4 serial: <filter> 
  BIOS: American Megatrends v: P2.90 date: 07/11/2013 
  Topology: Quad Core model: Intel Core i5-3570K bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27199 
  Speed: 1600 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1600 2: 1600 
  3: 1600 4: 1600 
  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics 
  vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: AMD Vega [Radeon RX Vega] driver: amdgpu v: kernel 
  bus ID: 03:00.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati,modesetting 
  unloaded: fbdev,radeon,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  renderer: Radeon RX Vega (VEGA10 DRM 3.23.0 4.15.0-20-generic LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.2 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: ASRock Z77 Extreme4 driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Device-2: AMD driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  Device-3: N/A type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 5-2.2:4 
  Sound Server: ALSA v: k4.15.0-20-generic 
  Device-1: Broadcom Limited NetLink BCM57781 Gigabit Ethernet PCIe 
  vendor: ASRock Z77 Extreme4 driver: tg3 v: 3.137 port: d000 
  bus ID: 06:00.0 
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  Local Storage: total: 1.24 TiB used: 10.34 GiB (0.8%) 
  ID-1: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB 
  ID-2: /dev/sdb vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB 
  ID-3: /dev/sdc vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  ID-1: / size: 219.05 GiB used: 10.34 GiB (4.7%) fs: ext4 dev: /dev/sdb2 
  System Temperatures: cpu: 30.0 C mobo: N/A gpu: amdgpu temp: 24 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
  Processes: 207 Uptime: 29m Memory: 15.55 GiB used: 1.57 GiB (10.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
Well after I got a good nights sleep I tried to set the 'Accel Speed' to negative numbers and and that worked for me :D
It did not even cross my mind at first to set it to negative numbers...
Though any value > 0 would not change my mouse sensitivity but values < 0 would lower my mouse sensitivity which is what I wanted!
Level 1
Level 1
Posts: 1
Joined: Fri Jul 10, 2020 2:56 pm

Re: [Solved] Can't change mouse sensitivity.

Post by tj2705 »

Thanks lolakkalol. I spent hours trying to figure this out. Finally realized I could enter negative numbers after reading your solution. Thanks for the updated solution.
Post Reply

Return to “Newbie Questions”