Copying from pc to usb flashdrive always fails

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 54
Joined: Sun Aug 19, 2018 2:48 am

Copying from pc to usb flashdrive always fails

Post by bradrar »

I am copying my files from my pc to usb. It is 10GB. However I am just at 8% of the transfer and my usb is saying that the transfer failed. Then my usb is ejected and I have to pull it out and push it in again so my pc can read the usb. and then I copy the file then fails again.

Please help

Level 4
Level 4
Posts: 297
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: Copying from pc to usb flashdrive always fails

Post by iironjade »

If your usb drive isn't formatted to NTFS then transferring large files will always fail. It happened to me and I had to call the manufacturer to find out what was going on. Reformatting to NTFS fixed it.
"A good many dramatic situations begin with screaming."

User avatar
Level 8
Level 8
Posts: 2020
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Copying from pc to usb flashdrive always fails

Post by BG405 »

I'd be interested to know if this solved the problem. It's the first time I've heard of the formatting being responsible for an issue like this; it evidently doesn't affect transfers to USB-connected hard disks at least in my case, so I am unsure why USB memory sticks would be any different (unless perhaps if it's a slow one). Something I'll have to try.

Are these large individual files, or a large number of files, or maybe both?
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

Post Reply

Return to “Newbie Questions”