[Solved] Window cutting off on right click

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

[Solved] Window cutting off on right click

Post by hpmc13 » Thu Feb 28, 2019 11:17 am

This is a little hard to describe so please bear with me.
Using LM 19.1 Cinnamon, dual monitors, (inxi to follow)
I have a bottom panel on my left (main) monitor (the one set to 1920x1080), set to auto-hide. If I open any application in a window (not maximized) and then double-click on the top or bottom resize handle the window will stretch top-to-bottom as expected. However, if I right-click on the application to get a context menu, then click on anything that brings up a dialogue box, the bottom of the application's window will get cut off by a few (10, 20, 30? not sure) pixels. Think of having Firefox open, right-clicking, choosing "Save Image As..." then having the dialogue come up. As soon as the dialogue pops up, the bottom of the window is cut off. This happens in any application under the same circumstances. LibreOffice Calc, for instance, will do the same thing by right-clicking, choosing "Delete..." It doesn't move the window or resize it, it cuts it off.
This does not happen with the other monitor even if I move the panel over to that monitor. It does not happen if the application is in a window, or maximized, or if I simply stretch it to the top and bottom; it's only if I double-click the top or bottom resize handle.
If I restart Cinnamon it all goes back to normal, until I right-click again.

Any help is greatly appreciated. I hope that I explained that all okay.

Code: Select all

inxi -Fzx
System:    Host: workpc Kernel: 4.18.0-14-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.9 
           Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
           Mobo: Gigabyte model: 990FXA-UD3 R5 v: x.x serial: <filter> BIOS: American Megatrends v: F2 date: 04/01/2015 
CPU:       Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 70729 
           Speed: 1841 MHz min/max: 1400/4400 MHz Core speeds (MHz): 1: 1406 2: 1406 3: 1405 4: 1405 5: 1405 6: 1406 7: 1406 
           8: 1405 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: ZOTAC driver: nvidia v: 415.27 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1280x1024~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Device-2: NVIDIA vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.18.0-14-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: 2.3LK-NAPI 
           port: c000 bus ID: 05:00.0 
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.31 TiB used: 740.81 GiB (55.2%) 
           ID-1: /dev/sda model: ZOTAC ZTSSD-A4P-120G size: 111.79 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-60WN4A0 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD3200AAJS-22B4A0 size: 298.09 GiB 
Partition: ID-1: / size: 29.34 GiB used: 15.04 GiB (51.3%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 28.84 GiB used: 6.67 GiB (23.1%) fs: ext4 dev: /dev/sda2 
           ID-3: swap-1 size: 1.99 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 33.0 C mobo: 30.0 C gpu: nvidia temp: 56 C 
           Fan Speeds (RPM): cpu: 0 fan-1: 764 fan-3: 0 fan-4: 1400 fan-5: 0 gpu: nvidia fan: 0% 
           Voltages: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.10 
Info:      Processes: 289 Uptime: 2h 14m Memory: 15.63 GiB used: 1.65 GiB (10.6%) Init: systemd runlevel: 5 Compilers: 
           gcc: 7.3.0 Shell: bash v: 4.4.19 inxi: 3.0.27 
Last edited by hpmc13 on Thu Feb 28, 2019 11:48 am, edited 1 time in total.
Running LM 19 Cinnamon

hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

Re: Window cutting off on right click

Post by hpmc13 » Thu Feb 28, 2019 11:47 am

Figured it out. Thought that I had tried everything, then something sort of rung a bell somewhere in the dim recesses of my brain.

Went to Settings->Windows->Behavior and turned OFF "Attach dialog windows to the parent window" Solved it for everything. All is well. I'll leave this here in case anyone else runs into it.
Running LM 19 Cinnamon

Post Reply

Return to “Newbie Questions”