fileSystem is full

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Actually looking at the output more closely seems you had mistyped the command, looks like you added a minus in front of the 100. :wink:

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Wed Mar 20, 2019 6:42 am
Actually looking at the output more closely seems you had mistyped the command, looks like you added a minus in front of the 100. :wink:
Ops sorry for my fault ...

Output :
17G /timeshift
856M /lib
152M /boot
4.1G /var
5.5G /usr
28G /

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Looks all ok except the overgrown timeshift folder, nuke that for now:

Code: Select all

sudo rm -rfv /timeshift
and then probably move it to the other partition. Also check the configuration, you're likely keeping too many old snapshots for it to grow that big.

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Wed Mar 20, 2019 6:57 am
Looks all ok except the overgrown timeshift folder, nuke that for now:

Code: Select all

sudo rm -rfv /timeshift
and then probably move it to the other partition. Also check the configuration, you're likely keeping too many old snapshots for it to grow that big.
Thank you . that command removed many files and after that was finished , i ran sudo reboot and after that login page was shown and i'm logged in to desktop .
But when i was writing this post , that message was shown again that Low Disk Space on filesystem . :(


What can i do ?
Attachments
Screenshot from 2019-03-20 16-13-13.png

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Run this again:

Code: Select all

sudo du / -hxd 1 -t 100M
My guess is it's Timeshift again and you're including something in the snapshots that you shouldn't, like your entire second partition maybe. Make sure you exclude its mount point via Timeshift's filters.

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Wed Mar 20, 2019 8:51 am
Run this again:

Code: Select all

sudo du / -hxd 1 -t 100M
My guess is it's Timeshift again and you're including something in the snapshots that you shouldn't, like your entire second partition maybe. Make sure you exclude its mount point via Timeshift's filters.

17G /timeshift
856M /lib
152 M /boot
4.2G /var
5.5G /usr
28G /


How i exclude its mount point ?
Although i've been installing Docker in Linux .
Is it possible this problem created because of installing docker ??

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Post output of

Code: Select all

lsblk
That'll show you all mount points.

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Wed Mar 20, 2019 9:38 am
Post output of

Code: Select all

lsblk
That'll show you all mount points.
Attachments
photo_2019-03-20_13-49-49.jpg

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Nothing there. It's something you must have added yourself to Timeshift's configuration, like your user folder.

You can copy & paste from a terminal window by the way. ;)

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Wed Mar 20, 2019 9:59 am
Nothing there. It's something you must have added yourself to Timeshift's configuration, like your user folder.
How to get what was i added in Timeshift's configuration ??
Because i don't know what i did ...
gm10 wrote:
Wed Mar 20, 2019 9:59 am
You can copy & paste from a terminal window by the way. ;)
I know :D
But i can't login to desktop again .
After that i posted that post which i took a screenShot from "filesystem" error , i rebooted system and i stuck in login loop again and now come here with windows .

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Well, same as before, nuke the timeshift folder, and then as I had already said, check Timeshift's configuration (Timeshift > Settings). Or just reset the configuration:

Code: Select all

sudo rm /etc/timeshift.json

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Wed Mar 20, 2019 10:43 am
Well, same as before, nuke the timeshift folder, and then as I had already said, check Timeshift's configuration (Timeshift > Settings). Or just reset the configuration:

Code: Select all

sudo rm /etc/timeshift.json
I ran reset configuration command and after that i rebooted system .
But problem dosen't solve . :(

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

Hi
My problem isn't solved yet . :( :( :(
I will thank you if you guide me.

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

I really got nothing to add, nuke /timeshift and change the configuration, that's all.

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Thu Mar 21, 2019 1:47 pm
I really got nothing to add, nuke /timeshift and change the configuration, that's all.
Via sudo rm /etc/timeshift.json command ?
can i remove timeshift again for logging in to desktop and when i log in to desktop , i change timeshift configuration in desktop ??
Is it possible ?

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Yes.

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

gm10 wrote:
Thu Mar 21, 2019 3:37 pm
Yes.
only way to reset timeshift configuration is sudo rm /etc/timeshift.json command ?
actually , when i log in to desktop , should i run that command in terminal ??
is it different output for running that command in desktop terminal area or ctrl+alt+F1 terminal area ?!!

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: fileSystem is full

Post by gm10 »

Code: Select all

sudo rm -rfv /timeshift /etc/timeshift.json
in whichever terminal you like.

rezza
Level 1
Level 1
Posts: 44
Joined: Sat Mar 16, 2019 4:42 am

Re: fileSystem is full

Post by rezza »

Hi again
I had nuke timeshift in ctrl+alt+F1 and after that i logged in to desktop like a charm .
When i logged , i opened timeshift application and a window was shown with "setup wizard" title .
I can choose two option of Snapshot Type ( RSYNC and BTRFS ) .
Which can i choose ?

User avatar
Larry78723
Level 7
Level 7
Posts: 1808
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: fileSystem is full

Post by Larry78723 »

rezza, choose RSYNC. At the Select snapshot location screen, choose a location that isn't your hard drive (the first selection). Then click the "Next" button and change the number of daily snapshots to 0. That will set up Timeshift to only make backups when you request it to make one.

Hope this helps.
Larry
Image

Post Reply

Return to “Newbie Questions”