Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
mateen619
Level 1
Level 1
Posts: 5
Joined: Tue Mar 26, 2019 12:56 pm

Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by mateen619 »

Hi there,
First of all, I was a newbie in Linux and messed up big time. Kindly help me. :(
I purchased a Dell XPS 15 9550 1-2 months ago and decided to run linux on it. Downloaded latest Linux Mint 19.1 from the website and without doing any research on how to properly install Linux tried to installed it.

BIGGEST MISTAKE I did was that I select the same drive to boot the Linux, on which I was installing the Linux. :( :( (
(i.e. both boot loader and linux /root directory was on same drive i.e. /dev/sda4)
As clearly mentioned NOT TO DO in this post:
https://help.ubuntu.com/community/Grub2/Installing

After the installation process was completed and I started my laptop, there was just BLANK SCREEN, NO DELL LOGO, NO VIDEO, NO BOOTLOADER, NO OPTION, NOT ANYTHING. :( :( The screen was just blank and completely black. :( :(

I visited local market for repair, and the repair persons were not well versed with the issue. The diagnosed that it was the issue of BIOS and flashing the BIOS will correct the problem, but there was still blank screen. They worked on the motherboard of the laptop but still the problem persist. Now they are saying that only replacing the motherboard will solve the problem.

Please let me know what to do?

Regards.
Last edited by mateen619 on Tue Mar 26, 2019 4:09 pm, edited 1 time in total.

User avatar
Larry78723
Level 7
Level 7
Posts: 1808
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by Larry78723 »

mateen, let me make sure I understand what you did. Did you transfer the file you downloaded to a bootable USB or burn it to a DVD before installing it? If so,we should be able to guide you thru recovering your Dell.

The first thing I want you to repeatedly press the F2 key after turning the power on and let us know what happens.

Larry
Image

mateen619
Level 1
Level 1
Posts: 5
Joined: Tue Mar 26, 2019 12:56 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by mateen619 »

Thank you so much for replying.
Yes, I did made a bootable usb and installed linux mint from it.... the worst mistake I did was that
I chose same device on which I was installing linux as "Device to boot loader installation" (i.e. both boot loader and linux /root directory was on same drive i.e. /dev/sda4)
As clearly mentioned NOT TO DO in this post:
https://help.ubuntu.com/community/Grub2/Installing

This only screen I get is when I press ""D"" while starting the laptop and it give me 4,5 different LED colors on the laptop, so maybe my screen is working.

However I tried pressing F2 repeatedly as well as holding it while turning on the laptop. Still nothing.....
No screen, no dell logo, no boot menu, not anything :(

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by kevin987 »

mateen619 wrote:
Tue Mar 26, 2019 1:41 pm
These are the thing that I did wrong:
1- Tried to do it manually (last option in disk partition screen)
2- Not created any SWAP drive
3- Not created any /home drive.... Just the one / directory
4- "BIGGEST MISTAKE": selected the same drive to boot the Linux, on which I was installing the Linux. :( :(
Someone with more experience can help you with the BIOS issues and why that happened.

I just wanted to start you off with the issues listed above.

1- If Linux Mint 19.1 is the only operating system you are going to use, you might be better off choosing the install to entire disk option.

2- You don't need a swap partition with Mint 19.1 as it uses something called swap file.

3- You don't need to create a /home directory, unless that's what you want. Installing the whole system to the / (root) partition is what a lot of people do. It will install a /home directory there. Don't forget to check the format box and to make the new partition(s) ext4.

4- When you reinstall to your USB flash drive, use GParted from the Live Session in the Menu / Administration area. You can identify the hard drives this way, /dev/sda or /dev/sdb.

Hope things work out for you.
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

mateen619
Level 1
Level 1
Posts: 5
Joined: Tue Mar 26, 2019 12:56 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by mateen619 »

Thanks kevin987 for your kind reply.
Actually, this was my first time on linux. So, I didn't know alot.
So maybe the first 3 points were okay.

Actually the 4th point is where I completely got off the rails. I have read everywhere after the incident and everywhere I was mentioned to not chose any other device for grub2 installation:
https://help.ubuntu.com/community/Grub2/Installing

But that was my mistake. I installed Linux on laptop from bootable USB, and now everything is just blank and there is no options to select. I am quite lost here.
The local repair person also said that it is BIOS related and they tried to flash different BIOS versions, but it was not resolved. Maybe they didn't had the right one or maybe it was a different issue. I don't know :(

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by kevin987 »

mateen619 wrote:
Tue Mar 26, 2019 3:57 pm
Actually the 4th point is where I completely got off the rails. I have read everywhere after the incident and everywhere I was mentioned to not chose any other device for grub2 installation:
https://help.ubuntu.com/community/Grub2/Installing
Yes always install Grub to the same drive you are installing Mint to. If you're installing to sda, then choose sda for the Grub, not sda1 or any of the other partitions if you have any.
But that was my mistake. I installed Linux on laptop from bootable USB, and now everything is just blank and there is no options to select. I am quite lost here.
The local repair person also said that it is BIOS related and they tried to flash different BIOS versions, but it was not resolved. Maybe they didn't had the right one or maybe it was a different issue. I don't know :(
I am not sure why your BIOS would be borked after a mistake installing Grub. How old is the laptop. Did the repair shop try replacing the BIOS battery?
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

User avatar
Larry78723
Level 7
Level 7
Posts: 1808
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by Larry78723 »

mateen, I'd like you to try doing the same thing you did with the F2 key but use the F12 key. That should take you to the pre-bios test screen.

Larry
Image

mateen619
Level 1
Level 1
Posts: 5
Joined: Tue Mar 26, 2019 12:56 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by mateen619 »

kevin987 wrote:
Tue Mar 26, 2019 4:12 pm

I am not sure why your BIOS would be borked after a mistake installing Grub. How old is the laptop. Did the repair shop try replacing the BIOS battery?
well the laptop is dell xps 15 9550 i7 7th gen....it is quite new....maybe released in 2017 i think.... and didn't replaced the battery but plugged out the battery cable and reinserted it again.
Larry78723 wrote:
Tue Mar 26, 2019 4:15 pm
mateen, I'd like you to try doing the same thing you did with the F2 key but use the F12 key. That should take you to the pre-bios test screen.
Did that but it is still the same old blank screen. I almost pressed and hold almost every button on the keyboard while turning the laptop on but still nothing... Only pressing "D" work and it just show 5 different color LED lights on the screen

User avatar
Larry78723
Level 7
Level 7
Posts: 1808
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by Larry78723 »

mateen, I'm afraid that's as far as I can try to help. I'm sure that there's someone on here that can be of more help. Be patient and don't lose hope. It might take some time for the right person to come along to help you.

Larry
Image

mateen619
Level 1
Level 1
Posts: 5
Joined: Tue Mar 26, 2019 12:56 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by mateen619 »

Larry78723 wrote:
Tue Mar 26, 2019 4:32 pm
mateen, I'm afraid that's as far as I can try to help. I'm sure that there's someone on here that can be of more help. Be patient and don't lose hope. It might take some time for the right person to come along to help you.
No problem, thank you so much..

SandyVirgina
Level 1
Level 1
Posts: 1
Joined: Sun Apr 07, 2019 5:31 pm

Re: Dell XPS 15 9550 Blank Screen after installation NO VIDEO, NO BOOT OPTION

Post by SandyVirgina »

I have the exact same computer. And almost exactly the exact same problem. No post. The video test at start up works. When I made my flashdrive I remember changing a few bios settings to get it to boot from USB. I think if I remember right I changed uefi and some other boot settings. Dell is telling me to send it in for service. I have tried every bios recovery option I could find. Really about to send it in. What's another few hundred bucks on a 2k+ laptop.

Post Reply

Return to “Newbie Questions”