Page 1 of 1

How to get curly brackets working with Macbook Pro keyboard

Posted: Thu Apr 04, 2019 9:33 am
by Ruuti
I am using Macbook pro scandic (Finnish) keyboard and I have the latest Mint 19.1 installed on Virtualbox. I can't find { } [ ] anywhere and I have no idea how to get those working. Normally on mac those signs can be find with Shift+Alt/option + 8 and 9. This makes me crazy :( I have selected Finnish and English language and keyboard is Macintosh, but still not working.

Thanks for helping me!

Re: How to get curly brackets working with Macbook Pro keyboard

Posted: Fri Apr 05, 2019 1:52 am
by bartszu
Way VBox ?
On Linux you can manually define any key on keyboard.
You can do your own custom keyboard layout if you wish.
Tons of tutorials in Google!!!

I use one myself.

https://www.google.com/search?q=linux+c ... 8&oe=utf-8

Re: How to get curly brackets working with Macbook Pro keyboard

Posted: Fri Apr 05, 2019 9:31 am
by magnus7
Finnish keyboard layout:
AltGr + 7 = {
AltGr + 0 = }
AltGr + 8 = [
AltGr + 9 = ]

AltGr in Mac is probably right option key.

Re: How to get curly brackets working with Macbook Pro keyboard

Posted: Fri Apr 05, 2019 8:06 pm
by bartszu
Man I don't know.
Here:
/usr/share/X11/xkb/symbols

Take lets say "fr" and redo if you don't use it, if you afraid to mess around "fi".
After rename it to "my" if you wish, they are text files.
With Linux you can do what you want, if you can write.

Problem you describing don't exist.
øøøøø°°°°°°èèèèèççççççç´´ùùùùù