How to re-install NetworkManager without internet connection

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 10
Joined: Thu May 07, 2009 9:03 am

How to re-install NetworkManager without internet connection

Postby spz444 » Sun Jul 12, 2009 6:34 pm


I uninstalled Network Manager to install WICD. But WICD is not working at all, doesn't even open, no system tray internet icon, nothing, and now I can't even reinstall Network Manager. So I have no internet connection as the ethernet one also failed. I probably unistalled something bad from the system.

I tried many things reading in forums but nothing works. I made today a fresh install of LM7 from a USB pen drive. I read that you can reinstall it from the CD so I thought I could find how to do it from the pendrive but I failed. I also downloaded the NetworkManager files from the web site but the compilation and installation failed. Also tried to get a .deb file but also failed. I also tried to recover the Network Manager files from the VAR archives but it is not there. I have tried lots of things going to Windows back and forth.

Can somebody help me? I don't even want Network Manager, I want WICD because I have lots of problems to make my Atheros AR5700EG work with NetManager. It can work as I got it before but now I am failing...

Please help. I am very new and understand little of this. Thanks.


User avatar
Level 7
Level 7
Posts: 1880
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: How to re-install NetworkManager without internet connection

Postby lagagnon » Sun Jul 12, 2009 7:34 pm

Maybe you could try getting your network back up without all the silly GUI stuff getting in the way ;-)
If this works you could then open package manager and get wicd or gnome-network-manager back.

So open a terminal and try this:

sudo ifconfig wlan0 up (or if you are using a wired network card: "sudo ifconfig eth0 up")

then test to see whether the Internet is working, and if so reinstall whatever network GUI stuff you want.

PS: many people make the mistake with WICD of not realizing that you must, with the first launch, get the daemon running, and then with the second launch you should see the little applet in the botttom right of the taskbar and you can only then open it up.

Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 12 guests