[SOLVED] Firefox 67 doesnt open my homepage at startup but often only a blank tab

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
carum carvi
Level 5
Level 5
Posts: 885
Joined: Sun Apr 16, 2017 11:44 pm

[SOLVED] Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by carum carvi » Tue May 21, 2019 11:11 pm

Firefox 67 doesnt open my homepage at startup but only a blank tab. When I select the homepage button on this blank tab it will open my homepage correctly.

When I change the settings for my homepage in Firefox to the standard settings, Firefox DOES start up correctly MOST of the time. But when I change my homepage to something else the same problem keeps reocurring: at startup of Firefox 67 I get only a blank tab.

I use Linuxmint 19 Cinnamon.
No add ons installed whatsoever. All updates installed. Fresh install of the system.
Last edited by carum carvi on Fri Jun 14, 2019 9:03 am, edited 1 time in total.

bjmh46
Level 3
Level 3
Posts: 178
Joined: Fri May 30, 2014 6:44 pm

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by bjmh46 » Wed May 22, 2019 6:20 am

Same here on mint 18.3 xfce--on 5 different laptops. Tried disabling addons, new profile--all the standard troubleshooting, but 90% of the time, firefox 67 opens with a blank tab. The other 10% of the time it opens the homepage set in preferences. Waiting for a fix though, rather than reverting to ff 66, although I did that as a temporary troubleshooting step on one machine. Startup was normal--homepage opened--as expected.
EDIT: I've found that setting my homepage to bing instead of google, it works every time I start the browser.

Now, please don't interpret this as a "rant", but Moxilla's obsession with having a new version every month has recently resulted in lots of minor (66.0.1...5) updates throughout the month. This is a minor PITA, but I DO like firefox so I stick with it & thank the Firefox developers. Maybe monthly version updates are a fact of life for browsers.

Regards
Bob

User avatar
Jolly Roger
Level 1
Level 1
Posts: 7
Joined: Wed May 22, 2019 9:22 am
Location: città di Rovato / BS - Italy

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by Jolly Roger » Wed May 22, 2019 9:39 am

Linux Mint and Kubuntu 18.04 LTS Problem with Firefox 67.0

Hi guys, same problem.

This morning I installed Firefox 67.0

And a problem has arisen, when starting Firefox, the page inserted in ( Custom addresses... ) is no longer loaded
but is loaded ( Blank page ) but if you restore ( Firefox start page (default) ) this is loaded without any problem.

I have performed various tests at home and in the laboratory, in the versions of Linux Mint and Kubuntu 18.04 LTS installed directly on the PC,
and in Virtual Machine versions all give the same problem, Linux Mint and Kubuntu 18.04 LTS ( blank page ).

I've also done several restorations of Firefox, but the problem reoccurs.

See screenshots:

https://imgur.com/ohe4Hbg

https://imgur.com/Y9rhlem

https://imgur.com/yitER4o

https://imgur.com/KGwZXhF

Translated with www.DeepL.com/Translator

wwfwng
Level 3
Level 3
Posts: 112
Joined: Tue Jul 24, 2012 9:19 pm

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by wwfwng » Wed May 22, 2019 10:09 am

Have you tried Waterfox or Palemoon?

User avatar
Jolly Roger
Level 1
Level 1
Posts: 7
Joined: Wed May 22, 2019 9:22 am
Location: città di Rovato / BS - Italy

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by Jolly Roger » Wed May 22, 2019 10:22 am

Hello, Wwfwng.
---
No I have not tried the indicated Browsers.

I've been using Firefox for years, and I feel good about it.

I trust that the problem will be solved, as happened
with the blocking and quarantining of add-ons
I've been having a lot of success lately.

It is a problem, negligible.
---
Hi, there.

missmoondog
Level 3
Level 3
Posts: 107
Joined: Wed Nov 07, 2018 9:17 am

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by missmoondog » Wed May 22, 2019 1:12 pm

hmm? very odd. i don't have any issues with firefox 67 doing anything like that on 2 windows 10, 1 windows 7, 4 mint 19.1 and 1 antix 17.4.1 machines. actually, my antix machine hasn't been update to version 67 yet. then again, i use a blank page for home and new tabs.

sorry no help :(

bjmh46
Level 3
Level 3
Posts: 178
Joined: Fri May 30, 2014 6:44 pm

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by bjmh46 » Wed May 22, 2019 5:14 pm

Did some more experimenting, and I'm convinced that it has to do with something in my profile and "https://www.google.com". I've got a workaround that I'm using now on all but two of the laptops in our home. Since google is set as my default search engine, I just opened preferences/home, then hit the + sign to add a tab, and selected "use current page". This gives me a fairly simple start page with a search box ready to type in a google search. I don't think I'll even miss the google doodles!
BTW, I've had to do the same on windows 7 loads that I occasionally boot, AND on my mint 19 loads that I maintain--so 18.3, 19, 19.1, and win 7 all have the same "problem". My wifes 18.3 mint machine, and her win7 laptop don't have the problem--different profile. I could create a new profile, but I would prefer not too. Too much configuration involved in tweaking my current profile! (maybe that's the problem, LOL).
Now, with all this messing around I discovered another more serious (for me) problem with ff67. I've always been able to transfer my .mozilla folder from my main os (mint 18.3 xfce), to any of the home folders on any other mint machine be it running 18.3 or 19 or 19.1. I was shocked when this failed to work.
That is, .mozilla from my mint 18.3 machine will not work on my mint 19 or 19.1 machines. I've done this successfully literally hundreds of times up til now, ff67 is the first time I've had this problem.

User avatar
lsemmens
Level 8
Level 8
Posts: 2263
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by lsemmens » Wed May 22, 2019 10:40 pm

It is an odd problem that I have yet to reliably find a cause or solution to.

My home page is an extension called "Group Speed Dial". Most times I open FF and it loads fine. Occasionally, however, FF forgets to load it. The "home" key seems not to work, but opening a new tab does. Once there, all seems well again.

I suspect that there is a small bug that occurs infrequently when something is updated or changed, just not consistently. I've rarely had to set my homepage in prefereneces again.
Kernel: 4.15.0-46-generic x86_64 bits
Desktop: Cinnamon 3.8.9
Distro: Linux Mint 19 Tara

Laptop HP-ProBook-470-G2 8Gb RAM SSD
Server AMD Phenom 9650 - GEForce 9400GT 6Gb RAM
+ three other Mint machines
Out of my mind - please leave a message

pbear
Level 6
Level 6
Posts: 1459
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by pbear » Thu May 23, 2019 2:00 am

FWIW, not having any problems. Also, not blowing up Firefox's User Group.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
Jolly Roger
Level 1
Level 1
Posts: 7
Joined: Wed May 22, 2019 9:22 am
Location: città di Rovato / BS - Italy

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by Jolly Roger » Thu May 23, 2019 8:34 am

Hi, there.
---
This morning, I installed in Virtual Machines, Ubuntu 19.04 and KDE Neon, If you run the updates,
the Default page loads without any problems, while if you enter in ( Personalized addresses... )
in my case ( https://www.qwant.com and https://www.startpage.com ) after the closure of Firefox 67.0
and when you restart the problem of the ( empty page ) reoccurs.

See screenshots:

https://imgur.com/Bs3mJBy

https://imgur.com/D2e7leu

https://imgur.com/7oO9jDx

https://imgur.com/Ry2oi1c
---
ATTENTION !!!

The problem occurred, without any configuration, only by changing the Default Page.
---
ATTENTION !!!

With Windows 10, various versions this problem does not occur.

I have downloaded several ISOs from ( partner.microsoft.com ), installed / updated and activated,
in Virtual Machines:

Windows 10 Professional 2019

Windows 10 Enterprise 2019

Windows 10 Enterprise LTSC 2019

Windows 10 Enterprise N LTSC 2019

Installed Firefox 67.0, changing ( Custom Addresses... ) the problem does not arise.

And even if I make my own changes, the problem does not occur.
---
Translated with www.DeepL.com/Translator

User avatar
vansloneker
Level 5
Level 5
Posts: 518
Joined: Sat Mar 17, 2018 6:10 am

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by vansloneker » Thu May 23, 2019 1:50 pm

I am always annoyed Firefox opens to somebody's homepage instead of about:blank
Returning to about:blank and leaving it to the user to set a homepage or not would be a great step in the development of Firefox.
Unless stated otherwise Mint 18.3-64 XFCE

===============================================================================================================================Image

carum carvi
Level 5
Level 5
Posts: 885
Joined: Sun Apr 16, 2017 11:44 pm

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by carum carvi » Sat Jun 08, 2019 1:17 pm

Two weeks later the same problem is still occuring.

The temporary solution I use is to simply press the HOMEPAGE button after startup of Firefox 67. One extra mouse click every time I start up Firefox 67

On another computer I dont have this issue, with exactly the same Linuxmint 19 Cinnamon OS.

Probably a bug of no concern? I read that since the "add ons disaster" Firefox devellopers wished to stop fixing bugs TOO quickly, because it could trigger other problems...

User avatar
vansloneker
Level 5
Level 5
Posts: 518
Joined: Sat Mar 17, 2018 6:10 am

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by vansloneker » Sat Jun 08, 2019 3:59 pm

Can you look into about:config and then browser.startup.homepage
What does it show?
If you change it into your homepage does it show your homepage on startup?
Unless stated otherwise Mint 18.3-64 XFCE

===============================================================================================================================Image

bjmh46
Level 3
Level 3
Posts: 178
Joined: Fri May 30, 2014 6:44 pm

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by bjmh46 » Sun Jun 09, 2019 6:35 am

After playing around with this problem since the update, I finally found the key. My habit has always been to clear history when firefox closes. (set in preferences). If the clear history checkbox is cleared, my google homepage displays as normal at startup. Or, if set to "use private browsing", it works fine. After all this, I've found that using a firefox blank tab as a homepage, and setting it to display only a search box (and the default firefox logo) I'm happier than when I used google with their totally annoying & distracting google doodles.

Bob

User avatar
Jolly Roger
Level 1
Level 1
Posts: 7
Joined: Wed May 22, 2019 9:22 am
Location: città di Rovato / BS - Italy

Re: Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by Jolly Roger » Fri Jun 14, 2019 8:57 am

With the New Version of Firefox 67.0.2, Mozilla solved the problem of the Empty Page,
as indicated in the ( Version notes ), see link:

https://www.mozilla.org/en-US/firefox/6 ... easenotes/

carum carvi
Level 5
Level 5
Posts: 885
Joined: Sun Apr 16, 2017 11:44 pm

Re: [SOLVED] Firefox 67 doesnt open my homepage at startup but often only a blank tab

Post by carum carvi » Fri Jun 14, 2019 9:04 am

Thanks for the link Jolly Roger! Glad to notice that the problem is taken care of by the Firefox devellopers.

Post Reply

Return to “Newbie Questions”