Mouse way too fast!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
waterbaby
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 10:38 am

Mouse way too fast!

Post by waterbaby »

Like so many others my mouse is way too sensitive in Linux Mint I have tried 3 different mice on the system and number 3 is almost slow enough only because it has adjustable DPI. A web search revealed a way to change the speed using the command line, only it won't work for me. All 3 mice are cordless and I keep getting the same list which doesn't make sense, and so I don't know what to work on. None of them work. Is this a problem with cordless mice?
Here is a a screenshot of what I tried last time in desperation, perhaps someone can tell me what I'm doing wrong or tell me which line represents my mouse.
Attachments
Screenshot from 2019-05-24 19-56-13.png

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

You might try using the id number instead of the device name in quotes.

waterbaby
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 10:38 am

Re: Mouse way too fast!

Post by waterbaby »

I have tried that too. Either I didn't do it right or that method doesn't work either. How much of the id number do I use ( just 9 or id=9) and is it in quotes?
I guess I need to know which one to work on since all the mice have shown the same list. AND is this problem related to my cordless mice?
Thanks for the reply!

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

Here's mine for a logitech wireless mouse:

Code: Select all

xinput  --set-prop  12  "Device Accel Constant Deceleration" 2.5
I've never bothered to automate this, after boot I ctrl-alt-t and hit the up arrow til the command appears and hit enter. I use a couple of different wireless mice, both logitech and microsoft and all require this tweak.

-set-prop should be preceded by -- not -

Bob
Last edited by bjmh46 on Sat May 25, 2019 4:31 pm, edited 1 time in total.

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

You don't mention your desktop environment, but in xfce, there is a slight anomaly with this procedure. Before I got the "xinput" thing to work, I set mouse acceleration to zero with the slider in the settings manager. When I tried using the code I pasted in my previous post, it had no effect! At zero acceleration, the mouse was almost, but not quite usable. After some experimentation, I discovered that if I set the acceleration slider to some positive value, the tweak worked fine. My accel slider is set to 2 FWIW. Doesn't really matter, since you can tune mouse performance with the deceleration value. Don't know if the above applies in other de's i.e.:cinnamon, mate or kde.
All of the above applies to mint 18.3 xfce. To get this to work on 19, had to remove libinput and install evdev.

Code: Select all

apt remove xserver-xorg-input-libinput

Code: Select all

apt install xserver-xorg-input-evdev
Hope this helps!

Bob

User avatar
freekvb
Level 1
Level 1
Posts: 10
Joined: Thu Jan 26, 2017 3:47 pm

Re: Mouse way too fast!

Post by freekvb »

Maybe this:

Code: Select all

xset m 'acceleration' 'threshold'
see:
http://xahlee.info/linux/linux_set_mouse_speed.html
there's no business like .. your own business ..

rickNS
Level 5
Level 5
Posts: 753
Joined: Tue Jan 25, 2011 11:59 pm

Re: Mouse way too fast!

Post by rickNS »

I have found the mouse speed to be pretty fast on fresh installs. ON mint 19 for sure, I don't recall what it was like on Mint 18, anyway,

Opening up the mouse preferences shows the speed to be set to the slowest level, however just moving the slider up a bit, and maybe back again has always fixed it.

I like the mouse to be quite fast, IE from left of screen to the right with about an inch, and a half to two inches of mouse movement.
Mint 19.0 mate on 2 identical Thinkpad T420's

waterbaby
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 10:38 am

Re: Mouse way too fast!

Post by waterbaby »

I'm using LM 19.1 Cinnamon 64 bit. I remember years ago trying to leave Windows and go to LM, the mouse was too fast then and the sliders had little to no effect on mouse speed and I had to use the command line. I thought that was surely fixed by now, but no.
I wound up going back to Windows because of what seemed like the constant need for typing in linux. I am disabled and linux presents me with some real challenges. The mouse movements have to be really slow and as I try to use the keyboard I have to look at each key and focus on it before I press it, this makes typing slow and tedious but I REFUSE to pay for the "privilege" of going to Win 10 and all it's spyware so there isn't much choice!
This time I can't seem to reduce the mouse speed no matter what I do. I'll just keep trying!

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

Waterbaby,
Are you using libinput or evdev? (see my previous post)

philgm
Level 1
Level 1
Posts: 4
Joined: Mon Aug 05, 2019 6:06 am

Re: Mouse way too fast!

Post by philgm »

Hello, I've been trying on and off for some time to adjust the mouse speed in different editions of LM. In Cinnamon, the sliders in the mouse section of system settings work fine, but have no effect in Mate or xfce, which mystifies me. Bob I tried your suggestion of replacing libinput with evdev, then xinput --set-prop 9 "Device Accel Constant Deceleration" 2.5 but am getting this message "property 'Device Accel Constant Deceleration' doesn't exist, you need to specify its type and format". This is in 19.2 by the way.

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

Hi philgm,
Sounds like you've got the wrong device number. Try the following:

xinput --list (to get device number e.g.:11) then:

xinput --set-prop 11 "Device Accel Constant Deceleration" 2.6 (11, & 2.6 are the numbers that I use, so substitute what works for you)

One caution though. If you have switchable graphics, that device number may change. On my dell latitude with nvidia graphics, if I boot with the nvidia enabled, I will have a different number for the mouse.

philgm
Level 1
Level 1
Posts: 4
Joined: Mon Aug 05, 2019 6:06 am

Re: Mouse way too fast!

Post by philgm »

Thanks for your response Bob. I did have the right device number so that wasn't the issue.

So I did a bit of experimenting and here's what I found. On my main desktop PC I had LM Cinnamon 19.2 installed. Using the commands you suggested worked fine - I was able to adjust the mouse speed by changing the numbers at the end of the line. On my laptop which is running LM xfce the commands didn't work at all with the mouse - it kept returning the response I mentioned before ie "property 'Device Accel Constant Deceleration' doesn't exist, you need to specify its type and format" - but they did work with the Touchpad.

I then wiped Cinnamon off the desktop PC and installed the xfce edition to see if was a problem specific to the laptop and now I am getting the same error message on the desktop PC. I'm wondering if its working in Cinnamon is connected to the fact that the slider controls in settings work OK in that environment but in xfce they don't, and neither do the command line options. I hope that makes sense.

In fact the mouse speed in xfce is useable, just rather faster than I would like and it would be nice to be able to tweak it.

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

Slider control for acceleration & sensitivity do exist in XFCE, under settings,mouse & touchpad. Are you using libinput or evdev? See my post above.

philgm
Level 1
Level 1
Posts: 4
Joined: Mon Aug 05, 2019 6:06 am

Re: Mouse way too fast!

Post by philgm »

I tried replacing libinput with evdev but that didn't make any difference. I know there are slider controls for acceleration and sensitivity in XFCE the same as Cinnamon but in my set-up at least they don't have any effect, which was my issue in the first place.

Code: Select all

xinput --list
produced this:

Code: Select all

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse         	id=9	[slave  pointer  (2)]
⎜   ↳ SEM USB Keyboard                        	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ SEM USB Keyboard                        	id=10	[slave  keyboard (3)]
    ↳ SEM USB Keyboard                        	id=12	[slave  keyboard (3)]
Mouse id is 9 so:

Code: Select all

xinput  --set-prop  9  "Device Accel Constant Deceleration" 2.5
which produces this:

Code: Select all

xinput  --set-prop 9 "Device Accel Constant Deceleration" 2.5
property 'Device Accel Constant Deceleration' doesn't exist, you need to specify its type and format
Following guidance in this post https://www.reddit.com/r/linux4noobs/co ... e/do4a9sh/

Code: Select all

xinput list-props 9
gives this:

Code: Select all

Device 'Logitech USB-PS/2 Optical Mouse':
	Device Enabled (140):	1
	Coordinate Transformation Matrix (142):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (277):	0
	libinput Natural Scrolling Enabled Default (278):	0
	libinput Scroll Methods Available (279):	0, 0, 1
	libinput Scroll Method Enabled (280):	0, 0, 0
	libinput Scroll Method Enabled Default (281):	0, 0, 0
	libinput Button Scrolling Button (282):	2
	libinput Button Scrolling Button Default (283):	2
	libinput Middle Emulation Enabled (284):	0
	libinput Middle Emulation Enabled Default (285):	0
	libinput Accel Speed (286):	0.000000
	libinput Accel Speed Default (287):	0.000000
	libinput Accel Profiles Available (288):	1, 1
	libinput Accel Profile Enabled (289):	1, 0
	libinput Accel Profile Enabled Default (290):	1, 0
	libinput Left Handed Enabled (291):	0
	libinput Left Handed Enabled Default (292):	0
	libinput Send Events Modes Available (262):	1, 0
	libinput Send Events Mode Enabled (263):	0, 0
	libinput Send Events Mode Enabled Default (264):	0, 0
	Device Node (265):	"/dev/input/event3"
	Device Product ID (266):	1133, 49216
	libinput Drag Lock Buttons (293):	<no items>
	libinput Horizontal Scroll Enabled (294):	1
So then:

Code: Select all

xinput --set-prop 9 "libinput Accel Speed" -0.5
and the mouse is now slowed down to a more amenable speed.

I haven't figured out yet how to get it to do this on reboot but this is a start.

Thanks for your help and suggestions Bob.

rene
Level 16
Level 16
Posts: 6283
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mouse way too fast!

Post by rene »

Please see viewtopic.php?f=18&t=298936&p=1666746#p1666453 for persistent configuration. The MatchProduct string should in your case be "Logitech USB-PS/2 Optical Mouse".

bjmh46
Level 4
Level 4
Posts: 231
Joined: Fri May 30, 2014 6:44 pm

Re: Mouse way too fast!

Post by bjmh46 »

As an alternative, I set up a keyboard shortcut (alt+m) that I hit as soon as the laptop boots. Not as elegant as what rene is referring to, but easy to change as I switch mice sometimes.

Bob

philgm
Level 1
Level 1
Posts: 4
Joined: Mon Aug 05, 2019 6:06 am

Re: Mouse way too fast!

Post by philgm »

Rene's method worked great. Thanks to you both.

vatin
Level 1
Level 1
Posts: 6
Joined: Tue Feb 22, 2011 8:36 am

Re: Mouse way too fast!

Post by vatin »

rickNS wrote:
Sun May 26, 2019 9:32 pm
just moving the slider up a bit, and maybe back again has always fixed it.
Thanks. This fixed my problem.

Lady Fitzgerald
Level 4
Level 4
Posts: 488
Joined: Tue Jan 07, 2020 3:12 pm
Location: AZ, SSA (Squabbling States of America)

Re: Mouse way too fast!

Post by Lady Fitzgerald »

vatin wrote:
Tue May 05, 2020 9:02 pm
rickNS wrote:
Sun May 26, 2019 9:32 pm
just moving the slider up a bit, and maybe back again has always fixed it.
Thanks. This fixed my problem.
Same here. Thanks!
Jeannie

Linux Mint Cinnamon 19.3 Cinnamon 64 bit
System 76 Serval WS (serw11) 17" Laptop

pcpunk
Level 5
Level 5
Posts: 929
Joined: Sun Jun 15, 2014 1:44 pm
Location: Florida

Re: Mouse way too fast!

Post by pcpunk »

vatin wrote:
Tue May 05, 2020 9:02 pm
rickNS wrote:
Sun May 26, 2019 9:32 pm
just moving the slider up a bit, and maybe back again has always fixed it.
Thanks. This fixed my problem.
Yes, for me too! Thanks for a simple solution as this issue is one of the most irritating that Linux has provided me in all the years I've been using it. Why in the world is it so hard to make one of the most popular mice work on linux????
HP Compaq nx7400, Cinnamon 19.2
Intel R Core™2CPU, T5500@1.66GHz, 4GB Crucial RAM
Super Clean Runs Perfect

Post Reply

Return to “Newbie Questions”