Page 1 of 1

(SOLVED) Mic not working Xonar DS Linux Mint

Posted: Sat Jun 01, 2019 10:58 am
by ovisergiu
My specs are in my signature ar MAIN.
AlsaMixer v1.1.1.3 shows me when pressing F6:
- default
- 0 Xonar DS
- 1 HDA Intel PCH
- 2HDA ATI HDMI

My PC has a audio+mic jacks on the tower case (front), the mainboard ones and I add a Xonar DS audioboard.
The first two work, but I want to record my voice using ther Xonar DS audioboard.
I have a headphone set with mic for gaming, and I plug in the audio jack (green one) and the mic jack (pink one) into their holes in the Xonar DS, and in the Sound Settings I see it and I chose the Analog Output or Headphones, but Analog seems to give better sound.
Screenshot from 2019-06-01 17-51-22.png
In the Input tab, I tried every each one of them but no sound is recorded at all... I tried Audacity, I tried some online webpage, and no sound is being recorded.
With other 2 mic jacks (from mainboard and tower case) everything works fine.
Screenshot from 2019-06-01 17-52-57.png
I have read the past 2 hours a lot of topics but I just did not manage to make my mic work.
In Alsamixer I press F6, I select XONAR DS, then F4, and there no matter what commands I press (I saw in Help some commands), nothing happends...
Screenshot from 2019-06-01 17-57-50.png
Where do I do wrong and what can I do so I can use my mic via XONAR DS?

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 11:28 am
by MrEen
Hi ovisergiu.

In alsamixer, stay on the first page after selecting the Xonar card, or press F3 if it's still open. You'll probably have a Mic option there as well that at the bottom will show MM meaning it it muted. Simply select the column then press the m key to unmute. Be aware that there are more options than what appears in the window on the screenshot you showed. See the column of little arrows on the right of the window in the "border"? That means there are more choices that you have to keep hitting the right arrow key to make visible, or increase the width of the window.

If that doesn't help, paste back the results from running amixer in the terminal. That should show all the mixer options available to you for the Xonar card.

Good luck.

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 11:55 am
by ovisergiu
MrEen, thank you mery much for your reply.
Here is a picture from the back. Did I insert the jacks correctly? (I started doubting that too)
xonar ds av 200.jpeg

I opened alsamixer, I selected Xonar card using F6, then I pressed F3, and here it is what I see (after expanding the window size:
Screenshot from 2019-06-01 18-49-30.png

Code: Select all

oks@oks-lm19-1-x64:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 2 [67%] [20.00dB]
  Front Right: 2 [67%] [20.00dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 [0%] [-64.00dB] [off]
  Front Right: Playback 0 [0%] [-64.00dB] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] [-64.00dB] [off]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] [-64.00dB] [off]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Line Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 46 [100%] [30.00dB] [on]
  Front Right: Capture 46 [100%] [30.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 0 [0%] [-16.00dB] [off]
  Front Right: Capture 0 [0%] [-16.00dB] [off]
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch'
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Front Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Rear Mic'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Rear Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Rear Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
oks@oks-lm19-1-x64:~$ 

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 12:44 pm
by MrEen
As far as I can tell, you've inserted the cables correctly.

I gave you the wrong amixer command, as I expected the Xonar to be card #0 based on your original post.

First see if unmuting Analog Input in alsamixer helps. If not, let's see the output of aplay -l please.

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 1:15 pm
by ovisergiu
OK, here it is:
In Sound Settings I noticed something: If I click on ”Analog Output CMI...” below at Output Profile there is only „Analog Stereo Input” available. If I click on „Headphones” then click back on ”Analog Output CMI 8788”, the Output Profile lists Analog Surround 4.0 Output, , Analog Surround 5.1 Output, Analog Surround 7.0 Output. Is it normal? What should I choose?

In the Input tab, what should I choose?
Microphone (CMI 8788 Oxygen HD Audio Virtuoso 66 Xonar DS)
or
Front Microphone CMI 8788 Oxygen HD Audio Virtuoso 66 Xonar DS

I mean I chose both, but no sound is recorded at all... The „Front” one was recording only when I connect the mic in the front jack of the tower case.

This is what Alsamixer shows after unmuting what you said:
Screenshot from 2019-06-01 20-07-58.png

Code: Select all

oks@oks-lm19-1-x64:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: DS [Xonar DS], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: DS [Xonar DS], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
oks@oks-lm19-1-x64:~$ 

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 1:32 pm
by MrEen
It's getting a little confusing here. Let's see amixer -c2 first.

I can't really say what's "normal" with the Sound Settings app as I don't have it. You might want to try PulseAudio Volume Control (pavucontrol) instead as it has more configuration options. I think some of the confusion is when you're selecting something, sometimes it not from the same sound card as the last thing selected, which is why the options change.

If you install pavucontrol, make sure the Configuration tab Profile for the Xonar is set for both input and output (duplex), then you should see something available on the Input Devices tab for the Xonar to use. Click on the check mark next to it to make it the default input device, then test to see if it's working.

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 1:40 pm
by ovisergiu

Code: Select all

oks@oks-lm19-1-x64:~$ amixer -c2
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right - Rear Left - Rear Right - Front Center - Woofer - Side Left - Side Right
  Limits: Playback 135 - 255
  Mono:
  Front Left: Playback 215 [67%] [-20.00dB] [on]
  Front Right: Playback 215 [67%] [-20.00dB] [on]
  Rear Left: Playback 215 [67%] [-20.00dB] [on]
  Rear Right: Playback 215 [67%] [-20.00dB] [on]
  Front Center: Playback 215 [67%] [-20.00dB] [on]
  Woofer: Playback 215 [67%] [-20.00dB] [on]
  Side Left: Playback 215 [67%] [-20.00dB] [on]
  Side Right: Playback 215 [67%] [-20.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 61 - 127
  Mono:
  Front Left: Playback 127 [100%] [on]
  Front Right: Playback 127 [100%] [on]
Simple mixer control 'Front Mic',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Line',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Mic',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Loopback',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Validity Check',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Aux',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'ADC Filter',0
  Capabilities: cenum
  Items: 'None' 'High-pass Filter'
  Item0: 'High-pass Filter'
Simple mixer control 'Analog Input Monitor',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 1
  Mono: Playback 1 [100%] [0.00dB] [on]
Simple mixer control 'Digital Input Monitor',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 1
  Mono: Playback 1 [100%] [0.00dB] [off]
Simple mixer control 'Input',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 165 - 255
  Front Left: Capture 165 [0%]
  Front Right: Capture 165 [0%]
Simple mixer control 'Level Control',0
  Capabilities: cenum
  Items: 'None' 'Peak Limiter' 'Automatic Level Control'
  Item0: 'None'
Simple mixer control 'Noise Gate',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Stereo Upmixing',0
  Capabilities: enum
  Items: 'Front' 'Front+Surround' 'Front+Surround+Back' 'Front+Surround+Center/LFE' 'Front+Surround+Center/LFE+Back'
  Item0: 'Front+Surround'
oks@oks-lm19-1-x64:~$ 

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 1:46 pm
by ovisergiu
First I saw this:
Screenshot from 2019-06-01 20-41-47.png
and this:
Screenshot from 2019-06-01 20-41-56.png
Then I set this as you said (duplex):
Screenshot from 2019-06-01 20-43-07.png

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 1:47 pm
by ovisergiu
And after setting the „duplex” I saw this:
Screenshot from 2019-06-01 20-43-24.png

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 1:48 pm
by MrEen
I'm pretty sure this is your issue:

Code: Select all

Simple mixer control 'Input',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 165 - 255
  Front Left: Capture 165 [0%]
  Front Right: Capture 165 [0%]
I think that'll be on the alsamixer then F4 page near the end to the right. Move it up with the up arrow at least half way then test.

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 2:06 pm
by ovisergiu
Entered Alsamixer, F6 and selected my Xonar, then F4, and in the Right Corner there is MIC (first) and the FrontMic (third). Presing Up Arrow does nothing for either Mic and FromMic.
Screenshot from 2019-06-01 21-04-10.png

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 2:08 pm
by MrEen
Sorry I wasn't clear. Raise the column that says Input.

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 2:34 pm
by ovisergiu
SUCCESS!
Thank you so very much, MrEen!
Is there something else I should do?

Re: Mic not working Xonar DS

Posted: Sat Jun 01, 2019 3:04 pm
by MrEen
All that's needed at this point is to edit your original post by clicking on the pencil icon and adding Solved to the Subject.

Happy I could help! :D

Re: (SOLVED) Mic not working Xonar DS Linux Mint

Posted: Mon Jun 03, 2019 8:52 am
by ovisergiu
MrEen, I want to ask you something more if it is possible:
In alsamixer - F4 - at INPUT I have set it to 70.
Some YouTube tutorial regarding best settings for voice recording via Audacity recommends the „70-80” for the microphone.
Is that 70 from Input the setting for the mic?

Re: (SOLVED) Mic not working Xonar DS Linux Mint

Posted: Mon Jun 03, 2019 4:06 pm
by MrEen
For your setup, I believe it might be. If pavucontrols Input Devices tab has Mic volume settings that have an effect, then you probably want Input in alsamixer at 100%, and 70-80% in pavucontrol. You might have to play around with it a bit to find what works best with your system.

Hope that helps.