External HD Issues

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 12
Joined: Tue Jul 09, 2019 2:50 am

External HD Issues

Post by BigH »

I visited this forum a week or two ago to get an XHD issue fixed. The fix worked fine. Thanks. Today, same XHD, new problem.

Running Linux Mint 19.0 Cinnamon. After my last fix I could read my files and access them but as it was late in the day for me, I shut my XHD down for another day. Today, I connected my new XHD to my Acer laptop and all the files appeared, and were accessible, but I could not write to the drive. Finally, I discovered that all permissions had been stripped from me - no permission to write. In exasperation, I reformatted the XHD into FAT32 (NTSB was another choice), thinking that this action would restore my permissions. NO such luck.

How do I restore the permissions of my new XHD so that I have complete control of the HD in All activities?

Thanks, Big H
Level 4
Level 4
Posts: 210
Joined: Sun Jan 25, 2015 3:35 pm
Location: Norway

Re: External HD Issues

Post by SprinterDriver »

You wiould want to take ownership of the drive.

How did you create the partition? If you did use Gparted for inscance, tha need to run as root and therefore normally only root have access to it.

To take ownership you should run:

Code: Select all

sudo chown -R bigh /media/bigh/whatevernameyougavethispartition
I put your username, and you change it for whatever username you're logged in as - and the name of the partition as well.
So I got this bright idea. But when I tried to grab the light bulb, I did not hurt my hands as expected from a warm bulb, because it turned out to be one of those LED bulbs.
Level 5
Level 5
Posts: 634
Joined: Mon Nov 19, 2007 3:27 pm

Re: External HD Issues

Post by ajgreeny »

You can not set permissions for a fat32 drive using chown or chmod; you will have to either allow the system to mount it automatically which will give it correct permissions, or set the mount options in the /etc/fstab file if it is mounted at boot up, and is always connected.

See https://askubuntu.com/questions/11840/h ... -partition for lots more detail.
Level 5
Level 5
Posts: 999
Joined: Sat Jul 15, 2017 9:57 pm

Re: External HD Issues

Post by jglen490 »

Is it really necessary to format the drive with NTSB or FAT? If you are not sharing the drive with Windows, it is unnecessary and just use ext4.
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB
Post Reply

Return to “Newbie Questions”