Cinnamon freezing after nvidia driver installation

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Joe1_vm
Level 1
Level 1
Posts: 2
Joined: Sat Aug 17, 2019 2:18 am

Cinnamon freezing after nvidia driver installation

Post by Joe1_vm » Sun Aug 18, 2019 5:10 am

Hello.
As absolute newbie I recently installed Linux Mint 19.2 Cinnamon on Lenovo SL500 with GeForce 9300M GS. Everything went relatively well up to the point, when the Nouveau driver was replaced by Nvidia driver (340.107 - 0ubuntu0.18.04.3) as was recommended by Driver manager.
Then the system started freezing after few minutes after restart.
It took me a while to discover that the issue is caused by the Nvidia Powermizer function, which change the performance level of the graphic card by stepping down the clock. It seems to work well in lower direction up to the point, when the lowest level is achieved. Than, if the system require to increase the frequency by some load (for example -opening, or closing the windows) the system will start freezing intermediately.
This issue does not happen if the PowerMizer is switched to "Prefer Maximum Performance" mode in NVIDIA X Server Setting. Than the system work nicely.
I have spent few days on this forum to find some workaround. I tried to create xorg.conf with

Code: Select all

Option  "Coolbits" "13"
Option  "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefaultAC=0x1"
in various locations like /usr/share/X11/ or /etc/X11/ , but still without success to load Maximum performance setting after system start.

So, any advice will be more than appreciated. Thank you.

User avatar
catweazel
Level 19
Level 19
Posts: 9232
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Cinnamon freezing after nvidia driver installation

Post by catweazel » Mon Aug 19, 2019 10:20 pm

Joe1_vm wrote:
Sun Aug 18, 2019 5:10 am
Hello.
As absolute newbie I recently installed Linux Mint 19.2 Cinnamon on Lenovo SL500 with GeForce 9300M GS.
That card dates back to 2009. That could be the root of the problem. Perhaps a BIOS update is called for. Nevertheless your post leaves out a lot of important information, so please post the output of this terminal command:

Code: Select all

inxi -Fxz
Enclose the results between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply. Note that it's a capital F in that command, followed by lower case xz. You can copy the text from the terminal screen by selecting it then right-clicking.

The information will help others to decide if they have the knowledge or experience to assist you.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Joe1_vm
Level 1
Level 1
Posts: 2
Joined: Sat Aug 17, 2019 2:18 am

Re: Cinnamon freezing after nvidia driver installation

Post by Joe1_vm » Tue Aug 20, 2019 12:43 am

Hello,
thank you for your reply.
The inxi output is

Code: Select all

System:    Host: joe-ThinkPad-SL500 Kernel: 4.15.0-58-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.3 
           Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: LENOVO product: 27464EG v: ThinkPad SL500 serial: <filter> 
           Mobo: LENOVO model: 27464EG v: LENOVO 6AET64WW serial: <filter> BIOS: LENOVO v: 6AET64WW date: 12/01/2010 
Battery:   ID-1: BAT0 charge: 52.9 Wh condition: 53.4/56.2 Wh (95%) model: SANYO 92P1127 status: Unknown 
CPU:       Topology: Dual Core model: Intel Core2 Duo T5870 bits: 64 type: MCP arch: Core Merom rev: D L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7979 
           Speed: 798 MHz min/max: 800/2001 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: NVIDIA G98M [GeForce 9300M GS] vendor: Lenovo driver: nvidia v: 340.107 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1680x1050~60Hz 
           OpenGL: renderer: GeForce 9300M GS/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.15.0-58-generic 
Network:   Device-1: Intel PRO/Wireless 5100 AGN [Shiloh] Network driver: iwlwifi v: kernel port: 6c00 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: 2.3LK-NAPI 
           port: e800 bus ID: 0c:00.0 
           IF: enp12s0 state: down mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 16.09 GiB (3.5%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
Partition: ID-1: / size: 36.41 GiB used: 14.47 GiB (39.7%) fs: ext4 dev: /dev/sda5 
           ID-2: /home size: 183.28 GiB used: 1.62 GiB (0.9%) fs: ext4 dev: /dev/sda7 
           ID-3: swap-1 size: 5.59 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 67 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 185 Uptime: 12m Memory: 3.85 GiB used: 1.52 GiB (39.4%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 
           Shell: bash v: 4.4.20 inxi: 3.0.32 
Finally I found the workaround on some forum - following command was added to startup application.

Code: Select all

/usr/bin/nvidia-settings -a "[gpu:0]/GpuPowerMizerMode=1"
This force the performance level to maximum since start.
Strange thing is that even if the following command is in the startup application as well

Code: Select all

sh -c '/usr/bin/nvidia-settings --load-config-only'
the setting from the config file is not loaded.
Thank you.

Post Reply

Return to “Newbie Questions”