Port 22 How to open it?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
bradleyrose
Level 1
Level 1
Posts: 1
Joined: Thu Aug 22, 2019 10:54 am

Port 22 How to open it?

Post by bradleyrose » Thu Aug 22, 2019 10:55 am

You might be right. I'm a newbie. One of the Gurus in this forum told me that iptables came in Mint enabled by default closing all ports. I also know that I used 'fish' in Konqueror with port 22 open from box with Ubuntu in to box with Suse 10.2, where I had to open port 22 in Firestarter. Since then I erased Suse and I installed Mint. When I tried the same from box with Ubuntu, it gave me error. In a word, I need guidance. All I want to do is transfer files. 'fish' in Konqueror, which I think is another expression of ssh, allowed me to do that. So, please help. Do I need to 'install' ssh in Mint?

User avatar
WharfRat
Level 21
Level 21
Posts: 13072
Joined: Thu Apr 07, 2011 8:15 pm

Re: Port 22 How to open it?

Post by WharfRat » Thu Aug 22, 2019 4:59 pm

Hello bradleyrose Image

Welcome to Linux Mint and the Linux Mint forum :)

Ports are open, it's a question if any process is listening on it.

Run pgrep sshd in the terminal. If you don't get any results then install sudo apt-get install openssh-server

You can also run nmap -p22 localhost to check if sshd is open.

Code: Select all

[bill@XPS] ~ $ nmap -p22 localhost

Starting Nmap 7.01 ( https://nmap.org ) at 2019-08-22 16:58 EDT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.000047s latency).
Other addresses for localhost (not scanned): ::1
PORT   STATE SERVICE
22/tcp open  ssh

Nmap done: 1 IP address (1 host up) scanned in 0.05 seconds
[bill@XPS] ~ $ 
Good luck :wink:
ImageImage

gm10
Level 18
Level 18
Posts: 8720
Joined: Thu Jun 21, 2018 5:11 pm

Re: Port 22 How to open it?

Post by gm10 » Thu Aug 22, 2019 5:09 pm

bradleyrose wrote:
Thu Aug 22, 2019 10:55 am
One of the Gurus in this forum told me that iptables came in Mint enabled by default closing all ports.
Then you were misinformed, the firewall is inactive by default. But you may have enabled it yourself, just check the Firewall Configuration tool from the menu (gufw).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

Post Reply

Return to “Newbie Questions”