Q. re safe install of plugins for MediaPlayer

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Marty Feldman
Level 1
Level 1
Posts: 32
Joined: Mon May 19, 2014 4:25 pm

Q. re safe install of plugins for MediaPlayer

Post by Marty Feldman » Fri Aug 23, 2019 12:31 pm

desktop computer, running LM19.1,Tessa, 4.15.0-20-generic x86_64

I have a couple of home movies I recorded onto the small size dvd discs (DVD-R format) using a Sony camcorder (Handycam). The discs play back fine in the camcorder. When I insert the discs into the DVD drawer of the computer, I get:
"Media Player requires pulgins to play media files of the following type: MPEG-2 System Stream demuxer"
Below that, 4 plugins are listed, the first two being checked:
"gstream1.0 plugins-bad"
-and-
"gstream1.0 pugins-bad (i386)"

I'm uneasy about that "bad". Is it safe to go ahead and click the INSTALL button for these two plugins so that I can, hopefully, view the vids on my monitor?

Thanks, as always.
-Marty-

jglen490
Level 5
Level 5
Posts: 625
Joined: Sat Jul 15, 2017 9:57 pm

Re: Q. re safe install of plugins for MediaPlayer

Post by jglen490 » Fri Aug 23, 2019 12:38 pm

The term "bad" does not imply evil or nefarious. Instead they refer to the fact that they support media types that are not typically open source. They work very well. When you plug them in, there will be NO black helicopters circling overhead nor will your PC blow up or have to leave the country :D
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

Marty Feldman
Level 1
Level 1
Posts: 32
Joined: Mon May 19, 2014 4:25 pm

Re: Q. re safe install of plugins for MediaPlayer

Post by Marty Feldman » Fri Aug 23, 2019 3:34 pm

Thanks jglen490. OK, I installed the 2 plugins from the "bad" set, I thought successfully. DVD still would not play, and the message onscreen said I needed to install the following 2 additional plugins, from the "ugly" set, to support the multimedia feature "DVD source":
"gstream1.0-plugins-ugly"
-and-
"gstream1.0-plugins-ugly(i386)"

This time, no sign of anything appearing after clicking INSTALL and giving my authentication PW. Just a black window onscreen, no lights flashing on computer. Reinserting the disc just gave the same message about needing to install the two "ugly" plugins.
I did a shutdown/restart and tried the disc again. This time, it wanted me to once again install the original 2 plugins from the "bad" set that I thought I had installed previously. The two "ugly" plugin optionss did not appear. Hitting INSTALL again did nothing. On screen there was a "Playlist" whose only entry is what I take to be the identity of the disc including its date of manufacture - "2006_01_01_12HOOM_AM".
Disc still plays in the camcorder, not on computer.

-Marty-

Post Reply

Return to “Newbie Questions”