cannot disable sleep/suspend

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
unit_1
Level 1
Level 1
Posts: 8
Joined: Wed Aug 22, 2018 1:23 pm

cannot disable sleep/suspend

Post by unit_1 » Fri Aug 23, 2019 12:49 pm

So I uppgraded from 19.1 to 19.2 without a hitch, but encountered a problem.

After a short period of disuse my system suspends, at least thats what I think is happening, as I have to "wake it up" by pressing the space bar on the keyboard.

Now the previous 19.1 had hibernate disabled and none of the power/screensaver settings were set to put the systsem or monitor to sleep and everything was fine. So I followed the instructions, after updating to 19.2 (10 things to do after installing mint) and removed the suspend option which in now absent in the shutdown options dialog box.
So, no sleep/hibernate/suspend options set for shutdown, no sleep options set in screensaver and power options in system settings, hibernate/suspend disabled and it still goes to sleep, I hav'nt calculated the length of time it takes to happen yet but would appreciate any help in trying to figure out whats going on. Thanks in advance.

User avatar
majpooper
Level 5
Level 5
Posts: 909
Joined: Thu May 09, 2013 1:56 pm
Location: North Carolina, USA

Re: cannot disable sleep/suspend

Post by majpooper » Fri Aug 23, 2019 2:35 pm

Have you gone through System Settings ?

This works for me - I always check Screesaver Settings and turn off "Lock the computer when put to sleep" and "Lock the computer after screensaver starts"
Then I go to Power Management and set "Turn off the screen when inactive for" to Never and "Suspend when inactive for" to Never

unit_1
Level 1
Level 1
Posts: 8
Joined: Wed Aug 22, 2018 1:23 pm

Re: cannot disable sleep/suspend

Post by unit_1 » Fri Aug 23, 2019 2:57 pm

Yes, I have done all that you mention and even have hibernate and suspend disabled altogether, but there must still be some config file or something causing this. Like I said this only happened after updating to 19.2, but I don't know enough to diagnose the problem forensically.

all41
Level 15
Level 15
Posts: 5546
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: cannot disable sleep/suspend

Post by all41 » Fri Aug 23, 2019 5:45 pm

Perhaps the monitor itself is sleeping due to EnergyStar compliance.
Try running these lines in a terminal:

Code: Select all

xset s 0 0

Code: Select all

xset -dpms; xset s off
If that alleviates the issue you can implement a startup script
to run these

unit_1
Level 1
Level 1
Posts: 8
Joined: Wed Aug 22, 2018 1:23 pm

Re: cannot disable sleep/suspend

Post by unit_1 » Sat Aug 24, 2019 1:11 pm

Thank you for your suggestion, I will try that, perhaps you could elaborate on what those settings are/do.

all41
Level 15
Level 15
Posts: 5546
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: cannot disable sleep/suspend

Post by all41 » Sat Aug 24, 2019 10:22 pm


unit_1
Level 1
Level 1
Posts: 8
Joined: Wed Aug 22, 2018 1:23 pm

Re: cannot disable sleep/suspend

Post by unit_1 » Sun Aug 25, 2019 11:05 am

Hi, thank you for your input, I have disabled DPMS and confirmed it is disabled, will post back if it works.

unit_1
Level 1
Level 1
Posts: 8
Joined: Wed Aug 22, 2018 1:23 pm

Re: cannot disable sleep/suspend

Post by unit_1 » Sun Aug 25, 2019 6:28 pm

It appears that disabling dpms in not the solution.

Post Reply

Return to “Newbie Questions”