Asking for password when booting from USB

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Asking for password when booting from USB

Post by Zenryoku »

Hi all,

I'm being asked to enter a username and password. I've tried "mint" for the username and no password. I've never installed Linux on this computer in the past.
I've Googled this and this is apparently a known issue when using the Live version, but I'm booting from a USB drive with the intent to do an installation on my SSD alongside Windows 10.

I'd like to be able to delve into this realm, but this is a bit of a wall.

Any help is appreciated.
User avatar
catweazel
Level 19
Level 19
Posts: 9883
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Asking for password when booting from USB

Post by catweazel »

Zenryoku wrote:
Fri Aug 30, 2019 9:18 pm
Any help is appreciated.
I'd suggest re-writing the USB media from a fresh iso.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

I'll try, but I just reformatted this USB drive and installed the ISO on it with Rufus. I'll repeat that and try again.
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

That did not work. I tried reformatting the drive and reinstalling a fresh ISO from a different mirror. Same issue. When I try entering "mint" as the username and then no password, the screen goes blank for a few moments, then pops right back to that screen.
pbear
Level 15
Level 15
Posts: 5662
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Asking for password when booting from USB

Post by pbear »

Is secure boot enabled? If so, try again with it turned off.

FYI, Mint usually is okay with secure boot, because it piggy-backs on Ubuntu's certification, but reportedly stumbles on some firmware.
User avatar
zcot
Level 6
Level 6
Posts: 1396
Joined: Wed Oct 19, 2016 6:08 pm

Re: Asking for password when booting from USB

Post by zcot »

you're not entering "mint" are you? as opposed to mint.

You shouldn't be required any password to simply boot the usb live session.

Is the system giving you a complete text screen. -full black screen with the login prompt at upper left? Is that after seeing a Mint logo.. maybe interrupt the initial countdown timer when it starts to boot, just press any key. They boot using compatibility mode.
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

I'll try disabling Secure Boot.

I'm entering "mint" without the quotes. It's a graphical UI with the Mint wallpaper as well as a clock, restart/shutdown controls, etc. The login dialog is on the far left side of the screen about half-way up. When I type the username and then enter-through the password, the screen blanks out for a few moments and then goes back, asking for the username again.
pbear
Level 15
Level 15
Posts: 5662
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Asking for password when booting from USB

Post by pbear »

Would it be possible to snap a photo, upload to a hosting service and link here? If so, please enclose the link with [rimg] and [/rimg] so it will display as a clickable thumbnail. BTW, secure boot is just a stab in the dark. Harmless to try and maybe get lucky.
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

Here are the pictures I took...
Image
Image
Image
Image

I interrupted the countdown and tried loading Compatibility Mode, which did work. However, the installer said that it couldn't detect any other operating systems (Windows 10 is on my boot drive) and the only other option was to start manually messing around with partitions, which I really don't feel comfortable with. I was able to determine which drive I want to install it on, which is my second hard drive, but I'm not really sure how to do that manually.

Hopefully the images will help.
User avatar
Pierre
Level 20
Level 20
Posts: 11271
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Asking for password when booting from USB

Post by Pierre »

that does seem like an Compatibility Mode issue, but you still shouldn't get that Log-In screen,
- unless the screen_saver kicks in, after 5 Min - - which is way too short - - that's adjustable in power settings.

if the Installer still can't see that win-10, then check that both systems are in the same boot mode:
- typically UEFI & 64 bit for win-10, so the LinuxMint must match that.

also use Gparted on the LinuxMint Live Media to see if that can see that windows partition(s).
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

I am selecting the UEFI option in regards to the flash drive when I'm in the boot menu. I'll try compatibility mode and look for Gparted.

I also took a picture of this just before it gets to the that screen. It happened so quickly before that I didn't really get a good look at it, but it could be relevant. Especially that last line of text.
Image
pbear
Level 15
Level 15
Posts: 5662
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Asking for password when booting from USB

Post by pbear »

Zenryoku wrote:
Sat Aug 31, 2019 1:27 am
I interrupted the countdown and tried loading Compatibility Mode, which did work.
That's a huge step forward. To test boot mode as Pierre suggests, open Terminal and run run ls /sys/firmware (that's an "L", ls = list). If “efi” is listed, you are booted in UEFI mode. If not, well, you aren't.

BTW, would appreciate if someone could explain how to do the rimg tags, as I seem to recall it incorrectly.
User avatar
Moem
Level 20
Level 20
Posts: 12377
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Asking for password when booting from USB

Post by Moem »

pbear wrote:
Sat Aug 31, 2019 12:04 pm
BTW, would appreciate if someone could explain how to do the rimg tags, as I seem to recall it incorrectly.
Like so:
[rimg]https://link to an image somewhere on the net[/rimg]
If it doesn't work, check whether you are using the link to the image itself, and whether it's https.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
pbear
Level 15
Level 15
Posts: 5662
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Asking for password when booting from USB

Post by pbear »

Thank you! I was indeed forgetting an important detail. So, Zenryoku, you need to use the direct link to the image, not the webpage. Here, I got that by going to your link, right-clicking the image and (in Firefox) selecting "Copy image location." To illustrate, this is what the code should look like.

[rimg]https://i.imgur.com/ZyJfYJ0.jpg[/rimg]

Image
User avatar
zcot
Level 6
Level 6
Posts: 1396
Joined: Wed Oct 19, 2016 6:08 pm

Re: Asking for password when booting from USB

Post by zcot »

is that a really new pc? might need that newer 5.0 kernel after you get it installed, so the thing will act right.

anyway compatibility mode uses these boot parameters: xforcevesa nomodeset b43.blacklist=yes noapic noacpi nosplash irqpoll

It would likely boot to a less than preferred graphics mode since xforcevesa(which is fixable later though).

But maybe that noacpi is the interesting one right now.

You can use compatibility to do the install since that's convenience, then after install you'll have to figure out what boot parameter to throw at it, so you can then get in and fix up the situation, maybe get one of the newest kernels if this is a very new pc. Deal with any graphics driver issue or something. And then it will be fine to easily boot without jumping through any hoops.

But don't do the install until you see it acknowledge the Win10 system.

There's some issues in Win10, like turning off fast startup, take off any hibernation. reboot then use shutdown(not restart). I don't know the details too specifically, but you need to boot into Win10 and make those changes. Someone's got a good guide for dual boot with Win10 install.

Of course as mentioned making positive sure you are booting the Mint live session in UEFI mode as well.

And check out the Cinnamon Release Notes, there's a section near the bottom about "Solving Freezes" during the boot process, and that will give a good example of manually adding any kernel boot parameter(because after install you don't get a "compatibility mode" so might have to add in noapic probably at the least).

Boot the live session and copy/paste this terminal command and show us the info: inxi -Fxxxrz
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

Okay, so some interesting stuff. Here's a picture of my boot options when I press F12 at the POST screen:
Image

There are two options for booting from the flashdrive. The obvious choice here is the "UEFI" one, but even if I pick Compatibility Mode, it puts me back to the GUI login screen. If I pick the non-UEFI option, I can boot into Compatibility Mode without issue into a lower-res GUI that allows me to install Mint. As expected, when I went into the terminal and typed "ls /sys/firmware", EFI was not listed...I got this "acpi dmi memmap". I would guess that if I were able to successfully boot into Compatibility Mode from the UEFI option, it might show what I want.

Also, the results for "inxi -Fxxxrz" are as follows:

Code: Select all

System:
  Host: mint Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.3 wm: muffin 4.2.2 dm: LightDM 1.26.0 
  Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Gigabyte product: Z370 AORUS Gaming WIFI v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: Z370 AORUS Gaming WIFI-CF v: x.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F1 date: 09/21/2017 
CPU:
  Topology: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76608 
  Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 801 2: 801 
  3: 800 4: 801 5: 801 6: 801 7: 800 8: 801 9: 801 10: 800 11: 800 12: 800 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: eVga.com. driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:1b82 
  Display: x11 server: X.Org 1.19.6 driver: vesa resolution: 1024x768~61Hz 
  OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.2 
  compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GP104 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Device-3: Blue Microphones type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-8.1.3:14 
  chip ID: b58e:6e77 serial: <filter> 
  Sound Server: ALSA v: k4.15.0-54-generic 
Network:
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 
  bus ID: 08:00.0 chip ID: 8086:3165 
  IF: wlp8s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 7.80 TiB used: 1.91 GiB (0.0%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS512G1X0C-00ENX0 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: B35500WD 
  scheme: GPT 
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HDN728080ALE604 
  size: 7.28 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: W91X temp: 37 C scheme: GPT 
  ID-3: /dev/sdb type: USB vendor: Transcend model: JetFlash Transcend 64GB 
  size: 58.84 GiB serial: <filter> rev: 1100 scheme: MBR 
Partition:
  ID-1: / size: 7.81 GiB used: 26.3 MiB (0.3%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Repos:
  Active apt repos in: /etc/apt/sources.list 
  1: deb cdrom:[Linux Mint 19.2 _Tina_ - Release amd64 20190729]/ bionic contrib main non-free
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tina main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 273 Uptime: N/A Memory: 15.61 GiB used: 661.7 MiB (4.1%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash 
  v: 4.4.19 running in: gnome-terminal inxi: 3.0.32 
mint@mint:~$ =
Last edited by WharfRat on Sat Aug 31, 2019 11:52 pm, edited 1 time in total.
Reason: Added code tag
User avatar
zcot
Level 6
Level 6
Posts: 1396
Joined: Wed Oct 19, 2016 6:08 pm

Re: Asking for password when booting from USB

Post by zcot »

So that Nvidia card is probably going to require booting with the nomodeset parameter at the least.
https://www.linuxmint.com/rel_tina_cinnamon.php

I would use etcher to create the usb iso. You need it to be able to start in UEFI mode.
https://www.balena.io/etcher/
Zenryoku
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2019 9:13 pm

Re: Asking for password when booting from USB

Post by Zenryoku »

Using "nomodeset" seems to have done the trick! Mint is installed, nVidia drivers have been installed and now I just have to tweak a few things...and hopefully get my games working. :)

The audio output that I normally use, which is just a 3.5mm cable that goes to RCA jacks on my receiver isn't being detected, which I'd guess means that I need to try and find motherboard drivers for Linux. At the moment, it's pulling audio from the HDMI connection through my TV. Better than nothing until I can resolve it.

Thanks very much to everyone who helped. :)
User avatar
zcot
Level 6
Level 6
Posts: 1396
Joined: Wed Oct 19, 2016 6:08 pm

Re: Asking for password when booting from USB

Post by zcot »

Great news!

Drivers are typically available with the kernel. -even gpu drivers, unless you're choosing something proprietary like the Nvidia driver. But audio is ready in the kernel too, so you don't typically go digging around for drivers like you would on a Windows pc.

Check in the audio settings. check configuration. You probably have analog and digital sources, and since hdmi, then digital will be used as default audio output. But that jack is analog.

You're off to a good start anyway. ;)
pbear
Level 15
Level 15
Posts: 5662
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Asking for password when booting from USB

Post by pbear »

Congratulations! By the way, a two year old system should be fine with the current kernel, so probably no need to worry about that.
Post Reply

Return to “Newbie Questions”