SOLVED - the destination is read only

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

SOLVED - the destination is read only

Post by MintyMorkyMindy »

LM 19.2 dual boot with Win10, error message when attempting to copy over files, from LM19.2 to Win 10, and unable to delete Win 10 files from within LM19.2.

The error message is "the destination is read only".
Last edited by MintyMorkyMindy on Fri Sep 13, 2019 6:32 am, edited 1 time in total.
Linux Mint since 5 October 2014 :D
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: SOLVED - the destination is read only

Post by MintyMorkyMindy »

SOLVED

Assuming that the Win10 drive has the appropriate read/write permission settings, the likely problem is Win10 based.

It relates to Win10 default setting of "fast boot". Even when "fast boot" has been previously disabled, Win10 may re-enable such for various reasons, such as an update.

To solve this, boot up Win10 and then navigate to the Power Settings, specifically "Define power buttons ..."

There is a heading there "Shutdown settings", and underneath there is an option called "Turn on fast start up (recommended)" ... turn that off, by unticking the box. Also untick the "Hibernate" box.

Once this is done, shut down Win10. Do not reboot, but shut down Win10.

When the computer off, restart and boot LM19.2.

You should now have access within LM19.2 to copy/delete etc files to the Win10 drive.

Note:

As Win10 is a bit of a maze to find settings, you may want to google for a diagram where these settings are.
Linux Mint since 5 October 2014 :D
Kalki
Level 1
Level 1
Posts: 1
Joined: Sun Aug 26, 2018 9:46 am

Re: SOLVED - the destination is read only

Post by Kalki »

MintyMorkyMindy wrote:
Fri Sep 13, 2019 6:31 am
SOLVED

Assuming that the Win10 drive has the appropriate read/write permission settings, the likely problem is Win10 based.

It relates to Win10 default setting of "fast boot". Even when "fast boot" has been previously disabled, Win10 may re-enable such for various reasons, such as an update.

To solve this, boot up Win10 and then navigate to the Power Settings, specifically "Define power buttons ..."

There is a heading there "Shutdown settings", and underneath there is an option called "Turn on fast start up (recommended)" ... turn that off, by unticking the box. Also untick the "Hibernate" box.

Once this is done, shut down Win10. Do not reboot, but shut down Win10.

When the computer off, restart and boot LM19.2.

You should now have access within LM19.2 to copy/delete etc files to the Win10 drive.

Note:

As Win10 is a bit of a maze to find settings, you may want to google for a diagram where these settings are.
Update:
I had the same problem with NTFS partition. I applied your fix & hey presto!

It worked beautifully, thank you.
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: SOLVED - the destination is read only

Post by MintyMorkyMindy »

Work around ... if the above doesn't work. Thinking outside the box.

In some instances both LM19.2 and Win10 work, but accessing Win 10 from within LM19.2 doesn't, for example "read only file system".

This solution requires space on a SDD/HDD that does not contain Win10.

Using gparted within LM19.2, create a new NTFS primary drive space. Use this to transfer files. Both LM19.2 and Win10 can read this, and Win10 OS has NO power to mess with this, so a safe and reliable solution.

For example:

I have LM19.2 on a SDD, and Win10 on another SDD. I have a 1GB external HDD. I cannot access Win10 within LM19.2, and all settings are correct to the best of my knowledge. Using gparted I allocated about 150GB NTFS primary on the 1GB external HDD, with the remainder remaining ext4.

LM19.2 can access this and transfer files, and within Win10, the 150GB drive space can also be accessed. What is nice about this, is that Win10 has no power SNAFU, which it tends to do.
Linux Mint since 5 October 2014 :D
Post Reply

Return to “Newbie Questions”