Page 1 of 1

Terminal takes ~ 1 sec to load

Posted: Sun Sep 22, 2019 3:15 am
by james-r
I noticed that after installing Mint 19.2 Cinnamon, the terminal would load instantly.
Now after having synced 200 MB of files from Dropbox it takes ~1 sec or so for

Code: Select all

name@hostname
to show up on terminal.
What is the reason for this?

Re: Terminal takes ~ 1 sec to load

Posted: Sun Sep 22, 2019 4:38 am
by Pjotr
Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.

Re: Terminal takes ~ 1 sec to load

Posted: Sun Sep 22, 2019 4:43 am
by james-r

Code: Select all

user@guest:~$ inxi -Fxz
System:    Host: guest Kernel: 4.15.0-64-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.4 
           Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: LENOVO product: 20AW007QMD v: ThinkPad T440p serial: <filter> 
           Mobo: LENOVO model: 20AW007QMD v: 0B98401 WIN serial: <filter> UEFI [Legacy]: LENOVO v: GLET99WW (2.53 ) 
           date: 05/21/2019 
Battery:   ID-1: BAT0 charge: 43.3 Wh condition: 54.4/56.2 Wh (97%) model: SANYO 45N1769 status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i5-4300M bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20751 
           Speed: 1097 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 1097 2: 1098 3: 1097 4: 1098 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo ThinkPad T440p driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Lenovo ThinkPad T440p driver: snd_hda_intel 
           v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo ThinkPad T440p driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.15.0-64-generic 
Network:   Device-1: Intel Ethernet I217-LM vendor: Lenovo ThinkPad T440p driver: e1000e v: 3.2.6-k port: 3080 bus ID: 00:19.0 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: efa0 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 119.24 GiB used: 11.17 GiB (9.4%) 
           ID-1: /dev/sda vendor: LITE-ON IT model: LCS-128L9S size: 119.24 GiB 
Partition: ID-1: / size: 45.59 GiB used: 11.17 GiB (24.5%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 197 Uptime: 6m Memory: 3.55 GiB used: 1.15 GiB (32.4%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 
           Shell: bash v: 4.4.20 inxi: 3.0.32 

Re: Terminal takes ~ 1 sec to load

Posted: Sun Sep 22, 2019 4:52 am
by Pjotr
Strange.... A modern and powerful machine like that, shouldn't behave in that way.

You might try this:
Update Manager - panel: View - Linux kernels
Install the latest kernel of the 5.0 series. Then reboot.

When no avail, do this:
https://easylinuxtipsproject.blogspot.c ... html#ID5.1
(item 5.1)