Page 1 of 1

[SOLVED] ffDiaporama won't launch

Posted: Tue Oct 01, 2019 4:27 pm
by Trevanion
Linux user of about a month. On a brand new HP laptop (1T SSD and 16 RAM) that until this week had a dual-boot with Win10 -- but upon discovery of and some practice with ffDiaporama for making Ken Burns-type family history slideshows I concluded that give the boot to my previous slideshow maker and (hooray) Win10.

So I did a wipe and fresh Linux Mint install. But now...

After installation of ffDiaporama, via Software Manager, the program will not launch (it tries briefly, briefly exhibiting a ghostly horizontal box that quickly disappears). Oddly enough, unlike other programs installed via Software Manager there was no appearance of a "Launch" button, only its post-installation appearance in the application list. Or maybe in my inexperience that seems unusual.

I am tempted to instead try to install, instead of Software Manager, from a download from the ffDiaporama site and install what they say is for Linux Mint but is also a "Debian based" package. As both an official Old Guy and Noob, I am at sea as to how that type of package should be handled in terms of installation. And whether I have to undo the installation or whatever it was via Software Manager.

I confess I'm not sure how I installed ffDiaporama the first time around, before the wipe of the dual boot (i.e., whether it was via Software Manager or I had some plain dumb luck in downloading and blindly installing from that).

Any tips or other suggestions would be most welcome.

Re: ffDiaporama won't launch

Posted: Tue Oct 01, 2019 11:04 pm
by zcot
The Software Manager version is 2.1, the same as the last release from 2014 on their website. It looks like the download available from their site would give you the 1.6 version from 2013(edit: that's actually the LMDE version - debian based), quite older and likely possibly not usable or even installable due to package dependencies. Btw, if you download a .deb file it's just a simple double-click on the file and the gdebi manager will give you a nice GUI to click through easily, but I wouldn't even waste time on that in this case for this particular software. You would probably be looking for the Ubuntu based version instead which actually does show 2.1 but the package is quite old and I'm guessing the current Ubuntu repository version(from Mint Software Manager) has been adjusted to account for the newer version systems we are using(Ubuntu 16.04 / Mint 18.x or Ubuntu 18.04 / Mint 19.x).

But aside from that, you'll want to make sure you reinstalled Mint using the "Allow 3rd party software and codecs", otherwise you can add some useful codecs I think there's a link in the Welcome Screen, or by simply installing the package called mint-meta-codecs. And/or perhaps you want to check with the graphics driver setup available in the Driver Manager.

Re: ffDiaporama won't launch

Posted: Wed Oct 02, 2019 9:12 am
by Trevanion
Thanks for your thoughts. I have checked the codec and driver situation and everything seems to be in order. I can only judge by a comparison of what software manager yielded in comparison with every other package it launched, and I still have a sense that the version grabbed by software manager may be the source of the problem.

I'm rather frustrated by this, given the importance of having access to ffDiaporama to my decision to go with a Mint-only installation. I understand that the software is old, but I assume there are still folks out there who still use ffDiaporama. So I am wondering if this inquiry might be more appropriate to the "Software & Applications" forum. I have read through every reference to ffDiaporama and while there is a hint or two fo a similar issue I haven't been able to latch on to a solution.

I would appreciate advice if posting this inquiry regarding ffDiaporarma on the S&A forum after first posting here would violate any protocol.

Re: ffDiaporama won't launch

Posted: Wed Oct 02, 2019 12:48 pm
by phd21
Hi Trevanion,

Welcome to the wonderful world of Linux Mint and its excellent forum!

I just read your post and the good replies to it. Here are my thoughts on this as well.

"ffDiaporama v2.1" is and has been my favorite slideshow and movie maker application followed closely by "imagination" (has new version), unfortunately it has been abandoned. But, thankfully someone or some people added it to the Ubuntu and Mint software repositories. But, in order to get ffDiaporama to work, you will have to add some other packages dependencies, see links below. I could not get ffDiaporama to work either until I installed another software package that I use the secure "Qtox (qTox)" messenger (like Skype only better) using my installation script which installed a bunch of other packages and then ffDiaporama came right up and worked.

Also, whenever doing video and or audio editing, it does help to add various video and audio codecs which is also described in the links below.

Highly recommend installing these using the console terminal command below, restarting, and retrying ffDiaporama. Updated to add "libqt5sql5-sqlite".

Code: Select all

sudo apt-get install ffmpeg x264 x265 mencoder mplayer mpv kde-runtime libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediawidgets5 ubuntu-restricted-extras libqt5sql5-sqlite
How to get ffdiaporama on Mint 18? - Page 2 - Linux Mint Forums

Problems with creating Video DVDs. - Linux Mint Forums

FYI: post on installing a newer version of the "Imagination" slideshow application with comments from its developer.
Video editor for zooming into the video - Linux Mint Forums

Hope this helps ...

Re: ffDiaporama won't launch

Posted: Wed Oct 02, 2019 6:12 pm
by Trevanion
Thanks for your response. You have certainly provided a wealth of material related to the issue of ffDiaporama failing to aljunch. After having gone through it all my hopes are raised (I did use that command you suggested for terminal, but it did not fix things).

Unfortunately, there is so much there that assumes knowledge or experience that I do not have at this point.

My more basic question is how do I logically go after this? I have attempted various ways to install, via Software Manager, and via download. E.g., should I clean all of that up first before proceeding? If so, what is the best way of doing that? And is there perhaps a sequence of different versions I should try? On one attempt with installing via a download I got a message about a PPA not supporting "bionic." Is that a clue? (I remain convinced that the Software Manager is not pointed at the correct or complete version, given that it so oddly shows no "launch" button after it says it installed ffDiaporama).

Again, these questions reflect not the materials provided in your kind message of assistance but my skill level. So any further thoughts on a sequence for me to follow would be most welcome. Thank you.

Re: ffDiaporama won't launch

Posted: Wed Oct 02, 2019 11:23 pm
by zcot
The version from the available software repository should be the one you want.

You can check your current version with terminal command: apt version ffdiaporama and it will show 2.1+dfsg-1 for Mint 19.x or 1.5-4build3 for Mint 18.x. And some ppa version will show something different, who knows, but surely you would want a 2.1 version I would think.

Anyway, you should get rid of any direct package install used via download from the ffdiaporama website for sure. Purge it out, ie. apt purge ffdiaporama and further if you did take any ppa installation method then next remove that source list info(and regardless remove the ppa source of the one that is saying it is not compatible with Bionic, for sure). You can use the "Software Sources" app and check in additional repositories or ppa's and uncheck that source. The reason you do this is because a ppa source will mark a higher priority on a particular package than the default repo version, so in that case the ppa version would always be installed. -unless you wanted to force a version install with something specific like: apt install ffdiaporama=2.1+dfsg-1(I'm basing that on the Mint 19.x repository version).

apt update to refresh the package list of the sources since this involved changing some ppa sources which affects the overall composite of the sources lists.

So it looks to me like phd21 is saying that indeed the good version to use is the one from our default repository, and that makes perfect sense since it was adjusted to be compatible with current dependencies. So you can purge any previous installations as mentioned above, and then a normal install using the Software Manager should be sufficient, or even doing a terminal install with: apt install ffdiaporama is good. But the problem is that the given repository package is not fully correct. There's clearly another true dependency to the package and evidently it has slipped through the cracks and was not defined correctly in the package definition unfortunately, and this is why phd21 is suggesting to install Qtox since it will end up adding whatever the other dependency is.

After seeing phd21's good info and digging into other dependencies with some testing, this is what worked for me: apt install ffdiaporama libqt5sql5-sqlite

for research info, see: apt recommends ffdiaporama I initially installed that extra list, but said well it's probably not all entirely required, so I kept doing purge / install and ended up with only the libqt5sql5-sqlite extra package needed.

[SOLVED] Re: ffDiaporama won't launch

Posted: Thu Oct 03, 2019 7:32 am
by Trevanion
Genius! I am a very happy person this morning. Your walk-through was perfect in its manner of presentation, and, most important, it was successful. I am very grateful. Here's to Linux, and to the good souls on this forum. Many thanks.

Re: [SOLVED] Re: ffDiaporama won't launch

Posted: Thu Oct 03, 2019 11:11 am
by phd21
Hi Trevanion, zcot, and anyone else interested in this,

You are welcome from all of us that replied...

Kudos (thanks) to "zcot" for finding out which package dependency ffDiaporama v2.1 needed to work, "libqt5sql5-sqlite".

Re: [SOLVED] ffDiaporama won't launch

Posted: Sun May 31, 2020 7:28 am
by mpv
Another possibility to install ffDiaporama 2.1 is described here.