rdp to Mint VM with no video hardware

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Fissile
Level 1
Level 1
Posts: 1
Joined: Wed Oct 09, 2019 8:28 am

rdp to Mint VM with no video hardware

Post by Fissile » Wed Oct 09, 2019 9:05 am

Hi,

Fairly new to Linux, so please be kind.

I have deployed Mint 19.2 64-bit on an HCI cluster for testing and learning, the machine is virtual and running without video hardware acceleration.

I have access via console, but after trying several options to access via RDP - I am getting nowhere.

This is what I have done so far:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get xrdp
sudo apt-get xrdp xorgxrdp
sudo apt install -y freerdp-x11
echo env -u SESSION_MANAGER -u DBUS_SESSION_BUS_ADDRESS xfce4-session>~/.xsession
sudo reboot

I have also tried installing thightvncserver (sudo apt-get install tightvncserver) and rebooting. Tried session type as Xorg, X11rdp and Xvnc. The first two (Xorg and X11rdp) after login show a blue screen and after approximately five minutes display an error indicating login successful | started connecting | connection problem | giving up some problem - screenshot attached. With Xvnc the same thing happens; however, with a black screen and the same error message is displayed immediately without having the wait the odd five minutes.

Testing with:
xfreerdp /v:127.0.0.1
displays the same login screen as with Windows RDP and results in the same as described above.

Output of:
sudo tail /var/log/xrdp-sesman.log
is attached.

Please help,
Attachments
error-rdp-mint1.jpg
error-rdp-mint.jpg
error-rdp-mint.jpg (26.66 KiB) Viewed 61 times

Post Reply

Return to “Newbie Questions”