Page 2 of 4

Re: Sound and DVD burn glitches

Posted: Mon Oct 21, 2019 4:35 pm
by greenstar
Ah, amazing, yes, there are other columns. Ok, channel column. I can highlight 2ch and channel, but neither up, down or <> will change anything. I see there is also a CD column, set MM, but I can't change that either. On sound settings I see a tab 'analogue stereo output' with a dropdown arrow, but clicking on that nothing happens.

Re: Sound and DVD burn glitches

Posted: Mon Oct 21, 2019 5:21 pm
by MrEen
I swear this sounds like a permissions issue. Is there any output when you run sudo chown -Rc $USER:$USER $HOME? It's a perfectly safe command to run as long as you're not in a root terminal window (you should see ? at the prompt, not #)

Re: Sound and DVD burn glitches

Posted: Tue Oct 22, 2019 2:52 am
by greenstar
Just checking - I am asked for the password with sudo (would that therefore be root and undesirable, because if i enter the password and hit enter it will run!):
tony@tony-G31M-ES2L ~ $ sudo chown -Rc $USER:$USER $HOME
[sudo] password for tony:

Re: Sound and DVD burn glitches

Posted: Tue Oct 22, 2019 9:53 pm
by MrEen
Anytime you run sudo in front of a command it will ask for your password*. The need for it here is I'm thinking there are some root-owned files in your home folder that we want to change to your user. You don't have permission as your normal user to change root-owned files, hence sudo. There is never any time that a file in your home directory should be owned by anyone other than you.

* There is a timer (15 minutes maybe? Probably less.) after you run a command with sudo, that any subsequent sudo commands won't ask for your password.

Re: Sound and DVD burn glitches

Posted: Wed Oct 23, 2019 2:05 pm
by greenstar
Here it is:
tony@tony-G31M-ES2L ~ $ sudo chown -Rc $USER:$USER $HOME
[sudo] password for tony:
changed ownership of '/home/tony/.cache/dconf/user' from root:root to tony:tony
changed ownership of '/home/tony/.cache/dconf' from root:root to tony:tony
changed ownership of '/home/tony/.wget-hsts' from root:root to tony:tony
tony@tony-G31M-ES2L ~ $

I have run sudo commands before, but was confused as I see neither ? or # but $.

Re: Sound and DVD burn glitches

Posted: Wed Oct 23, 2019 6:56 pm
by MrEen
Yeah, I goofed on that one.

I had two users recently fixed by a kernel update. I just noticed your is quite out of date. You really should either drop back to the 4.4 kernel series, or move up to the 4.15 series. Both of those series are still supported. Based on your old hardware, you might be better served by the 4.4 series. Both those users also had ALC883 like you.

If you'd like to hold off on that for the moment, we can still look at a couple of other things. First let me see the output of ls -la ~/.config/pulse

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 3:25 am
by greenstar
You will need to tell me how to drop back the kernal! Your help is appreciated. This way I can do other things and chip away at it.
tony@tony-G31M-ES2L ~ $ ls -la ~/.config/pulse
total 80
drwx------ 2 tony tony 4096 Oct 7 21:15 .
drwxr-xr-x 27 tony tony 4096 Oct 7 21:15 ..
-rw-r--r-- 1 tony tony 32768 Oct 7 21:57 bbada5cfcc9a4a80ac8dc5ce6d9f53aa-card-database.tdb
-rw-r--r-- 1 tony tony 43 Oct 24 08:05 bbada5cfcc9a4a80ac8dc5ce6d9f53aa-default-sink
-rw-r--r-- 1 tony tony 42 Oct 24 08:05 bbada5cfcc9a4a80ac8dc5ce6d9f53aa-default-source
-rw-r--r-- 1 tony tony 12288 Oct 21 15:14 bbada5cfcc9a4a80ac8dc5ce6d9f53aa-device-volumes.tdb
-rw-r--r-- 1 tony tony 16384 Oct 23 19:08 bbada5cfcc9a4a80ac8dc5ce6d9f53aa-stream-volumes.tdb
-rw------- 1 tony tony 256 Oct 7 21:15 cookie

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 7:44 am
by MrEen
The output was fine.

For the kernel, go to Update Manager > View > Linux kernels

Click on 4.4 in the left pane, then the highest numbered kernel in the right pane, then click on Install.

When it's done you need to reboot and you'll need to get the grub menu to show to boot to the 4.4 kernel. Pressing and Holding Space should bring up the grub menu if it's not set to show automatically. Then select Advanced Options, and pick the 4.4 kernel there.

At the moment, you'll need to do that on every boot until we get rid of the higher kernels. We won't do that until we see if this fixes you.

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 8:33 am
by greenstar
Ok, kernal 44-166 installed.
The bad news is that pressing space (that's the long key right at the bottom of the keyboard?) didn't bring up grub. Had my finger on it the whole while from hitting the on button to getting the mint desktop. Well, that's one step forward.

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 8:41 am
by greenstar
(nor does grub come up without pressing space).

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 1:06 pm
by Flemur
MrEen wrote:
Thu Oct 17, 2019 4:27 pm
Well, this is odd. When you ran the script the Headphones and Line Out were both muted and had no volume.
Un-muting with alsa doesn't always un-mute the audio; OP, you might need to also un-mute in "pavucontrol".

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 3:43 pm
by MrEen
Sorry, I'm making stupid mistakes lately. Press and hold Shift. No idea why I typed Space.

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 4:38 pm
by greenstar
It is actually fairly reassuring to see I am not the only person who does daft things ...
So, booted up pressing shift. Grub menu appeared, chose advanced .... several options, found '44-166 generic'. Enter.
Boot started, Mint symbol appeared. Hung. Left ten minutes, no change. Had to turn off power to get out of it.
Started up again and, with huge relief at getting back my usual desk top, here I am.

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 4:42 pm
by greenstar
ps,thanks, had looked at pavucontrol in my first wave of googled fixes. Just now checked again, and it isn't muted.

Re: Sound and DVD burn glitches

Posted: Thu Oct 24, 2019 4:53 pm
by MrEen
Okay. You can go back into Update Manager > View > Linux kernels and uninstall the 4.4 kernel as it isn't helping any. I'd suggest trying the latest 4.15.0-66 kernel using the same method.

Because this is higher kernel it will load automatically when you reboot. You'll only need to use the Shift method if the newer kernel also hangs so you can get back to your 4.10 kernel.

Re: Sound and DVD burn glitches

Posted: Fri Oct 25, 2019 3:35 am
by greenstar
4.15 hangs too. Now removed. Worth trying any of the others?

Re: Sound and DVD burn glitches

Posted: Fri Oct 25, 2019 7:34 am
by MrEen
I don't think so. After 4.15, I think 5.0 is the next supported kernel and that's most likely too new for your hardware. At lot of support for old hardware starts getting ripped out of the kernel around there. The other kernel series listed are no longer supported any more.

Booting issues are not my forte, but I'd really like to see if a supported kernel fixes your sound issue.

I have to head to work, but I'll try to come up with other suggestions for getting the sound working this afternoon/evening.

Re: Sound and DVD burn glitches

Posted: Fri Oct 25, 2019 4:11 pm
by MrEen
I just thought of something we can try and see if it has any impact.

You started the thread saying sound worked, until it didn't. To test if it may have been a kernel update (even though I doubt this) boot to the grub menu and select something previous to 4.10.0-38.

If that is still wonky, try this instead:

Code: Select all

apt install --reinstall alsa-base alsa-utils pulseaudio linux-sound-base libasound2

Re: Sound and DVD burn glitches

Posted: Sat Oct 26, 2019 3:32 am
by greenstar
There is only 4.10.0 - 0-38 in grub. generic, upstart,recovery.
I tried the command line suggested with an odd result. Few seconds I had sound on headphones. Then it went completely dead there. I tried a second pair just in case there was an intermittent broken lead, still dead. Also, and this has always been the case through this scenario, there is faint sound from the card output, faint with a lot of hum. This goes to my amp, and i have been checking the jacks and inputs etc, but all looks correct. The aux on my amp is the input I have always used and which did work. I guess it is possible i have a faulty sound card but this would not explain the lack of output to 'phones.
Thanks.

Re: Sound and DVD burn glitches

Posted: Sat Oct 26, 2019 5:15 am
by greenstar
I just thought to repeat aforesaid command, did so, and the sound on headphones is back. This is great. I restarted and it is still working. I have other things to do now but will keep checking and report back. Fingers crossed.