[SOLVED] Linux mint cinnamon not playing audio

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

[SOLVED] Linux mint cinnamon not playing audio

Post by TheDomesticUser » Wed Oct 16, 2019 5:42 pm

Hello. I am recently new to Linux Mint Cinnamon and I have had trouble with my laptop audio for the past few days. Some days, the audio works on speaker and headphones, and other days, they don't. Here are my audio results:

cat /etc/pulse/daemon.conf | grep sample-rate results:
; default-sample-rate = 44100
; alternate-sample-rate = 48000

ls -la ~/.config/pulse results:
total 88
drwx------ 2 thedomesticuser thedomesticuser 4096 Oct 12 11:20 .
drwxr-xr-x 19 thedomesticuser thedomesticuser 4096 Oct 12 11:23 ..
-rw------- 1 thedomesticuser thedomesticuser 256 Oct 12 11:20 cookie
-rw-r--r-- 1 thedomesticuser thedomesticuser 45056 Oct 12 11:27 f3d85c83fd6e458aba76dbf56f683032-card-database.tdb
-rw-r--r-- 1 thedomesticuser thedomesticuser 1 Oct 14 14:48 f3d85c83fd6e458aba76dbf56f683032-default-sink
-rw-r--r-- 1 thedomesticuser thedomesticuser 1 Oct 14 14:48 f3d85c83fd6e458aba76dbf56f683032-default-source
-rw-r--r-- 1 thedomesticuser thedomesticuser 12288 Oct 14 15:13 f3d85c83fd6e458aba76dbf56f683032-device-volumes.tdb
-rw-r--r-- 1 thedomesticuser thedomesticuser 12288 Oct 13 10:29 f3d85c83fd6e458aba76dbf56f683032-stream-volumes.tdb
Top
Last edited by TheDomesticUser on Mon Oct 28, 2019 4:35 pm, edited 1 time in total.

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Wed Oct 16, 2019 7:31 pm

Hi again TheDomesticUser.

Here's my last post from the other thread. I'm suspecting this might fix your issue:
Is sound completely gone now? I'm hoping I misunderstood and the reboot still fixes it.

This may be necessary for you for some reason. Install PulseAudio Volume Control. When the sound isn't working, go to the Playback tab. I am guessing when you remove the Headphones, it's probably switching the output to the HDMI audio. On the Playback tab, you can change it back to Built-in Audio Analog Stereo.

If that wasn't the issue, run alsamixer in the terminal. The Speaker column is probably muted which will show MM at the bottom of the column. Arrow over to it, then press the m key to unmute. You might also need to raise the level with the up arrow key.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Fri Oct 18, 2019 6:47 pm

Hello, MrEen
How do I switch the output in the Playback tab? I don't see any options for switching to Built-in Audio Analog Stereo.
Here is my screenshot:
Selection_001.png

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Fri Oct 18, 2019 6:58 pm

Indeed. My guess is you only have one audio profile available. With nothing to switch to, the option to switch is gone.

Let's get a look at your sound stuff. Paste back the outputs of the following terminal command: pacmd list-cards

After I see that, I'll give you a few suggestions to try the next time the sound output disappears.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Fri Oct 18, 2019 9:04 pm

pacmd list-cards results:
1 card(s) available.
index: 0
name: <alsa_card.pci-0000_00_1f.3>
driver: <module-alsa-card.c>
owner module: 7
properties:
alsa.card = "0"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xef128000 irq 129"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1f.3"
sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "9d71"
device.product.name = "Sunrise Point-LP HD Audio"
device.form_factor = "internal"
device.string = "0"
device.description = "Built-in Audio"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
input:analog-stereo: Analog Stereo Input (priority 60, available: unknown)
output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: unknown)
output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: no)
output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5460, available: unknown)
output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300, available: no)
output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 360, available: unknown)
output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 300, available: no)
output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) Output + Analog Stereo Input (priority 360, available: unknown)
output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: no)
output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) Output + Analog Stereo Input (priority 5260, available: unknown)
output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: no)
output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 100, available: no)
output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5200, available: no)
output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) Output + Analog Stereo Input (priority 5260, available: unknown)
output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 100, available: no)
output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 100, available: no)
output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5200, available: no)
output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) Output + Analog Stereo Input (priority 5260, available: unknown)
output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 100, available: no)
output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 100, available: no)
output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5200, available: no)
output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) Output + Analog Stereo Input (priority 5260, available: unknown)
output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 100, available: no)
output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input (priority 160, available: unknown)
output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 100, available: no)
output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input (priority 160, available: unknown)
off: Off (priority 0, available: unknown)
active profile: <output:analog-stereo+input:analog-stereo>
sinks:
alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
sources:
alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Built-in Audio Analog Stereo
ports:
analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-input-microphone"
analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-input-microphone"
analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-speakers"
analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Fri Oct 18, 2019 9:15 pm

All your sound output options are on the same sound card. So indeed, that's why there was nothing to change to on the Playback tab. Otherwise, the output look fine.

I may have not given enough info previously. The next time the sounds stops working, delete the files in /home/YourUserName/.config/pulse, then run pulseaudio -k in the terminal, then restart the app you're using to play sound (browser, media player, etc.) That last step wasn't mentioned previously, so I don't know if it had been attempted. You could also check by running aplay /usr/share/sounds/alsa/Front_Center.wav in the terminal. If that works, your sound is good, and it's the app that's having an issue at that point.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Fri Oct 18, 2019 9:57 pm

Deleting the files in the pulse directory, running pulseaudio -k and restarting fixes the sound problem. The headphones are the main issue for me at this point. Plugging them in causes the computer to produce no audio, even when I unplug them.

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Fri Oct 18, 2019 10:03 pm

Okay, try running amixer in the terminal before plugging in the headphones. Then run it again after plugging them in. Paste both outputs here.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Mon Oct 21, 2019 7:59 pm

Hello, MrEen. My apologies for the late reply.
My headphones have started producing sound again, causing no issues to the laptop audio when I unplug them. I will send you the headphone amixer results if the headphone volume problem occurs again.

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Mon Oct 21, 2019 8:18 pm

Sounds good, TheDomesticUser.

With luck, you'll never have to send those outputs!

Also, if you're dual booting with Windows, sometimes shutting down Windows completely (not rebooting) before booting into Mint can help prevent this kind of issue.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Tue Oct 22, 2019 6:01 pm

Hello, MrEen

The headphones stopped producing audio again. Here are my amixer results:

amixer before plugging in headphones:
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 31 [36%] [-42.00dB] [on]
Simple mixer control 'Headphone',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 0 [0%] [-65.25dB] [off]
Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'Speaker',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 87 [100%] [0.00dB] [on]
Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 253 [99%] [-0.40dB]
Front Right: Playback 253 [99%] [-0.40dB]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'IEC958',1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',2
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',3
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',4
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 63
Front Left: Capture 33 [52%] [7.50dB] [on]
Front Right: Capture 33 [52%] [7.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
Capabilities: enum
Items: 'Disabled' 'Enabled'
Item0: 'Disabled'
Simple mixer control 'Headset Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Internal Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]







amixer after plugging in headphones:
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 51 [59%] [-27.00dB] [on]
Simple mixer control 'Headphone',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 87 [100%] [0.00dB] [on]
Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 0 [0%] [-65.25dB] [off]
Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 253 [99%] [-0.40dB]
Front Right: Playback 253 [99%] [-0.40dB]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'IEC958',1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',2
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',3
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',4
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 63
Front Left: Capture 63 [100%] [30.00dB] [on]
Front Right: Capture 63 [100%] [30.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
Capabilities: enum
Items: 'Disabled' 'Enabled'
Item0: 'Disabled'
Simple mixer control 'Headset Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 2 [67%] [20.00dB]
Front Right: 2 [67%] [20.00dB]
Simple mixer control 'Internal Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]

User avatar
Spearmint2
Level 16
Level 16
Posts: 6874
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Linux mint cinnamon not playing audio

Post by Spearmint2 » Tue Oct 22, 2019 6:48 pm

I installed paman on mine, since I had problems with audio dropping out at times in 18.3 also. So far so good. I changed some things using it, and so far, no problems again. I can't say why it worked, nor if it will continue.

UPDATE; It didn't. switch user or log out and then log back in does.
Last edited by Spearmint2 on Sun Oct 27, 2019 9:22 pm, edited 1 time in total.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Tue Oct 22, 2019 9:22 pm

The 2 amixer outputs look as they should. Output was sent to speakers before plugging in the headphones. After plugging them in, output was directed to the headphones and the speakers were muted as they should be in that scenario.

Well, that would all be true, except that you have disabled Auto-Mute Mode. So in reality, that shouldn't be happening.

See if you can fix the output in alsamixer. In the terminal run alsamixer and while the headphones are plugged in, can you change the volume on the Speaker column? You'll also need to press the m key to unmute them.

It might be a good idea to run this as well:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
It'll give you a termbin.com URL when it's done to paste back here. Then I can see if there's any non-standard configs interfering.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Wed Oct 23, 2019 10:01 pm

Here is the termbin URL:
https://termbin.com/87an

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Thu Oct 24, 2019 7:28 am

It appears that when you plug in the headphones, the Headset Mic Boost goes from 0 to 2. You could try dropping that back down to zero in alsamixer and see if that has any impact. I'm doubting that'll be of much help, but it's an odd thing to see.

I've got an experiment I'd like you to try. When the headphones are plugged in and not working see if this gets them working (you'll need to install alsa-tools):

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x21 SET_PIN_WIDGET_CONTROL 0xc0
If that works, you can mute them with this:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x21 SET_PIN_WIDGET_CONTROL 0x0
Then see if this gets the speakers working again when you unplug the headphones:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x17 SET_PIN_WIDGET_CONTROL 0xc0
And muting the speakers could be done with this:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x17 SET_PIN_WIDGET_CONTROL 0x0
I can't tell what is causing the issue, but I'm hoping the above might give you a workaround when it happens. If the above messes things up, a reboot should get you back to normal.

I'll look through the output again when I get home to see if I get other ideas.

Good luck.

TheDomesticUser
Level 1
Level 1
Posts: 17
Joined: Sat Oct 05, 2019 4:30 pm

Re: Linux mint cinnamon not playing audio

Post by TheDomesticUser » Sun Oct 27, 2019 5:59 pm

Hello, MrEen
Unfortunately, the commands you've stated don't work. I found out that the headphones cause the volume issue whenever I dual boot into Linux Mint after restarting my computer from Windows 10 Home edition. All I have to do is shut down my computer completely, then dual boot into Linux Mint, and there is no sound problem. I think Windows could be the one that's causing my volume issues.

User avatar
MrEen
Level 14
Level 14
Posts: 5384
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux mint cinnamon not playing audio

Post by MrEen » Sun Oct 27, 2019 6:07 pm

Ahh, yes. A somewhat common issue. Rebooting from Windows doesn't actually turn off the sound card properly (I believe the amp specifically) so Linux never gets to control it properly. This can also happen in reverse. Rebooting from Linux back to Windows could mess up the sound in Windows.

Now that you've found this out, you should be good I believe.

Post Reply

Return to “Newbie Questions”