LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
tcs1752890
Level 1
Level 1
Posts: 5
Joined: Sun Oct 20, 2019 9:45 am

LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by tcs1752890 » Sun Oct 20, 2019 9:58 am

Hi,
None of the "slow shutdown" topics seem applicable to me so this is my problem:
I was running LM Cinnamon 17.3 and all was well, shutdown taking 2-3 seconds. I have upgraded to 19.2 in a new partition and shutdown takes 90 seconds. Running "shutdown now" in a terminal shuts down immediately.
So, since the hardware hasn't changed I can only assume there's something in the kernel causing a problem and any help would be appreciated.
I have attached the system info.
Regards,
Joe.
Attachments
SystemInfo.txt
(4.6 KiB) Downloaded 10 times

DisturbedDragon
Level 2
Level 2
Posts: 61
Joined: Mon Oct 29, 2012 6:29 pm
Location: Texas

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by DisturbedDragon » Sun Oct 20, 2019 10:14 am

I had this same issue on a newer Lenovo laptop. It was because of the current kernel. I rolled back one minor version and issue has been resolved. Give it a go. Kernel can be viewed/installed and removed from the update manager. By default you should have at least two or three installed at any given time. Boot the computer and select a kernel just below the current version. Let the pc boot and then shut it down. If it shuts down okay then repeat the boot process and remove the newest kernel using update manager. You can also set update manager to ignore kernel updates.
AMD Ryzen 3700x
MSI x470 Gaming Pro
1TB Crucial P1 NVMe
1TB Samsung 960 Pro NVMe
32GB DDR4 3200
Nvidia RTX2080 OC
-------------------------------------
Linux Mint 19.2 Cinnamon
Kernel 5.0.0-32

gittiest personITW
Level 5
Level 5
Posts: 819
Joined: Tue May 28, 2019 4:27 pm

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by gittiest personITW » Sun Oct 20, 2019 10:16 am

Hi,
First thing I would try would be to see if you have any apps, applets or extensions that you have ported over from 17.3 that don't get on very well with 19.2.
Before you shut down, kill some of the smaller running programs (run 'top' in terminal) and see if that makes a large difference.
First try lots of them, just to see whether it is worth going down that avenue.

Also, might be worth pasting the relevant lines of

Code: Select all

dmesg -T | less
after a reboot, and same with

Code: Select all

dmesg | grep -i "error\|warn\|fail"

User avatar
Larry78723
Level 7
Level 7
Posts: 1579
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by Larry78723 » Sun Oct 20, 2019 10:43 am

I would suggest reinstalling and testing shutdown time without the ppa's you've added. It's possible that they are causing a problem if they're designed for 17.3.
Image

User avatar
pbear
Level 8
Level 8
Posts: 2465
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by pbear » Sun Oct 20, 2019 11:43 am

Hey tcs, welcome to the Linux Mint Forums.

What's happening is that the system is waiting for some process to complete, then giving up after a 90 second timeout and moving to the next step. You can get a general sense of what's holding up shutdown by hitting the Esc key during shutdown, which will display messages normally hidden by quiet splash. For more detail, you would have to go into the logs, which is a bit complicated but doable. Another "solution" is to reduce the timeout.

By the way, it's much easier for folks trying to help if you post the inxi report as text rather than attaching a text file. Should look like this:

Code: Select all

System:    Host: joe Kernel: 4.15.0-65-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 
           Desktop: Cinnamon 4.2.4 wm: muffin dm: LightDM Distro: Linux Mint 19.2 Tina 
           base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> Chassis: type: 3 
           serial: <filter> 
           Mobo: Gigabyte model: F2A68HM-HD2 v: x.x serial: <filter> BIOS: American Megatrends 
           v: FB date: 04/22/2015 
CPU:       Topology: Dual Core model: AMD A6-7400K Radeon R5 6 Compute Cores 2C+4G bits: 64 
           type: MCP arch: Steamroller rev: 1 L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 13975 
           Speed: 2285 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1397 2: 1397 
Graphics:  Device-1: AMD Kaveri [Radeon R5 Graphics] vendor: Gigabyte driver: radeon v: kernel 
           bus ID: 00:01.0 chip ID: 1002:1315 
           Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD KAVERI (DRM 2.50.0 4.15.0-65-generic LLVM 8.0.0) 
           v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:     Device-1: AMD Kaveri HDMI/DP Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:1308 
           Device-2: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1022:780d 
           Sound Server: ALSA v: k4.15.0-65-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte 
           driver: r8169 v: 2.3LK-NAPI port: e000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.02 TiB used: 293.92 GiB (28.2%) 
           ID-1: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB speed: 6.0 Gb/s 
           serial: <filter> 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB 
           speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 57.42 GiB used: 15.24 GiB (26.5%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 6.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 chip ID: 1d6b:0001 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 chip ID: 1d6b:0001 
           Device-1: 4-2:2 info: Lenovo type: Mouse driver: hid-generic,usbhid rev: 2.0 
           chip ID: 17ef:6019 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 chip ID: 1d6b:0001 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 13.5 C mobo: N/A gpu: radeon temp: 7 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           1: deb https: //dl.winehq.org/wine-builds/ubuntu/ bionic main
           Active apt repos in: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-bionic.list 
           1: deb http: //ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic main
           2: deb-src http: //ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: //packages.linuxmint.com tina main upstream import backport #id:linuxmint_main
           2: deb http: //archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           3: deb http: //archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           4: deb http: //archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ bionic partner
           Active apt repos in: /etc/apt/sources.list.d/scootersoftware.list 
           1: deb http: //www.scootersoftware.com/ bcompare4 non-free
Info:      Processes: 177 Uptime: 1m Memory: 6.75 GiB used: 993.4 MiB (14.4%) Init: systemd v: 237 
           runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Client: Unknown python3.6 client inxi: 3.0.32 
Also, in future, please expand Terminal to full screen before running the command. The line breaks will be cleaner. Thanks.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

tcs1752890
Level 1
Level 1
Posts: 5
Joined: Sun Oct 20, 2019 9:45 am

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by tcs1752890 » Tue Oct 22, 2019 11:29 am

OK, thanks to everyone for their suggestions - this is what I have so far.

The only processes I have running are root processes and I wouldn't have a clue which of these I could safely stop before shutting down - so I didn't.

The only ppa I have is danielrichter2007/grub-customizer and I decided it was safer to leave this alone.

Having rebooted I ran the dmesg suggestions. The output from the "-T" option is extensive and pretty meaningless to me but the check for errors gave the following:

[ 0.000000] ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20170831/tbfadt-658)
[ 1.498413] RAS: Correctable Errors collector initialized.
[ 4.196804] ACPI Error: [\_SB_.ALIB] Namespace lookup failure, AE_NOT_FOUND (20170831/psargs-364)
[ 4.196824] ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.ATC0, AE_NOT_FOUND (20170831/psparse-550)
[ 4.196835] ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.ATCS, AE_NOT_FOUND (20170831/psparse-550)
[ 5.607796] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[ 17.857190] random: 7 urandom warning(s) missed due to ratelimiting


Scary!

I tried Restart (didn't think of it before) and the system shutdown in the normal 2-3s.

I did a Shutdown and then Esc and got the following message:
"A stop job is running for Session c2 of user joe (<clock cnt> / 1m 29s)"

When I went to the Update Manager to look at kernels I noticed a new version available (4.15.0-66) so I decided to go forwards rather than backwards. Installed and rebooted then tried a Shutdown - closed in 2-3s. Magic! Problem fixed I thought. No! Subsequent Shutdown attempts were back at 90s.
Tried a Restart - also 90s.
I left the Quit window to timeout (60s) and then it went into it's normal 90s shutdown with the same message.

I think I need to look at system logs in more detail if someone can point me in the right direction please.

Regards,
Joe.

tcs1752890
Level 1
Level 1
Posts: 5
Joined: Sun Oct 20, 2019 9:45 am

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by tcs1752890 » Sat Oct 26, 2019 12:58 pm

Hello again.
I have been looking at the journalctl output and it looks as though there may be a number of problems but specifically with pulseaudio. Here are selections of journal entries which may be interesting.

Oct 26 17:29:39 joe polkitd(authority=local)[855]: Unregistered Authentication Agent for unix-session:c2 (system bus name :1.56, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8) (disconnected from bus)
Oct 26 17:29:39 joe cinnamon-session[1152]: WARNING: t+9407.81617s: Playing logout sound '/usr/share/mint-artwork/sounds/logout.ogg'
Oct 26 17:29:39 joe cinnamon-session[1152]: WARNING: t+9407.88793s: Finished playing logout sound
Oct 26 17:29:39 joe cinnamon-session[1152]: WARNING: t+9407.88827s: Resuming logout sequence...
Oct 26 17:29:40 joe cinnamon-session[1152]: WARNING: t+9408.83587s: Requesting system shutdown...
Oct 26 17:29:40 joe cinnamon-session[1152]: WARNING: t+9408.84597s: Attempting to shutdown using systemd...
Oct 26 17:29:40 joe systemd-logind[728]: System is powering down.


Everything then looks OK until this:

Oct 26 17:29:40 joe dbus-daemon[707]: [system] Activation via systemd failed for unit 'polkit.service': Refusing activation, D-Bus is shutting down.
Oct 26 17:29:40 joe apport[2877]: * Stopping automatic crash report generation: apport
Oct 26 17:29:40 joe NetworkManager[784]: <warn> [1572107380.7631] error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: Authorization check failed: Refusing activation, D-Bus is shutting down.
Oct 26 17:29:40 joe speech-dispatcher[2886]: * speech-dispatcher disabled; edit /etc/default/speech-dispatcher
Oct 26 17:29:40 joe systemd[1]: Stopped LSB: Speech Dispatcher.
Oct 26 17:29:40 joe NetworkManager[784]: <warn> [1572107380.7658] error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: Authorization check failed: Refusing activation, D-Bus is shutting down.


Later on we get:

Oct 26 17:29:40 joe systemd[1]: Starting Show Plymouth Power Off Screen...
Oct 26 17:29:40 joe pulseaudio[2907]: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true
Oct 26 17:29:40 joe systemd[1]: Stopped ACPI event daemon.
Oct 26 17:29:40 joe dbus-daemon[707]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service' requested by ':1.90' (uid=1000 pid=2913 comm="/usr/bin/pulseaudio --start --log-target=syslog " label="unconfined")
Oct 26 17:29:40 joe dbus-daemon[707]: [system] Activation via systemd failed for unit 'rtkit-daemon.service': Refusing activation, D-Bus is shutting down.
Oct 26 17:29:40 joe dbus-daemon[707]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service' requested by ':1.91' (uid=1000 pid=2913 comm="/usr/bin/pulseaudio --start --log-target=syslog " label="unconfined")


There are lots of these lines, down to:

Oct 26 17:29:41 joe dbus-daemon[707]: [system] Activation via systemd failed for unit 'rtkit-daemon.service': Refusing activation, D-Bus is shutting down.
Oct 26 17:29:41 joe dbus-daemon[707]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service' requested by ':1.110' (uid=1000 pid=2913 comm="/usr/bin/pulseaudio --start --log-target=syslog " label="unconfined")
Oct 26 17:29:41 joe dbus-daemon[707]: [system] Activation via systemd failed for unit 'rtkit-daemon.service': Refusing activation, D-Bus is shutting down.
Oct 26 17:29:41 joe dbus-daemon[707]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.111" (uid=1000 pid=2913 comm="/usr/bin/pulseaudio --start --log-target=syslog " label="unconfined") interface="org.freedesktop.DBus.ObjectManager" member="GetManagedObjects" error name="(unset)" requested_reply="0" destination="org.bluez" (bus)
Oct 26 17:29:41 joe pulseaudio[2913]: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /run/user/1000/bus: Connection refused
Oct 26 17:29:41 joe pulseaudio[2913]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /run/user/1000/bus: Connection refused
Oct 26 17:29:41 joe pulseaudio[2913]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.111" (uid=1000 pid=2913 comm="/usr/bin/pulseaudio --start --log-target=syslog " label="unconfined") interface="org.freedesktop.DBus.ObjectManager" member="GetManagedObjects" error name="(unset)" requested_reply="0" destination="org.bluez" (bus)
Oct 26 17:29:41 joe systemd[1]: Received SIGRTMIN+20 from PID 2909 (plymouthd).
Oct 26 17:29:41 joe systemd[1]: Started Show Plymouth Power Off Screen.
Oct 26 17:29:42 joe kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=XXX SRC=192.168.1.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2
Oct 26 17:30:40 joe kernel: usb 4-2: USB disconnect, device number 2
Oct 26 17:30:42 joe kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=XXX SRC=192.168.1.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2
Oct 26 17:30:42 joe kernel: usb 4-2: new low-speed USB device number 3 using ohci-pci
Oct 26 17:30:42 joe kernel: usb 4-2: New USB device found, idVendor=17ef, idProduct=6019
Oct 26 17:30:42 joe kernel: usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct 26 17:30:42 joe kernel: usb 4-2: Product: Lenovo USB Optical Mouse
Oct 26 17:30:42 joe kernel: usb 4-2: Manufacturer: Logitech
Oct 26 17:30:42 joe kernel: input: Logitech Lenovo USB Optical Mouse as /devices/pci0000:00/0000:00:13.0/usb4/4-2/4-2:1.0/0003:17EF:6019.0002/input/input11
Oct 26 17:30:42 joe kernel: hid-generic 0003:17EF:6019.0002: input,hidraw0: USB HID v1.11 Mouse [Logitech Lenovo USB Optical Mouse] on usb-0000:00:13.0-2/input0
Oct 26 17:30:42 joe mtp-probe[2926]: checking bus 4, device 3: "/sys/devices/pci0000:00/0000:00:13.0/usb4/4-2"
Oct 26 17:30:42 joe mtp-probe[2926]: bus: 4, device: 3 was not an MTP device
Oct 26 17:31:10 joe systemd[1]: session-c2.scope: Stopping timed out. Killing.
Oct 26 17:31:10 joe systemd[1]: session-c2.scope: Killing process 2913 (pulseaudio) with signal SIGKILL.
Oct 26 17:31:10 joe systemd[1]: session-c2.scope: Failed with result 'timeout'.
Oct 26 17:31:10 joe systemd[1]: Stopped Session c2 of user joe.
Oct 26 17:31:10 joe systemd[1]: Removed slice User Slice of joe.


(I have removed the MAC addresses from the above snippets).

My version of pulseaudio is 11.1 but as I understand it this is bolted into the core and not easily updated by novices such as myself.

Has anybody got any clues/suggestions please?

Regards,
Joe.

allanr
Level 1
Level 1
Posts: 33
Joined: Tue Feb 07, 2017 1:02 pm
Location: Scotland

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by allanr » Tue Oct 29, 2019 4:33 pm

I have exactly the same problem with my desktop PC which started some time after the 19.2 upgrade (but not immediately). Sometimes it shuts down quickly but usually takes 1'30".

This posting in the September Linux Mint Blog by MenthaSuaveolens dated October 8, 2019 at 3:21 pm gives a workaround which works fine for me.
(pbear also touched on this in his reply.)
It looks that from time to time some peripherals fail to respond when shutting down the system.
One can change the timeout-setting
sudo gedit /etc/systemd/system.conf
#DefaultTimeoutStopSec=90s
change to
DefaultTimeoutStopSec=4s

Note: Remove the comment-character #
It doesn't address the root cause but certainly speeds up shutdown with no apparent ill-effects. Further analysis is beyond me.
Hope this is of some help.
Image

tcs1752890
Level 1
Level 1
Posts: 5
Joined: Sun Oct 20, 2019 9:45 am

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by tcs1752890 » Fri Nov 01, 2019 2:18 pm

Thanks allanr. I am aware of this workaround but I would rather not hide the issue. For now I just open a terminal and type "shutdown now" which works perfectly, closing down in 2-3 seconds. It also reminds me that I still have a problem to deal with :)
I am fairly sure that the issue is to do with pulseaudio but I think it may have to wait until either it is fixed in a new release or some Linux genius reads this post and provides an answer I can understand.

User avatar
pbear
Level 8
Level 8
Posts: 2465
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by pbear » Fri Nov 01, 2019 11:37 pm

If you're reconciled to shutting down manually for the time being, it's pretty easy to put a launcher for that on panel, desktop and/or menu.

Right-click anywhere on the desktop and select Create a new launcher here ... FYI, the second field is where you put the command string to be executed, e.g., shutdown now. Leave Launch in Terminal unchecked. Note option to add to Menu. (Otherwise, you get only a desktop launcher.) Do this if you want a panel launcher, as you add that by right-clicking the menu launcher. Menu launcher doesn't appear, though, until you log out then back in (or reboot). If don’t want menu entry and/or desktop launcher, either may be deleted (if desired, leaving only the panel launcher).
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

missmoondog
Level 3
Level 3
Posts: 183
Joined: Wed Nov 07, 2018 9:17 am

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by missmoondog » Sat Nov 02, 2019 8:36 am

had this exact same problem on 2 older, 32bit machines. gave up on trying to figure it out. installed Bodhi Linux legacy, which uses an older kernel, and all is well on those 2 machines. actually a pretty decent OS based on ubuntu.

not a fix for the issue really but a small suggestion.

tcs1752890
Level 1
Level 1
Posts: 5
Joined: Sun Oct 20, 2019 9:45 am

Re: LM Cinnamon 19.2 takes 90s to shutdown - 17.3 immediate

Post by tcs1752890 » Sat Nov 02, 2019 12:26 pm

Thanks pbear - saved me having to look up how to add the desktop launcher.

Post Reply

Return to “Newbie Questions”