Problem with R "rgl" package

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
fsc
Level 1
Level 1
Posts: 12
Joined: Mon Jan 13, 2020 5:20 pm

Problem with R "rgl" package

Post by fsc »

Hi everyone!
I don't know if this section, or even this forum, is the right one for my topic, and if it's not just tell me and I'll delete it.
I installed R on my XPS-13 with Mint 19.2 Cinnamon, and when I run it in a terminal it works. Nevertheless, when I try to install rgl package by running in R

Code: Select all

install.packages("rgl")
I get

Code: Select all

checking for X... no
configure: error: X11 not found but required, configure aborted.
Reading some threads in the internet, I tried to run in a terminal:

Code: Select all

sudo apt-get build-dep r-cran-rgl 
but I got the error message:

Code: Select all

E: You must put some 'source' URIs in your sources.list
You might wonder why I am posting this question in a Linux Mint forum: the fact is that when I installed Rcmdr on my previous Windows 10 OS I encountered no problems, and seeing there were issues on Mint I thought I could ask here. Thanks in advance for your answers!

deepakdeshp
Level 16
Level 16
Posts: 6561
Joined: Sun Aug 09, 2015 10:00 am

Re: Problem with R "rgl" package

Post by deepakdeshp »

You can also try in R forum.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Newbie Questions”