Canon TS 6151 wireless printer SOLVED

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
fred19
Level 4
Level 4
Posts: 206
Joined: Thu Apr 24, 2014 3:05 pm

Re: Canon TS 6151 wireless printer

Post by fred19 »

Brian and Pzz thank you all for your help. I hadn't really expected any helpful response to this problem.

Output below as requested.

vulcan@vulcan-Inspiron-1545 ~ $ ldd /usr/lib/x86_64-linux-gnu/sane/libsane-airscan.so.1
linux-vdso.so.1 => (0x00007ffcd6baa000)
libavahi-common.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-common.so.3 (0x00007fdf5aa46000)
libavahi-client.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-client.so.3 (0x00007fdf5a835000)
libavahi-glib.so.1 => /usr/lib/x86_64-linux-gnu/libavahi-glib.so.1 (0x00007fdf5a631000)
libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fdf5a320000)
libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007fdf5a0c7000)
libsoup-2.4.so.1 => /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1 (0x00007fdf59df0000)
libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fdf59b9d000)
libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007fdf597e2000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fdf595c5000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fdf591fb000)
libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007fdf58faf000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fdf58dab000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fdf58b3b000)
libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007fdf587b3000)
libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007fdf584de000)
libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007fdf582d6000)
libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007fdf57f42000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fdf57d28000)
liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007fdf57b06000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fdf577fd000)
/lib64/ld-linux-x86-64.so.2 (0x00007fdf5ae67000)
libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007fdf5afd3000)
libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fdf575f9000)
libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007fdf573d7000)
libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007fdf571bc000)
libicudata.so.55 => /usr/lib/x86_64-linux-gnu/libicudata.so.55 (0x00007fdf55705000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fdf55383000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fdf5516d000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fdf54f65000)
libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007fdf54c84000)
libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007fdf54a70000)
vulcan@vulcan-Inspiron-1545 ~ $

brian_p
Level 6
Level 6
Posts: 1036
Joined: Thu Jan 17, 2019 9:20 am

Re: Canon TS 6151 wireless printer

Post by brian_p »

I have some good news and some bad news. The good news first.

I installedl Mint 18.1 and was able to reproduce all of fred19's experience with my HP ENVY 4500. Then I replaced libjpeg-turbo8 with libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_amd64.deb from Ubuntu Bionic (which Mint 19.x is based on). Scanning with imagescan and simple-scan is now successful.

The bad news is that putting the Bionic package on the system led to the removal of a number of important packages. Warning: do not follow in my footsteps if you value the health of your 18.1 system.

One sensible way forward is to upgrade Mint to 19.1. Another way is to build sane-airscan for Mint 18.1. In principle it should not be too hard. I'll have a go in a little while.
--
Brian.

pzz
Level 1
Level 1
Posts: 9
Joined: Mon Jan 27, 2020 3:01 pm

Re: Canon TS 6151 wireless printer

Post by pzz »

fred19 wrote:
Tue Jan 28, 2020 4:56 am
Brian and Pzz thank you all for your help. I hadn't really expected any helpful response to this problem.
Next two commands, please:
nm -D /usr/lib/x86_64-linux-gnu/libjpeg.so.8
dpkg -S /usr/lib/x86_64-linux-gnu/libjpeg.so.8

brian_p
Level 6
Level 6
Posts: 1036
Joined: Thu Jan 17, 2019 9:20 am

Re: Canon TS 6151 wireless printer

Post by brian_p »

brian_p wrote:
Tue Jan 28, 2020 7:48 am

The bad news is that putting the Bionic package on the system led to the removal of a number of important packages. Warning: do not follow in my footsteps if you value the health of your 18.1 system.
After a careful look at what apt was telling me and some thought, I have decided to withdraw the big scary warning and readjust my recommendation. The packages which were slated to be removed were all i386 packages; this exposes the multiarch aspect of Mint. In my case, I could not care less whether they were on the system or not. Having them removed would do no damage.

In fact I can have my cake and eat it by installing both the amd64 and i386 versions of the Bionic packages. So, fred19, here is the command you use:

Code: Select all

sudo apt install ./libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_i386.deb ./libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_amd64.deb -s
The command is issued in the directory the two packages were downloaded to. -s is a safely net (simulate) which is removed when you are happy to go ahead for real.

It works for me and pzz and I are dying to find out if your scanner works with sane-airscan. :)
--
Brian.

fred19
Level 4
Level 4
Posts: 206
Joined: Thu Apr 24, 2014 3:05 pm

Re: Canon TS 6151 wireless printer

Post by fred19 »

brian_p wrote:
Tue Jan 28, 2020 1:35 pm
brian_p wrote:
Tue Jan 28, 2020 7:48 am



In fact I can have my cake and eat it by installing both the amd64 and i386 versions of the Bionic packages. So, fred19, here is the command you use:

Code: Select all

sudo apt install ./libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_i386.deb ./libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_amd64.deb -s
The command is issued in the directory the two packages were downloaded to. -s is a safely net (simulate) which is removed when you are happy to go ahead for real.

It works for me and pzz and I are dying to find out if your scanner works with sane-airscan. :)
Sorry guys I am a bit lost now with this. Do I have to download something before the install? Also don't understand the "-s" bit. I am a bit dim I am afraid.
I use Wine to run some 32bit programs, will they be affected?
Do you still want the two outputs.

Thanks again.

brian_p
Level 6
Level 6
Posts: 1036
Joined: Thu Jan 17, 2019 9:20 am

Re: Canon TS 6151 wireless printer

Post by brian_p »

We will do this stp by step.

Do:

Code: Select all

 wget http://security.ubuntu.com/ubuntu/pool/main/libj/libjpeg-turbo/libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_i386.deb
Does

Code: Select all

ls -l libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_i386.deb 
show you the file you have downloaded?
--
Brian.

brian_p
Level 6
Level 6
Posts: 1036
Joined: Thu Jan 17, 2019 9:20 am

Re: Canon TS 6151 wireless printer

Post by brian_p »

Now do

Code: Select all

wget http://security.ubuntu.com/ubuntu/pool/main/libj/libjpeg-turbo/libjpeg-turbo8_1.5.2-0ubuntu5.18.04.3_amd64.deb
Does

Code: Select all

ls -l 
show you this file and the previous one?
--
Brian.

pzz
Level 1
Level 1
Posts: 9
Joined: Mon Jan 27, 2020 3:01 pm

Re: Canon TS 6151 wireless printer

Post by pzz »

fred19 wrote:
Tue Jan 28, 2020 4:56 am
Output below as requested.
Hi Fred,

looking around the Internet, I came to conclusion that Mint 18.1 is rather Ubuntu 16.04 that 18.04. So I've added 16.04 to the list of distros I support. Please, try:

https://download.opensuse.org/repositor ... .04/amd64/

brian_p
Level 6
Level 6
Posts: 1036
Joined: Thu Jan 17, 2019 9:20 am

Re: Canon TS 6151 wireless printer

Post by brian_p »

pzz wrote:
Wed Jan 29, 2020 12:46 am

looking around the Internet, I came to conclusion that Mint 18.1 is rather Ubuntu 16.04 that 18.04. So I've added 16.04 to the list of distros I support. Please, try:

https://download.opensuse.org/repositor ... .04/amd64/
Hello fred19,

The advice I have offered works but it has become redundant - pzz's Mint 18.1 .deb file is much easier to deal with (and works for me). Please use it.
--
Brian.

fred19
Level 4
Level 4
Posts: 206
Joined: Thu Apr 24, 2014 3:05 pm

Re: Canon TS 6151 wireless printer

Post by fred19 »

Brilliant the new .deb file works a treat. I know Canon scanners are problematic so I wasn't expecting to get it working.

Brian, I held off your solution till I had had a good nights sleep and then saw Pzz's
Thanks again guys you are extremely clever.

Post Reply

Return to “Newbie Questions”