Video micro stutters/pauses I found a fix for

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
oldbob
Level 1
Level 1
Posts: 45
Joined: Thu Jan 02, 2020 8:54 am

Video micro stutters/pauses I found a fix for

Post by oldbob »

Hi folks,

I’d noticed a little oddity with Linux Mint Cinnamon 19.3 recently, and it’s to do with video playback on YouTube and Netflix.

Like all new converts to Linux I’ve been playing with all the new things MS didn’t want me to have/play with. Oh, Applets… ohh Desklets… oohhh Panel edits and settings…. ooohhhh Themes etc, you get the picture... and through the course of the month I’ve had Mint installed (that’s a lie, I’ve installed a few times due to my cockup’s), I’ve added a couple of things here and there. I’ve since learned how to do a proper backup, now there’s no more re-installs ;).

All was fine until I installed/applied a couple of Applets around 4/5 days ago, these being a CPU temp monitor and a GPU temp monitor to keep an eye on both chips... no idea why, just seemed like a good idea at the time :lol:.

Since I installed/applied these to Mint, every-time I watched a YouTube video or Netflix, I would see, what can only be described as ‘micro stutters or pauses’ every one to two seconds. I then tried watching one of my films that’s on my SSD to see if it was my system was causing it, and no, no stutters or pausing.

I asked my wife if she was having the same oddity on her laptop, she said no, same applies to my brother-in-law. They both use Firefox browser, my wife uses Google while B-in-L uses DuckDuckGo as search engines. I use the Brave browser along with DDG as a search engine. I switched back to Firefox/Google/DDG, tried Chrome/Google/DDG etc, still the same problem

I searched these forums for an answer, nothing came up that pertained to my specific oddity or search, (it’s been bugging me for days, plus I've installed all the updates via the Update Manager, so was scratching my head a bit), mostly they were about video drivers and broken screen etc. Mine are the nVidia drivers recommended by the Update Manager, and everything has been fine with them so far... so my next search was on the interweb, and after a few minutes of deep and intense searching :D, I found an answer pointing right at these very forums… typical eh? My searching parameter skills have always been dire at best.

The problem another poster had was almost the same as mine, it was because either the CPU temp monitor and/or GPU temp monitor Applets keep updating themselves every few minutes, and this was causing the video playback micro stutter/pause thing to happen in YouTube and/or Netflix. It was suggested to him (believe it or not, I can’t find that post again), or he figured it out, that by removing/uninstalling the Applets, everything should be as it was... re-online video and streaming.

I did the same thing myself (clever me! :D), and I can confirm that there are no more micro stutters or pauses to interrupt my viewing pleasure.

So to conclude… if any other new Linux user that’s come over from the dark-side, has applied/installed the above one or both Applets and is experiencing the same micro stutters/pauses while viewing YouTube or Netflix, remove them... it may or may not help you, but it did me, and I send my thanks to the original poster who experienced this similar problem and to your fix.

Kadaitcha Man
Level 5
Level 5
Posts: 954
Joined: Mon Aug 27, 2012 10:17 pm

Re: Video micro stutters/pauses I found a fix for

Post by Kadaitcha Man »

oldbob wrote:
Sat Jan 25, 2020 4:03 pm
... remove them... it may or may not help you, but it did me, and I send my thanks to the original poster who experienced this similar problem and to your fix.
You've posted into the Newbie Questions forum. What is your question?
It's pronounced kad-eye-cha, not kada-itcha.

decrepit
Level 4
Level 4
Posts: 298
Joined: Mon Dec 03, 2018 4:07 am
Location: Mandurah Western Australia

Re: Video micro stutters/pauses I found a fix for

Post by decrepit »

So I'll add a question here, "if we stumble on a useful fix, where do we post it so it comes up in a search?"

User avatar
smurphos
Level 15
Level 15
Posts: 5931
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Video micro stutters/pauses I found a fix for

Post by smurphos »

It would be a good for information type post in the Cinnamon sub-forum.

Interesting finding - reproduces for me albeit I can only detect the stutters on one of those tearing test type videos on youtube.

Ought to be posted as a bug report against the applets noted as causing the issue on https://github.com/linuxmint/cinnamon-s ... ets/issues
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

oldbob
Level 1
Level 1
Posts: 45
Joined: Thu Jan 02, 2020 8:54 am

Re: Video micro stutters/pauses I found a fix for

Post by oldbob »

Kadaitcha Man wrote:
Sat Jan 25, 2020 8:43 pm
oldbob wrote:
Sat Jan 25, 2020 4:03 pm
... remove them... it may or may not help you, but it did me, and I send my thanks to the original poster who experienced this similar problem and to your fix.
You've posted into the Newbie Questions forum. What is your question?
Sorry, there is no question.

I posted it here as this is the first stop for all new users who have questions relating to various quirks or problems they've run into, I just thought it would help them out.

Can a mod please move this the the appropriate sub forum please.

Post Reply

Return to “Newbie Questions”