Time is off by 8 hours <SOLVED>

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
pergelator
Level 1
Level 1
Posts: 36
Joined: Mon Apr 02, 2018 4:47 pm

Time is off by 8 hours <SOLVED>

Post by pergelator »

Just installed lastest version of Linux Mint and the time is off by 8 hours. Nothing in the Date and Time Settings seems to have any effect.
Last edited by pergelator on Mon Feb 17, 2020 7:57 pm, edited 1 time in total.

User avatar
karlchen
Level 20
Level 20
Posts: 12264
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Time is off by 8 hours

Post by karlchen »

Hello, pergelator.

Please, be so kind to provide a few more basic, but relevant system details. Please, open a terminal window.
  • Execute the commandline inxi -Fxxxz precisely as typed here.
    Mark the complete text output, which it will display, with your mouse.
    Press <Ctrl><Shift>C to copy the marked text into your clipboard.
    Paste it into your next reply, please.
  • Execute the commandline timedatectl precisely as typed here.
    Mark the complete text output, which it will display, with your mouse.
    Press <Ctrl><Shift>C to copy the marked text into your clipboard.
    Paste it into your next reply, please.
  • Are you dual-booting Mint and Windows on the same machine?
  • What is your timezone, please?
Best regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

pergelator
Level 1
Level 1
Posts: 36
Joined: Mon Apr 02, 2018 4:47 pm

Re: Time is off by 8 hours

Post by pergelator »

No Windows on this machine, Linux Mint only.
Booting from external USB hard drive.
Pacific time zone

Code: Select all

mint@mint:~$ inxi -Fxxxz
System:    Host: mint Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.5 wm: muffin 4.4.1 
           dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq Pro 4300 SFF PC v: N/A serial: <filter> Chassis: type: 3 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 2ADE v: 1.0 serial: <filter> BIOS: AMI v: 8.11 date: 03/08/2013 
CPU:       Topology: Dual Core model: Intel Pentium G640 bits: 64 type: MCP arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11174 
           Speed: 1597 MHz min/max: 1600/2800 MHz Core speeds (MHz): 1: 1596 2: 1596 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:0102 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa resolution: 1680x1050~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Desktop v: 3.3 Mesa 19.0.8 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.0.0-32-generic 
Network:   Device-1: Broadcom and subsidiaries NetLink BCM57788 Gigabit Ethernet PCIe vendor: Hewlett-Packard driver: tg3 
           v: 3.137 port: f040 bus ID: 05:00.0 chip ID: 14e4:1691 
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 223.58 GiB used: 109.66 GiB (49.0%) 
           ID-1: /dev/sda vendor: Samsung model: HE160HJ size: 149.05 GiB speed: 3.0 Gb/s serial: <filter> rev: 0-24 
           temp: 26 C scheme: GPT 
           ID-2: /dev/sdc type: USB vendor: Generic model: USB size: 74.53 GiB serial: <filter> rev: 9.02 scheme: MBR 
Partition: ID-1: / size: 1.87 GiB used: 1.61 GiB (86.3%) fs: overlay source: ERR-102 
           ID-2: swap-1 size: 7.87 GiB used: 903.0 MiB (11.2%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 28.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 193 Uptime: 3d 7h 42m Memory: 3.74 GiB used: 779.3 MiB (20.4%) Init: systemd v: 237 runlevel: 5 
           Compilers: gcc: 7.4.0 alt: 7 Shell: bash v: 4.4.20 running in: gnome-terminal inxi: 3.0.32 

Code: Select all

mint@mint:~$ timedatectl
                      Local time: Mon 2020-02-17 12:21:37 UTC
                  Universal time: Mon 2020-02-17 12:21:37 UTC
                        RTC time: Mon 2020-02-17 12:21:37
                       Time zone: Etc/UTC (UTC, +0000)
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

User avatar
karlchen
Level 20
Level 20
Posts: 12264
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Time is off by 8 hours

Post by karlchen »

Hello, pergelator.

The explanation why your system time is off by 8 hours - I assume the system time is 8 hours ahead of your local time (timezone PST):
Your machine does not know about your local time zone.
Seems as if you have never configured your timezone on the machine in any way.

Code: Select all

mint@mint:~$ timedatectl
                      Local time: Mon 2020-02-17 12:21:37 UTC
                  Universal time: Mon 2020-02-17 12:21:37 UTC
                        RTC time: Mon 2020-02-17 12:21:37
                       Time zone: Etc/UTC (UTC, +0000)
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no
All timezone details only mention UTC. UTC corresponds to British Greenwich meantime without DST.

You should configure your timezone on the machine and let it know that you are living in the PST timezone.

HTH,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

pergelator
Level 1
Level 1
Posts: 36
Joined: Mon Apr 02, 2018 4:47 pm

Re: Time is off by 8 hours

Post by pergelator »

I click on the date in the lower right corner of the screen, which brings up the time and date dialog box. I click on "Date & Time Settings" at the bottom of this dialog and it brings up another time and date dialog box which appears to allow you to set the time zone, which I do, but nothing happens, except my clock is now off by 4 hours instead of 8.
Image
Image
Checking "Network Time" does not see to have any effect.

JeremyB
Level 20
Level 20
Posts: 11463
Joined: Fri Feb 21, 2014 8:17 am

Re: Time is off by 8 hours

Post by JeremyB »

Click near your area on the world map, that might fix the issue

pergelator
Level 1
Level 1
Posts: 36
Joined: Mon Apr 02, 2018 4:47 pm

Re: Time is off by 8 hours

Post by pergelator »

Clicking on the map seems to change the time, though the map's behavior is a little odd. Clicking on a time zone sometimes gets you a city in the zone, but highlights the adjacent zone. But it does change the time immediately. So this fixes my immediate problem, but the dialog box still has problems.

rene
Level 14
Level 14
Posts: 5200
Joined: Sun Mar 27, 2016 6:58 pm

Re: Time is off by 8 hours <SOLVED>

Post by rene »

pergelator wrote:
Mon Feb 17, 2020 7:56 pm
Clicking on a time zone sometimes gets you a city in the zone, but highlights the adjacent zone.
Ha. You must've clicked just when the earth spun one timezone on....

Post Reply

Return to “Newbie Questions”