Trying to correct an incorrect file title [Overcome]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Trying to correct an incorrect file title [Overcome]

Post by norm.h »

The last post in this thread refers.

viewtopic.php?p=1765010#p1765010

I think I need to change the file title from disable-usb-wake.conf.text to disable-usb-wake.conf, but my knowledge of the CLI is so poor, I don't know, and can't find out how to do it.

I realise that it's in etc so must be done with sudo.

Any help will be much appreciated.
Last edited by norm.h on Thu Feb 20, 2020 3:50 pm, edited 1 time in total.

User avatar
JerryF
Level 12
Level 12
Posts: 4262
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Trying to correct an incorrect file title

Post by JerryF »

In File Manager, when you're in the /etc directory, right-click on an empty space and choose "Open as root". This will open File Manager as another window.

Right-click "disable-usb-wake.conf.text" file and remove ".text"

Make sure to close the File Manager that was opened as root.
IF your problem has been solved, please edit your ORIGINAL post and add [SOLVED] to the beginning of the Subject Line. It helps other members when browsing posts.

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title

Post by norm.h »

Thanks for replying.
JerryF wrote:
Thu Feb 20, 2020 8:33 am
In File Manager, when you're in the /etc directory, right-click on an empty space and choose "Open as root". ...
I don't get that option..

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title

Post by norm.h »

I have tried to change the file title using the mv command with and without sudo, but I get

Code: Select all

normh@normh-nSpire2:~$ mv disable-usb-wake.conf.text  disable-usb-wake.conf
mv: cannot stat 'disable-usb-wake.conf.text': No such file or directory
normh@normh-nSpire2:~$ 
But the file does exist....
Screenshot at 2020-02-19 17-32-44.png
Screenshot at 2020-02-19 17-32-44.png (6.43 KiB) Viewed 241 times

User avatar
pbear
Level 11
Level 11
Posts: 3982
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Trying to correct an incorrect file title

Post by pbear »

Needs sudo:

Code: Select all

sudo mv disable-usb-wake.conf.text disable-usb-wake.conf
BTW, all three desktops have the Open as Root option for File Manager, except
it's called Open as Administrator in MATE. Which desktop are you using?
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title

Post by norm.h »

I'd already tried sudo but tried again and still get.....

Code: Select all

normh@normh-nSpire2:~$ sudo mv disable-usb-wake.conf.text disable-usb-wake.conf
[sudo] password for normh:          
mv: cannot stat 'disable-usb-wake.conf.text': No such file or directory
normh@normh-nSpire2:~$ 
I'm using Mate.
Which ever way I go into file Manager I still can't get 'open as root'

User avatar
Schultz
Level 7
Level 7
Posts: 1874
Joined: Thu Feb 25, 2016 8:57 pm

Re: Trying to correct an incorrect file title

Post by Schultz »

What you need to do is right click the etc folder, then you will get the option to "Open as administrator." Once you open /etc as administrator, then you can make whatever changes inside of /etc that need made.

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title

Post by norm.h »

I have Nemo and Caja installed and Caja is in use.
I found this https://forum.manjaro.org/t/mate-caja-h ... tion/55070
But don't understand it - which 'location bar' do they mean?

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title

Post by norm.h »

Schultz wrote:
Thu Feb 20, 2020 1:27 pm
What you need to do is right click the etc folder, then you will get the option to "Open as administrator." Once you open /etc as administrator, then you can make whatever changes inside of /etc that need made.
I simply don't get the option to Open as Administrator
I've also tried sudo caja without success.

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title

Post by norm.h »

Success!

I gave up on trying to correct the file title, and just wrote a new file with the correct title.
/etc/tempfiles.d now contains both files, but the original issue has been overcome - ie shutting the laptop lid to go into and stay in, 'suspend' with wifi mouse ON works fine.

All that remains is to find why I don't get "Open as Administrator" for Caja, but that's an issue for another day and another topic, so I'll mark this on 'solved'

User avatar
JOPETA
Level 16
Level 16
Posts: 6432
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Trying to correct an incorrect file title [Overcome]

Post by JOPETA »

norm.h wrote:
Thu Feb 20, 2020 3:49 pm
All that remains is to find why I don't get "Open as Administrator" for Caja, but that's an issue for another day and another topic, so I'll mark this on 'solved'
There is no problem with that. You need to select something (folder or file) or that option wont be shown. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)

User avatar
Schultz
Level 7
Level 7
Posts: 1874
Joined: Thu Feb 25, 2016 8:57 pm

Re: Trying to correct an incorrect file title [Overcome]

Post by Schultz »

You don't get this at all? I'd be concerned about that. Can you post a screenshot?

open.as.admin.jpg

User avatar
JerryF
Level 12
Level 12
Posts: 4262
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Trying to correct an incorrect file title

Post by JerryF »

norm.h wrote:
Thu Feb 20, 2020 9:05 am
Thanks for replying.
JerryF wrote:
Thu Feb 20, 2020 8:33 am
In File Manager, when you're in the /etc directory, right-click on an empty space and choose "Open as root". ...
I don't get that option..
Sorry. I'm using Xfce and my file manager is Thunar. I can right-click on an empty space and choose "Open as root"
Click to enlarge
Click to enlarge
IF your problem has been solved, please edit your ORIGINAL post and add [SOLVED] to the beginning of the Subject Line. It helps other members when browsing posts.

User avatar
pbear
Level 11
Level 11
Posts: 3982
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Trying to correct an incorrect file title [Overcome]

Post by pbear »

Of course it works in Caja:
.
CajaAsAdmin.png
.
Notice location of pointer.


Ditto for Nemo:
.
NemoAsRoot.png
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
smurphos
Level 15
Level 15
Posts: 5944
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Trying to correct an incorrect file title [Overcome]

Post by smurphos »

norm.h wrote:
Thu Feb 20, 2020 1:23 pm
I'd already tried sudo but tried again and still get.....

Code: Select all

normh@normh-nSpire2:~$ sudo mv disable-usb-wake.conf.text disable-usb-wake.conf
[sudo] password for normh:          
mv: cannot stat 'disable-usb-wake.conf.text': No such file or directory
normh@normh-nSpire2:~$ 
I'm using Mate.
Which ever way I go into file Manager I still can't get 'open as root'
I know you've resolved the presenting issue but your problem was not giving the full path of the file. The command should have been

Code: Select all

sudo mv /etc/tmpfiles.d/disable-usb-wake.conf.text /etc/tmpfiles.d/disable-usb-wake.conf
For the lack of the Open as Administrator option in Caja run

Code: Select all

apt install --reinstall caja-admin
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

norm.h
Level 5
Level 5
Posts: 585
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Trying to correct an incorrect file title [Overcome]

Post by norm.h »

Tried apt install --reinstall caja-admin but it made no difference.

I fear I've inadvertently misled you good folks - this post explains...
viewtopic.php?p=1765930#p1765930

Please accept my sincere apologies :oops:

Post Reply

Return to “Newbie Questions”