Mint 18.3 & Latest Chrome Version still crashing.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
RavingLoony
Level 1
Level 1
Posts: 12
Joined: Mon Apr 30, 2012 2:44 pm

Mint 18.3 & Latest Chrome Version still crashing.

Post by RavingLoony »

Hello, although I've got the impression that this is either fixed or not as bad an issue, it is still crashing (but taking longer to get to the abend) on my machine. Is there a fix? I still think of myself as a newbie although on & off I've been using Mint for around 4 years, but all mainly through Cinnamon. I've read stuff about preload & not totally understood the discussion & I don't think this features under my version of Mint.
This is all the more annoying, because up until this issue, I'd experienced many years of uninterrupted use & the benefits of Linux being much more reliable than my Windows 10 platform, which sadly is now reversed.
Below is status of my machine & Linux using the inxi command. Would it help if I updated to 19.xx? Or do I install ubuntu (I'm already trying Ubuntu under Windows Sub-system for Linux but without a desktop which it doesn't support - making me use the command line which is maybe not a bad thing).
Any help greatly appreciated - can't believe this is still happening.
******************************************************************************

harry@harry-Latitude-E6230 ~ $ inxi -Fxxxrz
System: Host: harry-Latitude-E6230 Kernel: 4.15.0-96-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
Distro: Linux Mint 18.3 Sylvia
Machine: System: Dell (portable) product: Latitude E6230 v: 01
Mobo: Dell model: 0F0C2R v: A00 Bios: Dell v: A15 date: 08/19/2015
Chassis: type: 9
CPU: Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10366
clock speeds: min/max: 1200/3300 MHz 1: 2439 MHz 2: 1486 MHz
3: 1465 MHz 4: 2039 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0 chip-ID: 8086:0166
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.14hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card Intel 7 Series/C216 Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1e20
Sound: Advanced Linux Sound Architecture v: k4.15.0-96-generic
Network: Card-1: Intel 82579LM Gigabit Network Connection (Lewisville)
driver: e1000e v: 3.2.6-k port: f080
bus-ID: 00:19.0 chip-ID: 8086:1502
IF: eno1 state: down mac: <filter>
Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
driver: iwlwifi bus-ID: 02:00.0 chip-ID: 8086:0082
IF: wlp2s0 state: up mac: <filter>
Drives: HDD Total Size: 128.0GB (25.9% used)
ID-1: /dev/sda model: Samsung_SSD_840 size: 128.0GB serial: S12PNEAD280692L
Partition: ID-1: / size: 110G used: 24G (23%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.49GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 45.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://www.mirrorservice.org/sites/pack ... m/packages sylvia main upstream import backport
deb http://mirror.ox.ac.uk/sites/archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb http://mirror.ox.ac.uk/sites/archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http://mirror.ox.ac.uk/sites/archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ xenial partner
Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
deb [arch=amd64] https://repo.skype.com/deb stable main
Info: Processes: 212 Uptime: 8 min Memory: 945.7/7880.5MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35
harry@harry-Latitude-E6230 ~ $
Koning Mint

Re: Mint 18.3 & Latest Chrome Version still crashing.

Post by Koning Mint »

RavingLoony wrote:
Tue Apr 14, 2020 6:58 am
Hello, although I've got the impression that this is either fixed or not as bad an issue, it is still crashing (but taking longer to get to the abend) on my machine. Is there a fix?
Harry, already tried to re-install chrome?
User avatar
RavingLoony
Level 1
Level 1
Posts: 12
Joined: Mon Apr 30, 2012 2:44 pm

Re: Mint 18.3 & Latest Chrome Version still crashing.

Post by RavingLoony »

Yes, a few times uninstall then reinstall & now just leave it to update. It is the latest version from Google. Did have Chromium installed but used to get the same errors so abandoned that as it produced the same results. Did a search across other parts of the Linux community & ran chrome without extensions from terminal. It failed again & running from a terminal logged the errors, which I've saved to a text file attached in case anyone can shed light.
Regards
Attachments
Chrome run from terminal sans extns & output.odt
chrome from terminal sans extensions showing errors.
(16.21 KiB) Downloaded 13 times
User avatar
trytip
Level 13
Level 13
Posts: 4978
Joined: Tue Jul 05, 2016 1:20 pm

Re: Mint 18.3 & Latest Chrome Version still crashing.

Post by trytip »

RavingLoony wrote:
Tue Apr 14, 2020 8:06 am
Yes, a few times uninstall then reinstall & now just leave it to update. It is the latest version from Google. Did have Chromium installed but used to get the same errors so abandoned that as it produced the same results. Did a search across other parts of the Linux community & ran chrome without extensions from terminal. It failed again & running from a terminal logged the errors, which I've saved to a text file attached in case anyone can shed light.
Regards
you know i don't appreciate clicking on a link and downloading stuff directly. if you have outputs to report put them here in CODE brackets or learn how to post to pastebin and other servers.

so please run google-chrome-stable in Terminal and post the results here in CODE BRACKETS
Image
User avatar
RavingLoony
Level 1
Level 1
Posts: 12
Joined: Mon Apr 30, 2012 2:44 pm

Re: Mint 18.3 & Latest Chrome Version still crashing.

Post by RavingLoony »

Code: Select all

harry@harry-Latitude-E6230 ~ $ google-chrome-stable
[3571:3571:0424/123236.558038:ERROR:browser_switcher_service.cc(238)] XXX Init()
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:(tg)kill() failure
--2020-04-24 12:32:47--  https://clients2.google.com/cr/report
Resolving clients2.google.com (clients2.google.com)... 172.217.169.78, 2a00:1450:4009:819::200e
Connecting to clients2.google.com (clients2.google.com)|172.217.169.78|:443... connected.
HTTP request sent, awaiting response... [3701:1:0424/123247.888909:ERROR:command_buffer_proxy_impl.cc(125)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.
200 OK
Length: unspecified [text/plain]
Saving to: ‘/dev/fd/4’

Crash dump id: 8c152f0141f51745

     0K                                                        1.60M=0s

2020-04-24 12:32:48 (1.60 MB/s) - ‘/dev/fd/4’ saved [16]

[3725:1:0424/123250.375215:ERROR:command_buffer_proxy_impl.cc(125)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.
[1,2656884672:11:32:52.629062] Native Client module will be loaded at base address 0x0000494700000000

OK I'm not sure if I've done this correctly as there is little or no clue either in your response or on this board about what you mention. I thought I'd made it clear that I'm a newbie so I've spent on & off over the past couple of weeks trying to understand what exactly I need to do. I've done my best which may not be very good but I'd suggest being helpful in future may help the inexperienced. BTW I do have 42 years earning my living in IT, just not with Linux so am not a totally clueless.
There is a difference in that this mornings Mint update had another version of stable chrome. I was able to use it for over an hour & thought maybe the problem has been fixed. It then failed & subsequent failures occur at the same rate as before.
If I've done this incorrectly I apologise.
greenpossum
Level 2
Level 2
Posts: 95
Joined: Wed Apr 10, 2019 5:01 pm

Re: Mint 18.3 & Latest Chrome Version still crashing.

Post by greenpossum »

RavingLoony wrote:Did have Chromium installed but used to get the same errors so abandoned that as it produced the same results.

There's not many reports of the problem you're having which usually points to a problem specific to your environment/installation.
I'm running a Chromium based browser (Opera) on LM 18.3 (Intel Ivy Bridge CPU + Intel HD Graphics 4000) without any issues, however I'm running kernel 4.10.x.x while you've updated to 4.15.0-96.

Can you recall when the problem first occurred? Did you install any new programs or updates (including kernel updates) around that time?
To view update history: start the Update Manager, View -> History of updates.
To view installed software: start the Software Manager, Settings -> Show installed applications

Could other installed user apps be interfering with chrome? Sometimes installed user apps can interfere with other by changing the contents of shared areas such as /home/<user>/.local

This is an example of an app (antivirus) interfering with the operation of another (chrome). ESET NOD32 - Chrome 79 crashes in Linux

Try booting into linux then stopping all other running user apps before starting chrome. Alternatively, disable all other user apps from running at startup then reboot.
User avatar
trytip
Level 13
Level 13
Posts: 4978
Joined: Tue Jul 05, 2016 1:20 pm

Re: Mint 18.3 & Latest Chrome Version still crashing.

Post by trytip »

RavingLoony wrote:
Fri Apr 24, 2020 8:00 am
BTW I do have 42 years earning my living in IT, just not with Linux so am not a totally clueless.
If I've done this incorrectly I apologise.
42 years in IT i would think you are versed enough to research your own failures and no more apologizing for being a linux noob. we were all noobs in many aspects of life including windows 95, did we go on forums when we switched from win 3.1 cause we had no idea how to use it? the way i research my failures is pick a good keyword or string output from terminal and put it in a google search or whatever search you use. i have not come across your error, why would i know how to fix that unless i go do the searching for you.

you can also maybe you have extension problems, so start with fresh one rename it's .config folder .config/google-chrome/ and then undo if it's the same
Image
Post Reply

Return to “Newbie Questions”