Wine not installing "You have held broken packages"

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
EagleDev333
Level 1
Level 1
Posts: 2
Joined: Wed May 06, 2020 6:48 pm

Wine not installing "You have held broken packages"

Post by EagleDev333 »

I'm using mint 19.3 and tried to install wine with the store, but it says wine "Isn't available." Then I tried using snap. Then I tried installing wine through the terminal with the instructions on wine's website, but I get this:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.0~bionic)
E: Unable to correct problems, you have held broken packages.

Is there any way to install wine on my version of mint without getting an error?
fargodwe
Level 3
Level 3
Posts: 110
Joined: Mon Oct 02, 2017 2:08 am

Re: Wine not installing "You have held broken packages"

Post by fargodwe »

Did you try going to winehq and actually using the packages there? If that message is from after you did I would suggest you go back and remove anything you tried to install before. Remove the packages in synaptic package manager and the other tool you used. Then try again using only the winehq instructions. The packages in the repositories are usually behind those at winehq and I could see the presence of those messing up any further attempts. I run Wine in mint 19.3 and have run it in previous releases for a long time. If you follow their installation instructions it gives step-by-step how to install. I would highly recommend you try that. If you have questions please post back.
CapraFan
Level 1
Level 1
Posts: 33
Joined: Fri Jul 19, 2019 9:35 pm

Re: Wine not installing "You have held broken packages"

Post by CapraFan »

Don't overlook the sticky:

viewtopic.php?f=90&t=314921
pbear
Level 14
Level 14
Posts: 5206
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Wine not installing "You have held broken packages"

Post by pbear »

CapraFan wrote:
Wed May 06, 2020 7:41 pm
Don't overlook the sticky:

viewtopic.php?f=90&t=314921
+1

EagleDev333, at this point, your package management system probably is hopelessly confused. You need to clear out the prior attempts by restoring a Timeshift snapshot, then follow the linked instructions. This will install Wine 4.0, which is fine for almost all purposes.
EagleDev333
Level 1
Level 1
Posts: 2
Joined: Wed May 06, 2020 6:48 pm

Re: Wine not installing "You have held broken packages"

Post by EagleDev333 »

Alright, thanks for the help I'll see what works.
Post Reply

Return to “Newbie Questions”