Can I still use 17.3?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Locked
Vilsen
Level 4
Level 4
Posts: 471
Joined: Thu Nov 16, 2017 4:45 am

Re: Can I still use 17.3?

Post by Vilsen »

can someone give a sensible answer instead of joking about it!
User avatar
JoeFootball
Level 10
Level 10
Posts: 3158
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Can I still use 17.3?

Post by JoeFootball »

Vilsen wrote: can someone give a sensible answer instead of joking about it!
Last time (no joke): viewtopic.php?f=143&t=235992

Linux Mint 18.x will be supported until April 2021.

Linux Mint 19.x will be supported until April 2023.

Linux Mint 20.x will be supported until April 2025.
User avatar
Dark Owl
Level 4
Level 4
Posts: 311
Joined: Sat May 02, 2020 7:43 am
Location: Brit

Re: Can I still use 17.3?

Post by Dark Owl »

Vilsen wrote:
Tue Aug 04, 2020 1:38 pm
can someone give a sensible answer instead of joking about it!
Why do you think my posts are a joke? I'm absolutely serious: you do not need to upgrade/update unless you have a specific reason to.
Dark Owl wrote:
Tue Aug 04, 2020 10:01 am
From one of the links linked to above (https://community.linuxmint.com/tutorial/view/2):
If things are working fine and you're happy with your current system, then you don't need to upgrade.

A new version of Linux Mint is released every 6 months. It usually comes with new features and improvements but there's nothing wrong with sticking with the release you already have. In fact, you could skip many releases and stick with the version that works for you.

Each release receives bug fixes and security updates for about 18 months (or 3 years in the case of "Long Term Support" releases such as Linux Mint 13). The development team is also focused on the latest release. If bug fixes and security updates are important to you, you should regularly upgrade to the latest releases, otherwise there's nothing wrong with keeping things as they are.

As a general rule... unless you need to, or unless you really want to, there's no reason for you to upgrade.
That sums up my own views exactly.
Currently: Linux Mint 20 Cinnamon 64-bit 4.6.6, AMD Ryzen5 + Geforce GT 710
Previously: LM20β, LM18.2
User avatar
GS3
Level 7
Level 7
Posts: 1914
Joined: Fri Jan 06, 2017 7:51 am

Re: Can I still use 17.3?

Post by GS3 »

Vilsen wrote:
Tue Aug 04, 2020 1:38 pm
can someone give a sensible answer instead of joking about it!
What was the question again? This thread is almost three months old and ten pages long and it has been all over the place and back. You have gotten opinions and advice from every direction and you have managed to argue with pretty much everybody and their sister. This thread has, in fact, become The Vilsen Show.

You are not really here looking for advice are you?
Please do not use animated GIFs in avatars because many of us find them distracting and obnoxious. Thank you.
Vilsen
Level 4
Level 4
Posts: 471
Joined: Thu Nov 16, 2017 4:45 am

Re: Can I still use 17.3?

Post by Vilsen »

Yes I am !!

How can I upgrade my 18.3 (MATE) to 19.3 without
destroying all the work I have done ??
User avatar
JoeFootball
Level 10
Level 10
Posts: 3158
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Can I still use 17.3?

Post by JoeFootball »

Vilsen wrote: How can I upgrade my 18.3 (MATE) to 19.3 without
destroying all the work I have done ??
Fifth Time: viewtopic.php?f=143&t=235992
Vilsen
Level 4
Level 4
Posts: 471
Joined: Thu Nov 16, 2017 4:45 am

Re: Can I still use 17.3?

Post by Vilsen »

deepakdeshp
Level 18
Level 18
Posts: 8848
Joined: Sun Aug 09, 2015 10:00 am

Re: Can I still use 17.3?

Post by deepakdeshp »

Vilsen wrote:
Thu Aug 06, 2020 10:04 am
I missed the link:
https://community.linuxmint.com/tutorial/view/2416
viewtopic.php?f=143&t=235992
All the upgrades instructions.Right upto 20.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 / 8GB
Mint 20 Cinnamon AMD Ryzen3500U
Hoser Rob
Level 16
Level 16
Posts: 6943
Joined: Sat Dec 15, 2012 8:57 am

Re: Can I still use 17.3?

Post by Hoser Rob »

Vilsen wrote:
Tue Aug 04, 2020 1:38 pm
can someone give a sensible answer instead of joking about it!
You've had sensible answers and you just whine. And you can'\t seem to be bothered to use a search engine to solve easily solved problems. You're inviting ridicule. I'm done here. Good luck.
User avatar
BG405
Level 8
Level 8
Posts: 2415
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Can I still use 17.3?

Post by BG405 »

As this has turned out to be a mammoth thread, all I'd suggest is to clone the current disk and then attempt an upgrade to 18, then 19 and maybe 20 on the clone. That way there's nothing to lose.

If it works, great.

If it doesn't, then save all your configs/settings/whatever you want from your /home, note what applications you currently have, then on a clean disk make an install of whichever version you want, add in the configs, reinstall those programs and all your settings & customizations should be intact.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
Vilsen
Level 4
Level 4
Posts: 471
Joined: Thu Nov 16, 2017 4:45 am

Re: Can I still use 17.3?

Post by Vilsen »

And that is exactly what I am going to do !

Thanks for all good advice !
User avatar
Dark Owl
Level 4
Level 4
Posts: 311
Joined: Sat May 02, 2020 7:43 am
Location: Brit

Re: Can I still use 17.3?

Post by Dark Owl »

...but the question was "can I still use 17.3"! To which the answer is "yes".
Currently: Linux Mint 20 Cinnamon 64-bit 4.6.6, AMD Ryzen5 + Geforce GT 710
Previously: LM20β, LM18.2
User avatar
bob466
Level 6
Level 6
Posts: 1155
Joined: Mon May 15, 2017 5:23 am
Location: Australia

Re: Can I still use 17.3?

Post by bob466 »

My answer is...No as it is no longer supported and you're asking for trouble. Image

Don't put yourself at risk...Mint 19 Series is supported till 2023 and Mint 20 till 2025...it's better to be safe than sorry. Image
Linux For Ever...Windoze Never. Image
The Freedom To Choose Your Own Avatar Without Victimisation.
User avatar
Dark Owl
Level 4
Level 4
Posts: 311
Joined: Sat May 02, 2020 7:43 am
Location: Brit

Re: Can I still use 17.3?

Post by Dark Owl »

bob466 wrote:
Fri Aug 07, 2020 8:03 pm
My answer is...No as it is no longer supported and you're asking for trouble. Image

Don't put yourself at risk...Mint 19 Series is supported till 2023 and Mint 20 till 2025...it's better to be safe than sorry. Image
That's "shouldn't" rather than "can't", and is a matter of opinion rather than fact. If technical answers to technical questions stuck to fact rather than arguing over opinion, everyone would be a lot better off.
Currently: Linux Mint 20 Cinnamon 64-bit 4.6.6, AMD Ryzen5 + Geforce GT 710
Previously: LM20β, LM18.2
User avatar
GS3
Level 7
Level 7
Posts: 1914
Joined: Fri Jan 06, 2017 7:51 am

Re: Can I still use 17.3?

Post by GS3 »

bob466 wrote:
Fri Aug 07, 2020 8:03 pm
My answer is...No as it is no longer supported and you're asking for trouble. Image

Don't put yourself at risk...Mint 19 Series is supported till 2023 and Mint 20 till 2025...it's better to be safe than sorry. Image
We've already gone around the block several times in this thread and all we are doing is repeating what has already been said.

Upgrading has very real risks as witnessed by the many threads reporting trouble after upgrades. In fact, there is much more risk in upgrading than in not upgrading. Treating upgrading like there is no risk is completely misleading. And even if it works well in the end upgrading involves a substantial amount of time and effort.

The only one who can make an informed choice is the OP.

See my earlier (long) post in this same thread:
GS3 wrote:
Fri May 08, 2020 11:00 am
No matter how easy it is supposed to be before you start, everything takes much longer that you could even imagine it could take. Updates, upgrades and "improvements" have given me much more trouble and work than any malware or outdated software.

Each person is different and has different priorities. Only you can answer the question. If updating is something you don't enjoy doing, if you have any important data well backed up, if you do not feel any need to upgrade and you wold rather spend your time doing something else, then IMHO you can stay with LM17. If it ain't broke for you then there is no need to fix it.

Just my opinion. YMMV.
Please do not use animated GIFs in avatars because many of us find them distracting and obnoxious. Thank you.
User avatar
karlchen
Level 21
Level 21
Posts: 13688
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Can I still use 17.3?

Post by karlchen »

<Mod>
GS3 wrote:
Sat Aug 08, 2020 4:58 am
We've already gone around the block several times in this thread and all we are doing is repeating what has already been said.
Agreed. This thread strongly reminds of the movie "Groundhog Day". It keeps on dropping back to post #1 again and again. Closing the thread before another loop can start.
<Mod>
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Locked

Return to “Newbie Questions”