Page 1 of 2

Evaporating dialogue box?

Posted: Sun May 31, 2020 11:35 pm
by lilysotoo
Hello There!

I'm struggling to uninstall an application, specifically Zoom. I'd appreciate any help that someone might like to offer to me. I have linux mint cinnamon, 64 bit version. I'll put all of the other information from inxi - Fxxxrz below my question. If I forgot any of the question asking protocol, I apologize and would be happy to supplement with more details. Alternately, if there's just a better way for me to have asked or ask this question, I'd be super grateful to know that too.

I think I've managed to change the administrative password through terminal commands, by looking at other posts on this forum, though I've discovered that I still weirdly don't have access to some files on my hard drive. I don't know if that is related to my main problem in trying to uninstall this app, however? :?

My main issue is that when I access a dialogue box which says, 'please provide your password to uninstall this application', I type my password into the dialogue box to authorize deinstallation, and then the whole process just evaporates into the ether. :cry:

Like, the dialogue box just disappears and nothing else happens.

If anyone has any ideas about even what I might try, I'd be super happy to try any course of action. Thanks for considering my question during a time when people are literally fighting for the right to live through a number of painful realities. I guess that's been the case for as long as I've lived though, truly.

System: Host: Lily-HP-Pavilion-g6-Notebook-PC Kernel: 4.4.0-179-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
Distro: Linux Mint 18.1 Serena

Machine: System: Hewlett-Packard (portable) product: HP Pavilion g6 Notebook PC v: 068A130014204710000620100
Mobo: Hewlett-Packard model: 1695 v: KBC Version 15.1F
Bios: Hewlett-Packard v: F.37 date: 01/16/2013
Chassis: type: 10

CPU: Dual core Intel Pentium B940 (-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3) bmips: 7982
clock speeds: min/max: 800/2000 MHz 1: 999 MHz 2: 1000 MHz

Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
bus-ID: 00:02.0 chip-ID: 8086:0106
Display Server: X.Org 1.18.4 driver: vesa
Resolution: 1024x768@0.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1c20
Sound: Advanced Linux Sound Architecture v: k4.4.0-179-generic

Network: Card-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
driver: rtl8192ce port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8176
IF: wlo1 state: up mac: <filter>
Card-2: Realtek RTL810xE PCI Express Fast Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 2000
bus-ID: 03:00.0 chip-ID: 10ec:8136
IF: enp3s0 state: down mac: <filter>

Drives: HDD Total Size: 250.1GB (8.4% used)
ID-1: /dev/sda model: ST250LT007 size: 250.1GB serial: W0Q10YVC

Partition: ID-1: / size: 226G used: 16G (8%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.21GB used: 0.00GB (0%) fs: swap dev: /dev/sda5

RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none

Sensors: System Temperatures: cpu: 48.0C mobo: 0.0C
Fan Speeds (in rpm): cpu: N/A

Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb serena main upstream import backport #id:linuxmint_main
deb xenial main restricted universe multiverse
deb xenial-updates main restricted universe multiverse
deb xenial-backports main restricted universe multiverse
deb xenial-security main restricted universe multiverse
deb xenial partner

Info: Processes: 162 Uptime: 40 min Memory: 953.6/3898.4MB
Init: systemd v: 229 runlevel: 5 default:
Gcc sys: 5.4.0
Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35

Re: Evaporating dialogue box?

Posted: Mon Jun 01, 2020 7:38 pm
by LanceM
Where did you get the package? From the Software Manager, or did you download the .deb?

Re: Evaporating dialogue box?

Posted: Mon Jun 01, 2020 10:56 pm
by lilysotoo
Thank you so much for replying!

I downloaded Zoom, so maybe that means that I dowloaded the .deb?

Trying to remove Zoom however, caused me to wonder if this problem of the dialogue box exists in other ways, and when I try to modify anything or look at anything, all dialogue boxes seem to similarly disappear.

In trying to restore the dialogue box functions through terminal commands yesterday, in the way that I believe I read about on these forums through a search, I was told that I didn't have those privileges.

I apologize if I'm not answering your question well, or describing any of this in the correct manner.

I would really appreciate any advice that you might have, or that you took the time to reply at all.

Re: Evaporating dialogue box?

Posted: Mon Jun 01, 2020 11:13 pm
by LanceM
See what this command does:

Code: Select all

sudo apt-get purge --auto-remove zoom
If it shows that it can be uninstalled then answer Y for yes and hit enter.
Assuming that goes well, then run this command to remove dependencies:

Code: Select all

sudo apt-get autoremove
If the first command shows it's not on the system, then report back here for the next steps.

Re: Evaporating dialogue box?

Posted: Mon Jun 01, 2020 11:17 pm
by Reorx
Have you tried using Synaptic to remove ZOOM?

1) Open Synaptic and search for ZOOM
&lt;Click to enlarge&gt;
<Click to enlarge>
2) Right click the box next to ZOOM and select either "Mark for Removal" or "Mark for Complete Removal"

3) Click "Apply" in the menu at the top.

4) Done!

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 1:30 pm
by lilysotoo
Thank you LanceM and Reorx! That really helped!!!

I was able to use synaptic to remove the old version of Zoom, which is great.

I'm still trying to resolve the dialogue box problem, or find a work around, or understand what I'm doing wrongly, or if there is something serious going on that causes them to vanish into the ether.

Should I mark this as resolved and write a new post, or continue below as follows?

I have the same problem with the dialogue boxes disappearing when I try to install the new downloaded deb for zoom (I was trying to uninstall the old version, because zoom wouldn't update, and this was suggested as a possible tactic)

On a whim, I tried to use the termimal with a similar command to the one you suggested LanceM for uninstall, to instead install. The message said i didn't have those privileges.

I think I tried something like "sudo apt --install zoom" It is possible i guess that I don't have the privileges because I worded the command wrongly, and it made no sense?

I really appreciate both of your help so far, and also would be grateful to know from anyone, if I should start a new thread, or, if since the dialogue boxes still evaporate, the main problem is still related to this thread? Thank you.

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 2:07 pm
by LanceM
I think I tried something like "sudo apt --install zoom"
Wrong input You can try the following, but the .deb is likely better because it includes the whole package. See the last comment at the end of this.

Code: Select all

sudo apt-get install zoom
First run

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get dist-upgrade
I installed zoom on my test machine Mint 19.3 Cinnamon using the .deb and it works fine. When you used the purge command, did it show it was installed? Also, did

Code: Select all

sudo apt-get autoremove
rid it of the dependency?
Do you have a Timeshift snapshot from before you installed zoom?
To use the .deb, Download it from here:
In the dropdown choose Mint. When downloaded click on install. Follow prompts. Make sure it's purged first off your system plus the autoremove command I gave you.

PS Don't start a new topic. As your post is about disappearing dialog. All the post pertain to addressing this.

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 4:52 pm
by lilysotoo
Hi LanceM,

Thank you for your reply. I used synaptic to remove the prior version of Zoom, before noticing that I could try the commands that you recommended, but it was definitely previously installed, since I downloaded it and had no issue with it for about 3 months.

I think that I had no issues with losing the dialog boxes when I first downloaded it, maybe in March of 2020? I noticed issues only a few days ago, while trying to find a solution for updating Zoom, which definitely resulted in these disappearing dialog boxes.

When I try "sudo apt-get autoremove"
Terminal asks me for a password with the line, "[sudo] password for lily: ". I enter my password and it replies, "Sorry, user lily is not allowed to execute '/usr/bin/apt - get autoremove' as root on (and then lists my computer name). When I use the administrative password that allows me into synaptic package manager it returns the message, "Sorry, try again".

I have already downloaded that .deb from Zoom, at that link many times. That is how the journey into these diappearing dialog boxes began!

My main problem has been that in trying to install that download, the installation dialog box evaporates. I get a package installer dialog box which states, "All dependencies are satisfied" in yellow highlighting at the top, I click the "Install Package" button at the lower right corner, and I get a dialog box that says, "You need to grant administrative rights to install software" This box asks me for a password. I enter my password and press "okay" and *poof* the dialog box disappears into some liminal space, which I can't discover.

The download currently sits in the location of tmp folder from mozilla downloads, so I can find it squatly waiting, and I can right click on it to get the option "Open with GDebi Package Installer" which then brings me back to the infinite loop of trying to use the package installer dialog box, it prompting for my password, me entering the password and then *poof* a renewed disappearance, like the process never happened. No error message, no nothing. Gone without a trace.

A tertiary problem is that in trying to install the download from synaptic, which I thought might be possible, since I was able to remove it through synaptic (which weirdly allows me in, through the admin password I recently changed in terminal), I cannot locate this download.

Is there a way to check if there's some other password at play here, and reset it, if there is a third password or user option, or something?

It also occurs to me though, that I may be misunderstanding what the synaptic package manager can do? Maybe it only deals in already installed packages, so to try to install anything through it, makes no sense?

Oh gosh, I'm laughing so hard, I think i understand what you mean by "Timeshift snapshot" before I installed Zoom, based on me generally understanding the meaning of the word "Timeshift" and the word "snapshot" ?

Yet, maybe I do not even know what you mean, and certainly I have no idea how I would procure such an image of that time before installation, and also how I would have the foresight to know when I needed to take such an image?

Like do you do that every time you make a change to your computer? Is there a toggle switch somewhere that, once checked, does that every time you make a change?

Or, does every computer already do that, and every person just needs to know where to look for it? Like, in my case in February 2020 or January 2020 would be a safe bet for when to look, because, that was pre-Zoom time for my computer, so could I just retrieve that from where the computer has it stored? I am just so ignorant. :shock: I apologize that I do not know the answers to your probably very easy questions.

Is there a good book that you could recommend, that would help me become a better computer owner, so that I understand all of the obviously many things that I'm not doing, or doing wrongly?

Thank you so much for trying to help me through my ignorance, and also for any other people who you have similarly helped, or will help. I very much appreciate your kindness.

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 5:05 pm
by lilysotoo
Okay, so also I just figured out that through synaptic, I can go to "add downloaded packages", then go to other locations, and then to tmp, and mozilla0 where the .deb was downloaded, at that point, I see the zoom .deb package but it is greyed out?

I click open, anyway even though I can't select it, and it all uh...disappears, perhaps unsurprisingly.ugh.

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 5:13 pm
by lilysotoo
Also in synaptic, I find in the history of installed, upgraded, and removed software packages, under yesterday's date, that the Commit Log (whatever that is) recorded "completely removed the following packages:

Does this mean also that any depency is resolved?

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 5:48 pm
by LanceM
This is a complex issue. The password problem may be the main thing broken. I really can't tell you a simple way to fix it, although there may be. Were it me, I'd go for a fresh install of Mint 19.3 or cripple along until Mint 20 is released in about a month. It's usually faster to reinstall Mint than try to fix a mess. Timeshift is a stellar app included in Mint. It will allow recovery from most problems. Easy to use. And: ... shift.html
If you do a fresh install, make sure to have just one password, and don't choose encryption or anything complicated. Ask questions on installation if need be. Is this a dual boot with Windows or is it stand alone Mint?

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 6:43 pm
by lilysotoo
It is standalone Mint.

I was somehow able to get terminal to accept my root password, and then to follow the terminal commands of your earlier post, LanceM!

So I ran the update and got the dist upgrade, as you suggested. A lot happened very quickly in the terminal!

Is it possible that it appears complex only because I don't know what I'm doing, nor how to properly communicate what is happening? :lol:

What's weird, is that I never set any encryption or additional passwords, I just found that the root had a different password while trying to figure out why I couldn't access these dialog boxes, stumbling around in terminal. Then I changed the root password, so I could use it, and access synaptic, by following other threads on this forum, or maybe just on linux advice threads in general, I don't remember, that was at least yesterday.

Oh gosh, somehow, by running those two commands, I was just able to actually access the zoom .deb and install it!

Do you think though, that something could be inherently wrong with my computer system, that still warrants the timeshift or fresh installation of Mint?

I'm sorry that this question is so ignorant, but is there a way for me to check to see if there are larger problems which caused my inability to perform these simple changes, or should I just trust that it was my ignorance that made this so difficult, which seems quite plausible.

Also, thank you so much for helping me to (I think) solve the original problem that brought me here! I so appreciate all of your help!!!

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 7:04 pm
by LanceM
Post the output of running this in the terminal.

Code: Select all

uname -r
Have you been updating your system regularly? I suggested the update command because your kernel looked out of date, but I couldn't verify because I don't have any 18.x Mint systems. It's possible your kernel was so far out of date, the system was compromised. Always do your updates. As far as Timeshift goes, I'd suggest to start using it. Read those 2 sites I linked. Also post the results of this command

Code: Select all


Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 7:28 pm
by lilysotoo
running uname -r in the terminal yielded

and the results of command 'df' were:
Filesystem 1K-blocks Used Available Use% Mounted on
udev 1972920 0 1972920 0% /dev
tmpfs 399200 6252 392948 2% /run
/dev/sda1 236189440 16872108 207296548 8% /
tmpfs 1995996 24988 1971008 2% /dev/shm
tmpfs 5120 4 5116 1% /run/lock
tmpfs 1995996 0 1995996 0% /sys/fs/cgroup
cgmfs 100 0 100 0% /run/cgmanager/fs
tmpfs 399200 32 399168 1% /run/user/1001

As for updates, no. I have not been updating the system at all. What would it mean if the system was compromised? Would having updated just now help that, or should I do something else? I'm sorry I didn't realize that this was important. I will read the sites that you linked, for sure. Thank you very much.

Re: Evaporating dialogue box?

Posted: Wed Jun 03, 2020 8:31 pm
by LanceM
You always should keep you system up to date. Use the Update Manager in the right corner of your panel. If it's blue, you need updates. If it has a green checkmark, it's up to date. You have plenty of space to make a Timeshift snapshot once in a while. I recommend not setting them to run automatically. Keep say three, and delete (using Timeshift) the oldest. Always create the new one before deleting the old one because it's much faster. Do this once every 2 weeks or so. If you are going to install something or twiddle, make a snapshot first so you can "fix" a mess if need be. Set it to look like the pic below. Your kernel is the newest one best I can tell.

Re: Evaporating dialogue box?

Posted: Fri Jun 12, 2020 12:31 am
by lilysotoo
Thank you so much for that reply LanceM!!! I apologize for my long delay in following up.

I finally had a chance to read what you linked to, install all of the many pending updates, and started setting up timeshift after getting it through synaptic. I also think that i now remember trying to get updates but the system would not update, and I just gave up trying when it had failed several times. I am now curious about why it failed, and surprised that i didn't look into it at the time!

Timeshift through the setup wizard, automatically selects a snapshot location that confuses me. It looks like, in "Computer", there's my file system, and like the dvd/cd player, which both are normal, and then there's this other unmounted file system named ST250LT007-9ZV14C. When I look at its properties, everything is "unknown", except the "Type", which is
"Unknown (application/octet-stream). I am unable to select my file system, instead of this unknown one.

Is it okay to set up a timeshift snapshot there, even though I don't know what it is? I mean I'm starting to realize that i don't know what most of my computer is, so there's also that. :lol:

Also, I would like to eventually be able to check this topic as solved, so that it's not just sitting here open forever. However, I still do have the weird problem of dialog boxes vanishing after I enter my password, even after changing my password both in the terminal and in the grub menu.

I really don't know why those processes don't complete, and even though I've mostly been able to uninstall and reinstall the newer version of Zoom through alternate methods, might a problem (or many problems?) be indicated by the fact that I can not enter my password to follow most actions to completion?

Thank you!!

Re: Evaporating dialogue box?

Posted: Fri Jun 12, 2020 11:29 am
by LanceM
Timeshift can only save snapshots to a Linux filesystem. Like Ext4. There are others, but you won't have them. The default location is your partition with the root directory, and likely what you would use. Having Timeshift save snapshots to an external drive, or another internal drive provides more recovery options, but not without more knowledge. As to your password issue and disappearing windows, it seems only reinstalling Mint will truly fix this. There is a way to disable needing the password to run most software. You still would need it to install software from the Software Manager and to do your updates. I can post how to do this if you want to try it in lieu of not doing a clean install. Bear in mind, if we disable the password requirement, someone with physical access to your PC could do harmful things. I don't have that problem and I disable the password requirement for convenience, and have done so for many years without issue. I would ordinarily not suggest this on the forum, but this is a unique situation.

Re: Evaporating dialogue box?

Posted: Fri Jun 12, 2020 5:42 pm
by lilysotoo
Hi LanceM,

Thank you so much for your reply!!!

What I'm looking at that seems weird to me, is that under "my computer", there are these two disks, one which says it can't be mounted and the one storing all of my data, while at the same time in another corner of the memory, under: menu, preferences, and disks, the Master boot record which is partitioned, has the identity of the unmountable disk from the view in my computer.

Is that an average situation, that I just don't understand, like do those two views usually contain such different information? To be clear, I'm not trying to save timeshift snapshots to this "unmountable" disk which is listed as the master boot record in the disk view, that is just the only option that I am given in timeshift, and I can't find another option.

I have changed the passwords for root, administration, and user, and they work for some things. I am able to install through synaptic, using my password, and able to run the updates. I am firmly locked out of removing programs I don't use, and also am told that i do not have permissions for several files in the file system including a "lost and found" file, and the "root" file. Both of these file icons have an "X" on them to show me that I can't access them.

If it doesn't seem like a big deal to have these issues, maybe I should just wait until the new version of Mint comes out to reinstall it, as I believe you previously suggested, or would it make sense to reinstall Mint now?

It seems unlikely that anyone would do something harmful to my physical computer right now, but that could potentially be a concern in the future, i guess?

I'm kind of more concerned about the combination of my own ignorance and not having a password, like it's a good reminder to me, to slow down and consider what I'm trying to do, and if that is a good choice?

I guess the main things i need help figuring out are:
1. Is this seemingly dual identity hard drive/disk situation okay?
2. Relatedly, is it okay to save the timeshift snapshot to the "unknown" volume hard disk?
3. If not okay to save it there, how could i get timeshift to give me options about where to save it?
4. Lastly, should I wait to reinstall Mint until the new version, or just go ahead and do it now?

I think I want to not disable passwords at this point.

Thank you very much for discussing my confusion with me and trying to help me find options. I wish I were a better narrator of the situation.

* It seems that I can use my password to open the root file or the lost and found file, if i right click and open these "as root".

Re: Evaporating dialogue box?

Posted: Fri Jun 12, 2020 6:14 pm
by LanceM
I guess the main things i need help figuring out are:
1. Is this seemingly dual identity hard drive/disk situation okay?
2. Relatedly, is it okay to save the timeshift snapshot to the "unknown" volume hard disk?
3. If not okay to save it there, how could i get timeshift to give me options about where to save it?
4. Lastly, should I wait to reinstall Mint until the new version, or just go ahead and do it now?
To answer these questions please follow this guide and post a report: viewtopic.php?f=90&t=318644
Also run this in the Terminal and post the output:

Code: Select all


Re: Evaporating dialog box?

Posted: Wed Jul 01, 2020 12:50 am
by lilysotoo
Hello LanceM, or anyone, if you are understandably tired of trying to help me.

Well, I got help installing 19.3, I believe a day before 20 was released because my OS issues had progressed and I was having difficulty booting.

It is hard for me to believe this but I now perhaps have more significant troubles than I did when I was having trouble booting.

I'm a writer and had many projects stored on my hard drive. I did not have an external back up, which obviously I will never do again, if I'm able to not die from the loss of years of work that I may have just created for myself.

I am not sure that the person who helped me to install the new OS of Cinnamon Mint 19.3, as kind as they were to help me to figure that out, actually did back up any of my libre files? I don't really care about the music or pictures, sure those are losses but whatever. If the written files do exist (oh my god, please, please let there be some hope that they still exist, ffs. It is just now hitting me what a loss this could be, and I cannot stop crying) could someone please tell me where and how I might locate them in order to restore them?

I had installed timeshift as LanceM had suggested (though i don't know if that even backs up libre files?), and there was a snapshot from before the new install, but when I rebooted after the install, I was asked to reinstall timeshift again, so possibly that old version of timeshift is gone even if my docs were there? There is also no partition in my disk now, which makes me nervous for several reasons, most of which have to do with these missing documents, but some of which also are just like, do I need a partition, I mean actually who cares, if my writing is gone, the computer is probably just a doorstop or something in that event.

I also have a bunch of meetings to attend via Zoom, and even though I had been able to install the updated version of zoom on 18.3 before it became unstable in booting, I now cannot install Zoom on 19.3 at all, so if anyone would like to help me figure that out, I would super appreciate help there as well? It downloads and then gets stuck at package installer with this weird half message highlighted in red that states, "...g architecture 'amd64 --Run dpkg --add-architecture to add it and update afterwards'.

Some facts about my current inability to download Zoom are similar to my prior experiences on 18.3, listed above. I can find it in Synaptic Package Manager, but it is greyed out and I can't add it, for installation. It is just stuck in the package installer with that weird highlighted message. I tried a few commands in sudo based loosely on that error message, but sudo doesn't know what I mean, because I don't really know what I mean.

I also, in my panicked state of alternately being unable to find my writing and unable to install Zoom, have somehow created inert Zoom files on my desktop, and in some other places, and I think that this somehow was from an archive? If Zoom was archived, could my writing please, please, please also somehow be archived?

I will really appreciate any ideas, advice, directions, or any kind of mercy anyone might show me at this point. I am super miserable and confused, and don't know what to try next. Thanks for reading if nothing else.