Page 1 of 1

[SOLVED] MATE panel not showing after reboot following update of xserver

Posted: Tue Jun 30, 2020 8:56 pm
by yellowfinch
[Edit: I had originally titled this topic “...following update of kernel”.]

I doubt that the problem is related to the kernel update, but that is the circumstance.

There are a great many topics in this forum about the same or related subjects, but most seem to have been resolved by interventions that have not worked for me thus far.

When I first did mate-panel --reset, I got “Cannot register the panel shell: there is already one running”, which is true:

Code: Select all

$ ps -ef | grep panel
user    1680  1518  0 20:47 ?        00:00:00 mate-panel
user    1716  1497  0 20:47 ?        00:00:00 /usr/lib/mate-panel/clock-applet
user    1719  1497  0 20:47 ?        00:00:00 /usr/lib/mate-panel/notification-area-applet
user    1722  1497  0 20:47 ?        00:00:00 /usr/lib/mate-panel/wnck-applet
So I tried mate-panel --replace, but that command just got stuck; sitting there, not using any CPU.

When I tried mate-panel --reset again, it got stuck also, and from then I couldn’t get the system menu anymore (neither via Alt+F1 nor the super key), so I had to reboot again. (Invoked the shutdown command from terminal.)

Any help would be much appreciated.

LM 19.3
Kernel 5.3.0-61-generic x86_64 (previous was 5.3.0-53)
MATE 1.22.2
mate-panel 1.22.1-1mint1+tricia

Re: MATE panel not showing after reboot following update of kernel

Posted: Tue Jun 30, 2020 9:20 pm
by all41
Have you tried reverting to the previous working kernel?
At the grub screen press down arrow to highlight Advanced options.
Then press the down arrow (usually twice) to select the previous generic kernel.
That will be telling.

Re: MATE panel not showing after reboot following update of kernel

Posted: Tue Jun 30, 2020 10:23 pm
by yellowfinch
all41 wrote:
Tue Jun 30, 2020 9:20 pm
Have you tried reverting to the previous working kernel?
Yes. It doesn't make any difference. Besides, my new kernel was released 8 days ago, so I would expect that any such problem would already have been flagged by someone.

There are other, weird clues, though. These clues, combined with the fact that the panel processes are running, seem to indicate that the panel is there but simply positioned beyond the bottom edge of the screen.

So I temporarily changed the display resolution to a slightly lower one and... the panel is there! :shock:

Looking at the « org | mate | panel » section of dconf, I don't see anything related to positioning.

As explained before, I tried the --reset option and it was rejected. How does one make use of that option if it can't be used when a panel is already running? Should I just kill the mate-panel process first?

Re: MATE panel not showing after reboot following update of kernel

Posted: Tue Jun 30, 2020 11:09 pm
by yellowfinch
I found the dconf settings related to the positioning of the panel (under org | mate | panel | toplevels | bottom) but still can’t figure out how to make the panel appear within the screen, at the bottom. If I place it at the top, it works fine, but then all maximized windows get truncated because they extend beyond the bottom of the screen to occupy the space where the panel would normally be.

So it looks more like a resolution problem. The system (Xorg ?) seems to think that this monitor has more lines than it actually does. I’ve been using this same monitor at its native resolution and with the default LM driver ever since my first installation of LM 17.3 and never had a problem before.

I also performed a reset of the panel (after moving it to the top, I was able to right-click on it and select “Reset” there), but that changed nothing other than removing the applets, i.e. if I place the panel back at the bottom, it’s still outside the visible area.

Re: MATE panel not showing after reboot following update of kernel

Posted: Wed Jul 01, 2020 1:34 am
by all41
Good that you are troubleshooting this.
Sounds more and more like graphics driver conflicts.
Does Menu/Displays detect your monitor? If not what is the resolution set at in that window?
You can get to this from the menu, or by terminal:

Code: Select all

mate-display-properties
Also please post the terminal results of this terminal inquiry:

Code: Select all

inxi -G
That will return results related to your graphics chips.
Copy/paste those results to this thread.

Also you could try booting using nomodeset at the grub prompt
Search the forums for how to

Re: MATE panel not showing after reboot following update of kernel

Posted: Wed Jul 01, 2020 7:32 am
by yellowfinch
all41 wrote:
Wed Jul 01, 2020 1:34 am
Sounds more and more like graphics driver conflicts.
This reminded me that the kernel was not the only thing included in the complete MintUpdate operation that I had performed: it also included xserver, which was released 2020-05-14 according to the changelog but wasn’t present when I did the previous MintUpdate (2020-05-31).

Fortunately, I always do « apt-get upgrade --simulate » first and keep the results. This is the relevant part this time:

Code: Select all

Inst xserver-xephyr-hwe-18.04 [2:1.20.5+git20191008-0ubuntu1~18.04.1] (2:1.20.8-2ubuntu2.1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst xserver-xorg-legacy-hwe-18.04 [2:1.20.5+git20191008-0ubuntu1~18.04.1] (2:1.20.8-2ubuntu2.1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst xserver-xorg-core-hwe-18.04 [2:1.20.5+git20191008-0ubuntu1~18.04.1] (2:1.20.8-2ubuntu2.1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst xserver-xorg-video-amdgpu-hwe-18.04 [19.0.1-1ubuntu1~18.04.1] (19.1.0-1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst xserver-xorg-video-radeon-hwe-18.04 [1:19.0.1-1ubuntu1~18.04.1] (1:19.1.0-1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst xserver-xorg-video-ati-hwe-18.04 [1:19.0.1-1ubuntu1~18.04.1] (1:19.1.0-1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst xwayland-hwe-18.04 [2:1.20.5+git20191008-0ubuntu1~18.04.1] (2:1.20.8-2ubuntu2.1~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
I guess I’ll have to undo the whole thing by restoring the system to its prior state using the Timeshift backup I had done just before. Right? That’s a shame, because there were also some apps that were updated at the same time, including my two browsers; I’ll have to redo those updates.

For the record, this is the result of inxi -G:

Code: Select all

Device-1: Intel HD Graphics 620     driver: i915     v: kernel 
Display: x11     server: X.Org 1.20.8     driver: modesetting     unloaded: fbdev,vesa     resolution: 1680x1050~60Hz 
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)     v: 4.5 Mesa 19.2.8 

Re: MATE panel not showing after reboot following update of kernel

Posted: Wed Jul 01, 2020 1:15 pm
by yellowfinch
all41 wrote:
Wed Jul 01, 2020 1:34 am
Also you could try booting using nomodeset at the grub prompt
Adding the nomodeset parameter made the display so slow as to be essentially unusable. More importantly, it didn’t make any difference for the resolution problem.

I also tried with acpi_osi=Linux, but it didn’t make any (visible) difference either.

To be clear: I tried with nomodeset and acpi_osi=Linux separately and together.
all41 wrote:
Wed Jul 01, 2020 1:34 am
Sounds more and more like graphics driver conflicts.
Are the graphics drivers part of the kernel? If so, reverting to the previous kernel should have eliminated the problem, right? That’s why I rather suspect the update to xserver as the cause. But then, since my graphics “card” is the widespread Intel 620 integrated with the CPU, wouldn’t a bug in there have caused this problem for everyone who updated to this same version over the past couple of weeks?

Re: MATE panel not showing after reboot following update of xserver

Posted: Wed Jul 01, 2020 1:36 pm
by all41
You could revert the xserver packages to previous versions by finding them in Synaptic toolbar File/History
then toolbar Package/Force Version

Re: MATE panel not showing after reboot following update of xserver

Posted: Wed Jul 01, 2020 1:46 pm
by yellowfinch
all41 wrote:
Wed Jul 01, 2020 1:36 pm
You could revert the xserver packages to previous versions by finding them in Synaptic toolbar File/History
then toolbar Package/Force Version
The « Force version » command is greyed out for all of them. If I consult the « Versions » tab, only one is shown. (The currently installed one.)

Re: MATE panel not showing after reboot following update of xserver

Posted: Thu Jul 02, 2020 10:15 am
by yellowfinch
I was preparing to restore the entire system using my Timeshift snapshot from just before the update of two days ago. So I booted with the “Live CD” and... surprise! The MATE panel was missing in this situation too! This told me that the problem was with the monitor (even though it necessarily was caused by something that came in the update of the kernel and/or Xserver). I went through the monitor’s settings and didn’t see anything abnormal, so I just did a factory reset. Problem solved.

Re: MATE panel not showing after reboot following update of xserver

Posted: Thu Jul 02, 2020 5:40 pm
by all41
yellowfinch wrote:
Thu Jul 02, 2020 10:15 am
I was preparing to restore the entire system using my Timeshift snapshot from just before the update of two days ago. So I booted with the “Live CD” and... surprise! The MATE panel was missing in this situation too! This told me that the problem was with the monitor (even though it necessarily was caused by something that came in the update of the kernel and/or Xserver). I went through the monitor’s settings and didn’t see anything abnormal, so I just did a factory reset. Problem solved.
That's good to hear--kudos.
Some monitors do have raster size adjustments on the menu.