[solved] re-install of mintupdate not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
oldgranola
Level 4
Level 4
Posts: 462
Joined: Fri Sep 05, 2014 1:39 am

[solved] re-install of mintupdate not working

Post by oldgranola »

Hello,
I was using gm10's mintupdate tool with LM19.3 cinnamon but in prep to go to 20 I uninstalled and reinstalled from the normal PPA but I cannot get it to work. First I removed gm10's PPA in sources and ran:

Code: Select all

sudo apt-get purge --autoremove mintupdate
seemed successful. Then I reinstalled via

Code: Select all

sudo apt install mintupdate
and

Code: Select all

$ sudo apt policy mintupdate
mintupdate:
  Installed: 5.5.9
  Candidate: 5.5.9
  Version table:
 *** 5.5.9 500
        500 http://packages.linuxmint.com tricia/main amd64 Packages
        500 http://packages.linuxmint.com tricia/main i386 Packages
        100 /var/lib/dpkg/status
However I cannot get mintupdate to run either from the gui cinnamon menu or the command line, nothing happens. This is what I get with the command line:

Code: Select all

$ mintupdate
fun@fun2:~$ 'gi.repository.XApp' object has no attribute 'StatusIcon'
<class 'AttributeError'>
I have also tried using the cinnamon software installation gui tool. Any ideas?
Last edited by oldgranola on Wed Jul 01, 2020 7:16 pm, edited 1 time in total.
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob
dorsetUK
Level 4
Level 4
Posts: 423
Joined: Thu Sep 19, 2019 4:40 am

Re: re-install of mintupdate not working

Post by dorsetUK »

Hi oldgranola

I don't know if this'll help, but hope it does.

Removing the PPA:
=================
If you want to go back to the official versions you need to downgrade the
packages - for that you can run software-sources to remove this PPA and
then use the "Remove packages not available from sources" as well as the
"Replace packages from unavailable sources" options on the maintenance
page. Or go back to a system snapshot from before you installed the PPA.

On foreign platforms you can just
sudo apt-get purge --autoremove mintupdate
(or whatever other packages you installed)

Disclaimer:
===========
Use at your own risk. I may or may not keep these up to date.

https://launchpad.net/~gm10/+archive/ub ... mint-tools
oldgranola
Level 4
Level 4
Posts: 462
Joined: Fri Sep 05, 2014 1:39 am

Re: re-install of mintupdate not working

Post by oldgranola »

Hi dorsetUK,
I run programs and kernels not in the official lm 19.3. When I look at "Remove packages not available from sources" there's mostly stuff in there I definitely want to keep. The only thing not working after removing gm10's udpate manager and PPA is the official update manager
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob
oldgranola
Level 4
Level 4
Posts: 462
Joined: Fri Sep 05, 2014 1:39 am

Re: re-install of mintupdate not working

Post by oldgranola »

What did work though was to use software sources tool in maintenance to 'restore official package version' tool after 'delete cached repository index'. Thats me random clicking, sometimes works....
Gotta say though, looking at the official mintupdate tool I now have, sure gonna miss gm10's work. Why he wasn't supported here big time on that project and for LM20 I don't understand. Back to using UKUU but not as good over all
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob
Post Reply

Return to “Newbie Questions”