Changes to logind.conf not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Madaflipin_IKO
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:29 pm

Changes to logind.conf not working

Post by Madaflipin_IKO »

Hello everyone :D

Linux mint 20.04
Kernel: 5.4.0-40-generic
Desktop: Cinnamon 4.6.6
Device-1: Intel UHD Graphics 605 vendor: Lenovo driver: i915

When i close my lid, my screen blinks and then turns on (While closed!), also when I open the lid screen is obviousley on, but after 2 or 3 seconds screen turns of and then on again :cry:

My power options are set to "Do nothing"
I also edited logind.conf, set HandleLidSwitch=ignore, uncommented that line (removed #), saved logind.conf file, restarted logind service and also restarted my laptop.
I don't know why this is not working.

Someone please help :cry:

User avatar
Kadaitcha Man
Level 9
Level 9
Posts: 2535
Joined: Mon Aug 27, 2012 10:17 pm

Re: Changes to logind.conf not working

Post by Kadaitcha Man »

Madaflipin_IKO wrote:
Sat Jul 04, 2020 1:42 pm
I don't know why this is not working.
https://github.com/systemd/systemd/issues/11638

Perhaps that's what's happening.
It's pronounced kad-eye-cha, not kada-itcha.

Madaflipin_IKO
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:29 pm

Re: Changes to logind.conf not working

Post by Madaflipin_IKO »

I tried everything from this post but nothing works. I even had to use timeshift once becouse if u delete Upower system won't boot.
Although chabges to Upower settings work only option i have is to compleetly disable lid action, which does not work for me becouse screen stays on and wastes my battery life.
Whole intent is to have my laptop turn of its screen and all other funcion to stay the same so I can close my laptop and leave it to download torrent or something.
Maybe it is too much to ask from linux mint, or it is too much for my current linux skills :P
If u have any other idea how to get my latop to shut down screen and leave everything as is.
And thank You for your ansver, it did not help but I appreciate your effort.

User avatar
Kadaitcha Man
Level 9
Level 9
Posts: 2535
Joined: Mon Aug 27, 2012 10:17 pm

Re: Changes to logind.conf not working

Post by Kadaitcha Man »

Madaflipin_IKO wrote:
Sun Jul 05, 2020 1:42 pm
Maybe it is too much to ask from linux mint...
I don't see how we can get to that conclusion based on the bug report having to do with the ubiquitous systemd. You might want to post the terminal output of inxi -Fxz. Wrap the output in code tags. You'll see the code tags icon </> when you reply.
It's pronounced kad-eye-cha, not kada-itcha.

Madaflipin_IKO
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:29 pm

Re: Changes to logind.conf not working

Post by Madaflipin_IKO »

Not so ubiquitous for me :cry:

Here u go sir, as requested:

Code: Select all

System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: LENOVO product: 81J2 v: Lenovo ideapad S130-14IGM 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32802WIN serial: <filter> 
  UEFI: LENOVO v: 9HCN30WW date: 10/31/2019 
Battery:
  ID-1: BAT1 charge: 30.2 Wh condition: 31.4/32.2 Wh (97%) 
  model: LENOVO BASE-BAT status: Discharging 
CPU:
  Topology: Dual Core model: Intel Celeron N4000 bits: 64 type: MCP 
  arch: Goldmont Plus rev: 1 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4377 
  Speed: 2487 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 2487 2: 2585 
Graphics:
  Device-1: Intel UHD Graphics 605 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:0e.0 
  Sound Server: ALSA v: k5.4.0-40-generic 
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ce v: v5.5.2.1_35598.20191029 port: 1000 
  bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 58.22 GiB used: 24.65 GiB (42.3%) 
  ID-1: /dev/mmcblk0 model: MMC32G size: 28.50 GiB 
  ID-2: /dev/sda model: SD/M.S. size: 29.72 GiB 
Partition:
  ID-1: / size: 27.43 GiB used: 11.64 GiB (42.4%) fs: ext4 
  dev: /dev/mmcblk0p2 
Sensors:
  System Temperatures: cpu: 30.0 C mobo: 10.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 207 Uptime: 1m Memory: 1.76 GiB used: 1.10 GiB (62.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  inxi: 3.0.38 

User avatar
Kadaitcha Man
Level 9
Level 9
Posts: 2535
Joined: Mon Aug 27, 2012 10:17 pm

Re: Changes to logind.conf not working

Post by Kadaitcha Man »

Madaflipin_IKO wrote:
Mon Jul 06, 2020 4:50 am

Code: Select all

Graphics:
  Device-1: Intel UHD Graphics 605 vendor: Lenovo driver: i915 v: kernel 
That might be the cause. You could try sudo apt install linux-generic-hwe-20.04 and reboot.
It's pronounced kad-eye-cha, not kada-itcha.

Madaflipin_IKO
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:29 pm

Re: Changes to logind.conf not working

Post by Madaflipin_IKO »

linux-generic-hwe-20.04 successfully installed but nothing changes

inxi -Fxz still says

Code: Select all

Graphics:
  Device-1: Intel UHD Graphics 605 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 

User avatar
Kadaitcha Man
Level 9
Level 9
Posts: 2535
Joined: Mon Aug 27, 2012 10:17 pm

Re: Changes to logind.conf not working

Post by Kadaitcha Man »

Madaflipin_IKO wrote:
Mon Jul 06, 2020 6:09 am
linux-generic-hwe-20.04 successfully installed but nothing changes
Ok, I'm sorry but I can't offer anything else. You'll have to wait for someone who has more experience in this area.
It's pronounced kad-eye-cha, not kada-itcha.

Madaflipin_IKO
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:29 pm

Re: Changes to logind.conf not working

Post by Madaflipin_IKO »

Nevertheless, thank you for your help.
I heard Linux community is awesome but I did not expect anything like this
Thank you once again. :D

Madaflipin_IKO
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:29 pm

Re: Changes to logind.conf not working

Post by Madaflipin_IKO »

Cinnamon desktop update just solved this problem.
The cause is still not found but the problem is gone so it is oke now

Post Reply

Return to “Newbie Questions”