[SOLVED] Qt makes a mess with VLC and KeepassXC

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
ineuw
Level 4
Level 4
Posts: 483
Joined: Sun Nov 13, 2016 12:27 am
Location: Montreal

[SOLVED] Qt makes a mess with VLC and KeepassXC

Post by ineuw »

These two apps that use QT renders them unusable. The proportions are gigantic as if both suffer from Elephantiasis. Is there a remedy, surgical or otherwise?
Please see the attached image. They cover the whole screen. They can be moved but not resized. KeepassXC is also missing the sizing control on the window frame. Changing resolutions have no effect.
KeepassXC 2020-07-09 14-22-22.png
Videolan 2020-07-09 21-58-46.png
Last edited by ineuw on Fri Jul 10, 2020 7:34 pm, edited 1 time in total.
Desktop:Windows 10 and Linux Mint 19.3 Cinnamon 16gb RAM

rene
Level 16
Level 16
Posts: 6521
Joined: Sun Mar 27, 2016 6:58 pm

Re: Qt makes a mess with VLC and KeepassXC

Post by rene »

Not sure why I feel those screenshots to be as funny as I find them to be, but damn...

Do Preferences --> Qt5 Settings help any?

User avatar
ineuw
Level 4
Level 4
Posts: 483
Joined: Sun Nov 13, 2016 12:27 am
Location: Montreal

Re: Qt makes a mess with VLC and KeepassXC

Post by ineuw »

rene wrote:
Thu Jul 09, 2020 10:22 pm
Not sure why I feel those screenshots to be as funny as I find them to be, but damn...
Do Preferences --> Qt5 Settings help any?
Much thanks for pointing this out and I really appreciate it. It's only listed under the Preferences group of the Main menu. Someone forgot to include a link in the Preferences Group of System Settings panel, on which I relied on in the past. Also, I have no clue what the control & settings in the Qt5 panel supposed to do.

I added the following lines, in the /home/"username"/.profile file.

export QT_AUTO_SCREEN_SCALE_FACTOR=0 vlc
export QT_AUTO_SCREEN_SCALE_FACTOR=0 keepassxc

On first attempt after reboot, it didn't work because the Qt documentation was written for prophets and not mere mortals like myself. Now, on the second boot, both apps display normally.
Desktop:Windows 10 and Linux Mint 19.3 Cinnamon 16gb RAM

rene
Level 16
Level 16
Posts: 6521
Joined: Sun Mar 27, 2016 6:58 pm

Re: [SOLVED] Qt makes a mess with VLC and KeepassXC

Post by rene »

Okay, good one getting that to work. The syntax you've used is not fully correct though. Your

Code: Select all

export QT_AUTO_SCREEN_SCALE_FACTOR=0 vlc
export QT_AUTO_SCREEN_SCALE_FACTOR=0 keepassxc
does the same as the single

Code: Select all

export QT_AUTO_SCREEN_SCALE_FACTOR=0
which you then might as well turn it into in ~/.profile.

As to the issue itself there seems to be interaction with a locally set DPI for your display and given that others are not experiencing this and that your screenshot doesn't look particularly HiDPI --- buy maybe it is and even your taskbar has just been enlarged --- this might supposedly also provide a hint so as to not need it if you in fact remember setting an explicit DPI somewhere.

But that said, again good find, and the environment variable will supposedly work as well (although, then, for everything using Qt and not just for VLC and KeePassXC as it seems you intended in the above).

User avatar
ineuw
Level 4
Level 4
Posts: 483
Joined: Sun Nov 13, 2016 12:27 am
Location: Montreal

Re: [SOLVED] Qt makes a mess with VLC and KeepassXC

Post by ineuw »

rene wrote:
Fri Jul 10, 2020 8:02 pm
Okay, good one getting that to work. The syntax you've used is not fully correct though. Your

Code: Select all

export QT_AUTO_SCREEN_SCALE_FACTOR=0 vlc
export QT_AUTO_SCREEN_SCALE_FACTOR=0 keepassxc
does the same as the single

Code: Select all

export QT_AUTO_SCREEN_SCALE_FACTOR=0
which you then might as well turn it into in ~/.profile.

As to the issue itself there seems to be interaction with a locally set DPI for your display and given that others are not experiencing this and that your screenshot doesn't look particularly HiDPI --- buy maybe it is and even your taskbar has just been enlarged --- this might supposedly also provide a hint so as to not need it if you in fact remember setting an explicit DPI somewhere.

But that said, again good find, and the environment variable will supposedly work as well (although, then, for everything using Qt and not just for VLC and KeePassXC as it seems you intended in the above).
I tried the single line environment-variable as well, but had no luck. Will try it again after I post this and reboot.

I always use 1536p x 864p x 60mhz (16:9) resolution which always worked previously after setting the environment variable in /.profile. However, I never changed the DPI anywhere.

I also tried 1920p x 1080p then rebooted, but nothing changed. Of course as with all attempts the error had to be mine.
Desktop:Windows 10 and Linux Mint 19.3 Cinnamon 16gb RAM

User avatar
ineuw
Level 4
Level 4
Posts: 483
Joined: Sun Nov 13, 2016 12:27 am
Location: Montreal

Re: [SOLVED] Qt makes a mess with VLC and KeepassXC

Post by ineuw »

Naturally, one environment setting works for both thanks for the guidance.

Current environment variables using printenv | grep QT > env.txt

Code: Select all

QT_ACCESSIBILITY=1
QT_QPA_PLATFORMTHEME=qt5ct
QT_AUTO_SCREEN_SCALE_FACTOR=0
However, this was not so yesterday. That is why I started this thread. :-) But that's for another thread (story) after I recuperate.
Desktop:Windows 10 and Linux Mint 19.3 Cinnamon 16gb RAM

Post Reply

Return to “Newbie Questions”