WIFI after installing linux mint 20

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
talk2abhi
Level 1
Level 1
Posts: 4
Joined: Sun Jul 12, 2020 5:31 pm

WIFI after installing linux mint 20

Post by talk2abhi »

I am unable to connect my wifi. I attaching the system details here.
System:
Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana
base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X430FA_S430FA
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: X430FA v: 1.0 serial: <filter>
UEFI: American Megatrends v: X430FA.308 date: 05/28/2019
Battery:
ID-1: BAT0 charge: 20.3 Wh condition: 41.6/42.2 Wh (99%)
model: ASUSTeK ASUS Battery status: Charging
CPU:
Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP
arch: Kaby Lake rev: C L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 28800
Speed: 700 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 700 2: 700
3: 700 4: 700 5: 700 6: 700 7: 700 8: 700
Graphics:
Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.0.8
direct render: Yes
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k5.4.0-40-generic
Network:
Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: N/A
port: efa0 bus ID: 02:00.0
IF-ID-1: usb0 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 9.01 GiB (0.8%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
ID-2: /dev/sdb vendor: SK Hynix model: HFS256G39TNH-73A0A size: 238.47 GiB
temp: 35 C
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 bus ID: 00:17.0
Partition:
ID-1: / size: 233.24 GiB used: 9.00 GiB (3.9%) fs: ext4 dev: /dev/sdb2
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2300
Info:
Processes: 237 Uptime: 13m Memory: 7.63 GiB used: 1.29 GiB (16.9%)
Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16
inxi: 3.0.38
User avatar
Pjotr
Level 22
Level 22
Posts: 15235
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: WIFI after installing linux mint 20

Post by Pjotr »

Tip: 10 things to do after installing Linux Mint 20 Ulyana
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
talk2abhi
Level 1
Level 1
Posts: 4
Joined: Sun Jul 12, 2020 5:31 pm

Re: WIFI after installing linux mint 20

Post by talk2abhi »

I have followed item no 7. But still i am facing same problem. I am not able to connect to wifi.
talk2abhi
Level 1
Level 1
Posts: 4
Joined: Sun Jul 12, 2020 5:31 pm

Re: WIFI after installing linux mint 20

Post by talk2abhi »

Pjotr wrote:
Sun Jul 12, 2020 5:46 pm
This driver should work:
https://easylinuxtipsproject.blogspot.c ... k.html#ID7
(item 7)
I have again reinstall linux mint 20 and tried to follow item 7. The solution didn't worked out.
sleeper12
Level 11
Level 11
Posts: 3643
Joined: Thu May 25, 2017 3:22 pm

Re: WIFI after installing linux mint 20

Post by sleeper12 »

What do these show:

Code: Select all

 rfkill list 

Code: Select all

 mokutil --sb-state 
talk2abhi
Level 1
Level 1
Posts: 4
Joined: Sun Jul 12, 2020 5:31 pm

Re: WIFI after installing linux mint 20

Post by talk2abhi »

1. rkfill output

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
2: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no


2. mokutil --sb-state result

SecureBoot enabled

I have also tried by disabling secure boot but nothhing worked out.
sleeper12
Level 11
Level 11
Posts: 3643
Joined: Thu May 25, 2017 3:22 pm

Re: WIFI after installing linux mint 20

Post by sleeper12 »

Secure boot needs to be off. Then try:

Code: Select all

 sudo service network-manager restart 
Post Reply

Return to “Newbie Questions”