Scanner doesn't work in Mint Ulyana XFCE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Goro Daimon
Level 1
Level 1
Posts: 48
Joined: Sat Apr 28, 2012 10:30 pm

Scanner doesn't work in Mint Ulyana XFCE

Post by Goro Daimon »

I installed all dependencies.

Code: Select all

hp-check[44283]: info: :
hp-check[44283]: info: :[01mHP Linux Imaging and Printing System (ver. 3.20.3)[0m
hp-check[44283]: info: :[01mDependency/Version Check Utility ver. 15.1[0m
hp-check[44283]: info: :
hp-check[44283]: info: :Copyright (c) 2001-18 HP Development Company, LP
hp-check[44283]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[44283]: info: :This is free software, and you are welcome to distribute it
hp-check[44283]: info: :under certain conditions. See COPYING file for more details.
hp-check[44283]: info: :
hp-check[44283]: info: :[01mNote: hp-check can be run in three modes:[0m
hp-check[44283]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[44283]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[44283]: info: :are installed to successfully compile HPLIP.                                    
hp-check[44283]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
hp-check[44283]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
hp-check[44283]: info: :has the proper dependencies installed to successfully run.                      
hp-check[44283]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
hp-check[44283]: info: :will check both of the above cases (both compile- and run-time dependencies).   
hp-check[44283]: info: :
hp-check[44283]: info: :Check types:                                                                    
hp-check[44283]: info: :a. EXTERNALDEP - External Dependencies                                          
hp-check[44283]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)    
hp-check[44283]: info: :c. COMPILEDEP - Compile time Dependencies                                       
hp-check[44283]: info: :d. [All are run-time checks]                                                    
hp-check[44283]: info: :PYEXT SCANCONF QUEUES PERMISSION                                                
hp-check[44283]: info: :
hp-check[44283]: info: :Status Types:
hp-check[44283]: info: :    OK
hp-check[44283]: info: :    MISSING       - Missing Dependency or Permission or Plug-in
hp-check[44283]: info: :    INCOMPAT      - Incompatible dependency-version or Plugin-version
hp-check[44283]: info: :
warning: [01mlinuxmint-20 version is not supported. Using linuxmint-19.3 versions dependencies to verify and install...[0m
hp-check[44283]: info: :
hp-check[44283]: info: :---------------
hp-check[44283]: info: :| SYSTEM INFO |
hp-check[44283]: info: :---------------
hp-check[44283]: info: :
hp-check[44283]: info: : Kernel: 5.4.0-40-generic #44-Ubuntu SMP Tue Jun 23 00:01:04 UTC 2020 GNU/Linux
 Host: goro-desktop
 Proc: 5.4.0-40-generic #44-Ubuntu SMP Tue Jun 23 00:01:04 UTC 2020 GNU/Linux
 Distribution: linuxmint 20
hp-check[44283]: info: : Bitness: 64 bit

hp-check[44283]: info: :
hp-check[44283]: info: :-----------------------
hp-check[44283]: info: :| HPLIP CONFIGURATION |
hp-check[44283]: info: :-----------------------
hp-check[44283]: info: :
hp-check[44283]: info: :HPLIP-Version: HPLIP 3.20.3
hp-check[44283]: info: :HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  20 version 
hp-check[44283]: info: :
hp-check[44283]: info: :[01mCurrent contents of '/etc/hp/hplip.conf' file:[0m
hp-check[44283]: info: :# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.3
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

hp-check[44283]: info: :
hp-check[44283]: info: :[01mCurrent contents of '/var/lib/hp/hplip.state' file:[0m
hp-check[44283]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[44283]: info: :
hp-check[44283]: info: :[01mCurrent contents of '~/.hplip/hplip.conf' file:[0m
hp-check[44283]: info: :[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[fax]
email_address = 
voice_phone = 

[installation]
date_time = 07/13/20 19:25:41
version = 3.20.3

[last_used]
device_uri = "hp:/usb/Deskjet_2540_series?serial=BR541FH1C605XK"
printer_name = 
working_dir = .

[polling]
device_list = 
enable = false
interval = 5

[refresh]
enable = true
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1549909751
latest_available_version = 3.17.10
notify_upgrade = true
pending_upgrade_time = 0


hp-check[44283]: info: : <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
hp-check[44283]: info: :
hp-check[44283]: info: :-------------------------
hp-check[44283]: info: :| External Dependencies |
hp-check[44283]: info: :-------------------------
hp-check[44283]: info: :
hp-check[44283]: info: :[31;01m error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'[0m
hp-check[44283]: info: : gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
hp-check[44283]: info: : xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
hp-check[44283]: info: : scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
hp-check[44283]: info: :[31;01m error: dbus          DBus - Message bus system                                    REQUIRED        -               1.12.16         MISSING    'DBUS may not be installed or not running'[0m
hp-check[44283]: info: : policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
hp-check[44283]: info: : network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
hp-check[44283]: info: : avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -
hp-check[44283]: info: :
hp-check[44283]: info: :------------------------
hp-check[44283]: info: :| General Dependencies |
hp-check[44283]: info: :------------------------
hp-check[44283]: info: :
hp-check[44283]: info: :[31;01m error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'[0m
hp-check[44283]: info: :[31;01m error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'[0m
hp-check[44283]: info: :[31;01m error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'[0m
hp-check[44283]: info: : libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
hp-check[44283]: info: :[31;01m error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'[0m
hp-check[44283]: info: : sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
hp-check[44283]: info: :[31;01m error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'[0m
hp-check[44283]: info: :[31;01m error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'[0m
hp-check[44283]: info: :[31;01m error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           MISSING    'libcrypto needs to be installed'[0m
hp-check[44283]: info: : python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.2           OK         -
hp-check[44283]: info: :[31;01m error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'[0m
hp-check[44283]: info: :[31;01m error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'[0m
hp-check[44283]: info: :[31;01m error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'[0m
hp-check[44283]: info: : python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
hp-check[44283]: info: : python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
hp-check[44283]: info: :[31;01m error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.8.2           MISSING    'python3-devel needs to be installed'[0m
hp-check[44283]: info: : python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               7.0.0           OK         -
hp-check[44283]: info: : python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.34          OK         -
hp-check[44283]: info: :
hp-check[44283]: info: :--------------
hp-check[44283]: info: :| COMPILEDEP |
hp-check[44283]: info: :--------------
hp-check[44283]: info: :
hp-check[44283]: info: :[31;01m error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'[0m
hp-check[44283]: info: : gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           OK         -
hp-check[44283]: info: : make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -
hp-check[44283]: info: :
hp-check[44283]: info: :---------------------
hp-check[44283]: info: :| Python Extentions |
hp-check[44283]: info: :---------------------
hp-check[44283]: info: :
hp-check[44283]: info: : cupsext              CUPS-Extension                                               REQUIRED        -               3.20.3          OK         -
hp-check[44283]: info: : hpmudext             IO-Extension                                                 REQUIRED        -               3.20.3          OK         -
hp-check[44283]: info: :
hp-check[44283]: info: :----------------------
hp-check[44283]: info: :| Scan Configuration |
hp-check[44283]: info: :----------------------
hp-check[44283]: info: :
hp-check[44283]: info: :'/etc/sane.d/dll.d/hpaio' not found.
hp-check[44283]: info: : hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.3          OK         'hpaio found in /etc/sane.d/dll.conf'
hp-check[44283]: info: : scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.3          OK         -
hp-check[44283]: info: :
hp-check[44283]: info: :------------------------------
hp-check[44283]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[44283]: info: :------------------------------
hp-check[44283]: info: :
hp-check[44283]: info: :device `escl:http://127.0.0.1:60000' is a ESCL Deskjet 2540 series [BR541FH1C605XK] flatbed scanner
device `hpaio:/usb/Deskjet_2540_series?serial=BR541FH1C605XK' is a Hewlett-Packard Deskjet_2540_series all-in-one
device `escl:http://127.0.0.1:60000' is a ESCL Deskjet 2540 series [BR541FH1C605XK] flatbed scanner
device `hpaio:/usb/Deskjet_2540_series?serial=BR541FH1C605XK' is a Hewlett-Packard Deskjet_2540_series all-in-one

hp-check[44283]: info: :
hp-check[44283]: info: :--------------------------
hp-check[44283]: info: :| DISCOVERED USB DEVICES |
hp-check[44283]: info: :--------------------------
hp-check[44283]: info: :
hp-check[44283]: info: :  Device URI                        Model                 
hp-check[44283]: info: :  --------------------------------  ----------------------
hp-check[44283]: info: :  hp:/usb/Deskjet_2540_series?seri  HP Deskjet 2540 series
  al=BR541FH1C605XK                                       
hp-check[44283]: info: :
hp-check[44283]: info: :---------------------------------
hp-check[44283]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[44283]: info: :---------------------------------
hp-check[44283]: info: :
hp-check[44283]: info: :
hp-check[44283]: info: :[01mDeskjet_2540[0m
hp-check[44283]: info: :[01m------------[0m
hp-check[44283]: info: :Type: Printer
hp-check[44283]: info: :Device URI: hp:/usb/Deskjet_2540_series?serial=BR541FH1C605XK
hp-check[44283]: info: :PPD: /etc/cups/ppd/Deskjet_2540.ppd
warning: Failed to read /etc/cups/ppd/Deskjet_2540.ppd ppd file
hp-check[44283]: info: :PPD Description: 
hp-check[44283]: info: :Printer status: impressora Deskjet_2540 está inativa; habilitada desde seg 13 jul 2020 18:53:12
error: Device not found
error: Communication status: Failed
hp-check[44283]: info: :
hp-check[44283]: info: :[01mDeskjet_2540_series_BR541FH1C605XK_[0m
hp-check[44283]: info: :[01m-----------------------------------[0m
hp-check[44283]: info: :Type: Unknown
hp-check[44283]: info: :Device URI: implicitclass://Deskjet_2540_series_BR541FH1C605XK_/
hp-check[44283]: info: :PPD: /etc/cups/ppd/Deskjet_2540_series_BR541FH1C605XK_.ppd
warning: Failed to read /etc/cups/ppd/Deskjet_2540_series_BR541FH1C605XK_.ppd ppd file
hp-check[44283]: info: :PPD Description: 
hp-check[44283]: info: :Printer status: impressora Deskjet_2540_series_BR541FH1C605XK_ está inativa; habilitada desde seg 13 jul 2020 18:22:15
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
hp-check[44283]: info: :
hp-check[44283]: info: :
hp-check[44283]: info: :--------------
hp-check[44283]: info: :| PERMISSION |
hp-check[44283]: info: :--------------
hp-check[44283]: info: :
hp-check[44283]: info: :USB             Deskjet_2540                   Required        -        -        OK       Node:'/dev/bus/usb/003/019' Perm:'  root  lp rw- rw- rw- rw- r--'
hp-check[44283]: info: :
hp-check[44283]: info: :-----------
hp-check[44283]: info: :| SUMMARY |
hp-check[44283]: info: :-----------
hp-check[44283]: info: :
hp-check[44283]: info: :[01mMissing Required Dependencies[0m
hp-check[44283]: info: :[01m-----------------------------[0m
error: 'libcups2' package is missing/incompatible 
error: 'libdbus-1-dev' package is missing/incompatible 
error: 'libjpeg8-dev' package is missing/incompatible 
error: 'libcups2-dev' package is missing/incompatible 
error: 'cups-bsd' package is missing/incompatible 
error: 'cups-client' package is missing/incompatible 
error: 'libcupsimage2-dev' package is missing/incompatible 
error: 'libusb-1.0.0-dev' package is missing/incompatible 
error: 'libsane-dev' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'python3-dev' package is missing/incompatible 
error: 'libtool' package is missing/incompatible 
error: 'libtool-bin' package is missing/incompatible 
hp-check[44283]: info: :
hp-check[44283]: info: :[01mMissing Optional Dependencies[0m
hp-check[44283]: info: :[01m-----------------------------[0m
error: 'python3-notify2' package is missing/incompatible 
error: 'mate-notification-daemon' package is missing/incompatible 
error: 'python3-dbus.mainloop.qt' package is missing/incompatible 
hp-check[44283]: info: :
hp-check[44283]: info: :Total Errors: 15
hp-check[44283]: info: :Total Warnings: 1
hp-check[44283]: info: :
hp-check[44283]: info: :
hp-check[44283]: info: :Done.
Kris345
Level 2
Level 2
Posts: 77
Joined: Mon Jun 22, 2020 10:22 am
Location: New England

Re: Scanner doesn't work in Mint Ulyana XFCE

Post by Kris345 »

On my system, I install a deb to install my printer (Canon TS6020). That creates an entry in printers. But I could not get it to connect to scanner. Until. I created another entry in printers using the default cups stuff, AND temporarily made it default. Scanner worked instantly. Go figure! :mrgreen:
-- ThinkPad T530-2394-3J8, i5-3380M 2.9GHz. Dual Boot UEFI/GPT x64: Mint 20 Cinnamon, Win10. 8GB(15GB/s), Sammy 500GB SSD. --
User avatar
Goro Daimon
Level 1
Level 1
Posts: 48
Joined: Sat Apr 28, 2012 10:30 pm

Re: Scanner doesn't work in Mint Ulyana XFCE

Post by Goro Daimon »

I can't install latest HPLIP

Code: Select all

goro@gorol-desktop:~/Downloads$ ./hplip.run
Creating directory hplip-3.20.6
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.6 Self Extracting Archive.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.20.6)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Tue-14-Jul-2020_14:54:41.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: linuxmint-20 version is not supported, so all dependencies may not be installed. However trying to install using linuxmint-19.3 version packages.

Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*): y


INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a


INTRODUCTION
------------
This installer will install HPLIP version 3.20.6 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Linux Mint 20.

Is "Linux Mint 20" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y

Initializing. Please wait...


ENTER USER PASSWORD
-------------------
Please enter the sudoer (goro)'s password: 
 

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information.  Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit: 


SECURITY PACKAGES
-----------------
AppArmor is installed. 
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? y


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
libjpeg              base                 REQUIRED            
libtool              base                 REQUIRED            
cups-devel           base                 REQUIRED            
cups-image           base                 REQUIRED            
libusb               base                 REQUIRED            
sane-devel           scan                 REQUIRED            
dbus                 fax                  REQUIRED            
libnetsnmp-devel     network              REQUIRED            
libcrypto            network              REQUIRED            
python3-notify2      gui_qt4              OPTIONAL            
python3-pyqt4-dbus   gui_qt4              OPTIONAL            
python3-pyqt4        gui_qt4              REQUIRED            
python3-devel        base                 REQUIRED            
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: python3-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: python3-pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))
warning: Missing REQUIRED dependency: dbus (DBus - Message bus system)
warning: Missing REQUIRED dependency: sane-devel (SANE - Scanning library development files)


INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'gui_qt4': python3-notify2 (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing OPTIONAL dependency for option 'gui_qt4': python3-pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo apt-get install --assume-yes libjpeg8-dev'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libtool'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libtool-bin'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libcups2-dev'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes cups-bsd'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes cups-client'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libusb-1.0.0-dev'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes python3-dev'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes python3-pyqt4'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
Running 'sudo apt-get install --assume-yes python3-pyqt4'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
Running 'sudo apt-get install --assume-yes python3-pyqt4'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
Running 'sudo apt-get install --assume-yes python3-pyqt4'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
note: Some packages may not get installed on python3 due to distro incompatibilites

note: Please check for more information at http://hplipopensource.com/node/369
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? y
Running 'sudo apt-get install --assume-yes python3-pyqt4'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
note: Some packages may not get installed on python3 due to distro incompatibilites

note: Please check for more information at http://hplipopensource.com/node/369
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? 

https://iili.io/dFLeLb.png

error code 5012 on Mint 20

Missing Required Dependencies
error: ‘python-pyqt4’ package is missing/incompatible
error: ‘pygtk’ package is missing/incompatible

The python-pyqt4 is actually replaced by python-pyqt5
Post Reply

Return to “Newbie Questions”