unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
XP-refugee
Level 1
Level 1
Posts: 40
Joined: Mon Jan 01, 2018 2:41 am

unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by XP-refugee »

I've just used Update Manager and updated
linux-libc-dev 4.40-186.215 to linux-libc-dev 4.40-186.216
snapd 2.45.1 to snapd ubuntu0.2
firefox-locale-en 78.0.1+linuxmint1+sylvia to firefox-locale-en 78.0.2+linuxmint1+sylvia
firefox 78.0.1+linuxmint1+sylvia to firefox 78.0.2+linuxmint1+sylvia
libldap-2.4-2 2.4.42+dfsg-2ubuntu3.8 to libldap-2.4-2 2.4.42+dfsg-2ubuntu3.9

And now this machine's internet connection is unstable. (Another device is connecting through the same router nicely.

My wild guess is that I need to roll back to linux-libc-dev 4.40-186.215
But

Code: Select all

sudo apt-get install linux-libc-dev 4.40-186.215 
gives

Code: Select all

E: Unable to locate package 4.40-186.215
E: Couldn't find any package by glob '4.40-186.215'
E: Couldn't find any package by regex '4.40-186.215'
Any help from wiser users will be appreciated.
User avatar
zcot
Level 6
Level 6
Posts: 1287
Joined: Wed Oct 19, 2016 6:08 pm

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by zcot »

That looks like a pretty wild ride!

To specify a version of a package the format is <package_name>=<package_version_name>.
XP-refugee
Level 1
Level 1
Posts: 40
Joined: Mon Jan 01, 2018 2:41 am

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by XP-refugee »

Thanks zcot.

Code: Select all

sudo apt-get install linux-libc-dev=4.40-186.215
gets me

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '4.40-186.215' for 'linux-libc-dev' was not found

My internet connection remains unstable - a ping-time table is only half filled on this device whereas here-there times are all filled in on other devices connecting over the same router.
User avatar
zcot
Level 6
Level 6
Posts: 1287
Joined: Wed Oct 19, 2016 6:08 pm

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by zcot »

I would get with Jeremy on IRC to do some realtime diagnostics. Or formulate a good post on the forum here strictly mentioning the connection and the system data to go with it.

But as far as tinkering around with packages, that package version is not correct. I don't know where you got that version number but you'll have to use the exact appropriate one, and furthermore it's not just the version number you add, it's the versioned name of the package, you are specifying a certain exact package. Sometimes the version might be 1.2, but the package version name is actually 1.2-0ubuntu-5.2, so you can get the exact name with some apt or package searches or whatever and it will be correct.
XP-refugee
Level 1
Level 1
Posts: 40
Joined: Mon Jan 01, 2018 2:41 am

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by XP-refugee »

What you write in your last post is way beyond my understanding.
User avatar
zcot
Level 6
Level 6
Posts: 1287
Joined: Wed Oct 19, 2016 6:08 pm

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by zcot »

here is an ubuntu package search for linux-libc-dev and various versions are listed: https://packages.ubuntu.com/search?keyw ... x-libc-dev
XP-refugee
Level 1
Level 1
Posts: 40
Joined: Mon Jan 01, 2018 2:41 am

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by XP-refugee »

zcot what you write is way beyond my technical level.

I guess that that search shows me the list of the current linux-libc-dev packages.
That would make sense of Update Manager History showing me that I updated from linux-libc-dev 4.40-186.215 to linux-libc-dev 4.40-186.216

But how to downgrade to linux-libc-dev 4.40-186.215, and whether I need
xenial (16.04LTS) (devel): Linux Kernel Headers for development 4.4.0-186.215 [security]: amd64 i386
or
xenial-updates (devel): Linux Kernel Headers for development 4.4.0-186.215: amd64 arm64 armhf i386 powerpc ppc64el s390x
, if that is what is needed, remains a mystery.

With a google search for

Code: Select all

linux-libc-dev 4.40-186.215
returning nothing beside this thread, I suspect that I'm not approaching this the right way.
User avatar
zcot
Level 6
Level 6
Posts: 1287
Joined: Wed Oct 19, 2016 6:08 pm

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by zcot »

I think the version string is wrong in one of these searches:

Code: Select all

linux-libc-dev 4.40-186.215

Code: Select all

linux-libc-dev 4.4.0-186.215
XP-refugee
Level 1
Level 1
Posts: 40
Joined: Mon Jan 01, 2018 2:41 am

Re: unstable internet. Rollback from linux-libc-dev 4.40-186.216 ?

Post by XP-refugee »

Yes.
Error in "linux-libc-dev 4.40-186.215 to linux-libc-dev 4.40-186.216"

Update Manager History has
linux-libc-dev 4.40-185.215 to linux-libc-dev 4.40-186.216
with 185.215 both ending in 5, and 186.216 both ending in 6.
Post Reply

Return to “Newbie Questions”