Linux Mint 20 takes a lot of time to load [Abandoned]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

Sorry I was offline for a while, will give the output soon.
User avatar
zcot
Level 6
Level 6
Posts: 1384
Joined: Wed Oct 19, 2016 6:08 pm

Re: Linux Mint 20 takes a lot of time to load

Post by zcot »

Spectrum75 wrote:
Sun Aug 30, 2020 3:11 am
Umm, this is for xed admin:///etc/default/grub this command? I mean to edit grub?
Could you please simplify your instructions a bit, sorry as said earlier I am new to linux :roll: :?
Sorry for late reply by the way
You don't want to do that. Don't edit grub and make those test parameter permanent. It will force you to have to correct it in a tty or chroot session which is not going to be a fun task at this point.

You need to use the temporary testing method where you just boot with any test parameter temporarily for only that one boot session. There's a video example of doing it linked above by looking at the Release Notes in that section about "Solving freezes".
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

Larry78723 wrote:
Thu Aug 27, 2020 11:37 am
If you reboot then run the following command, it will show where your boot process is having problems:

Code: Select all

journalctl -b | grep -i "error\|warn\|fail" | tee >(gzip --stdout > journalctl_$USER.gz)
This command will write the current system log problems to the file journalctl_(yourname).gz. The file will be located in your /home/login_name directory

I ran the command everything else seems to be fine execept,

Code: Select all

Sep 11 09:01:32 PC kernel: random: 7 urandom warning(s) missed due to ratelimiting
Sep 11 09:01:32 PC kernel: EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
Sep 11 09:01:38 PC kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel
Sep 11 09:01:39 PC systemd-udevd[475]: nvidia: Process '/bin/systemctl start --no-block nvidia-persistenced.service' failed with exit code 5.
Sep 11 09:01:39 PC systemd-udevd[479]: NVIDIA ACPI Video Driver: Process '/bin/systemctl start --no-block nvidia-persistenced.service' failed with exit code 5.
Sep 11 09:01:41 PC systemd-udevd[472]: NVIDIA ACPI Video Driver: Process '/bin/systemctl stop --no-block nvidia-persistenced' failed with exit code 5.
Sep 11 09:01:41 PC systemd-udevd[469]: controlC0: Process '/usr/sbin/alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime restore 0' failed with exit code 99.
I cannot understand what that means :?
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

zcot wrote:
Thu Aug 27, 2020 9:19 am
For the power handling issue, ACPI messages, you will have to test a variety of parameters. I don't know some clear exact answer here, but instead of using nomodeset, for graphics related, which doesn't help this case, there are other possible combination(s) that can help, with other kernel modules.

To stop the fsck issue the kernel will have to properly handle the ACPI setup to where it reboots/shuts-down correctly and you never have to hold the power button to shut it down. The incomplete shutdown causes the fsck.

Look at this example mentioning the possibilities for finding a possible parameter correction for the kernel related to this hardware:
https://askubuntu.com/questions/127989/ ... t-can-i-do

I would try this one because the dmesg output shows some chatter about irq tables, but a lot of the early acpi messages look fine. I would test acpi=noirq for sure.

This might solve some of the issue.

There are too many options to just list.

acpi_sleep=nonvs

acpi_enforce_resources=lax

The fact is it's a pretty wide open field of info related to this stuff.

acpi_osi=! acpi_osi='Windows 2009'
so the temporary test would look like that but the grub line would look like this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009' "
There are more "Windows" configuration option, these tell the kernel to pretend the system is like one of these cases and the kernel will implement certain corrections related to odd bios bugs or different issues, in order to try to correctly handle everything.

You should be testing with the temporary grub option, not editing grub, because if you reach a total failure and it does not even boot completely then you would be stuck with an edited grub file that you have to fix from tty or chroot environment.

This is another thing to look at, although I didn't see any dmesg output related to problems with audio of the nvidia board, but just to show the info: https://ubuntuforums.org/showthread.php?t=2384893

The extreme option, and this could eliminate issue but it's not good, likely to not let the fans run, there will be no power management possible, and other possible issues: acpi=off

There is a lot of documentation and articles about this stuff on the internet.


Another thing here, and this is where most of the booting time is listed is with loading the nvidia driver. The driver is signed so it can be loaded on an UEFI setup but this is a legacy setup so not useful. You could rebuild the kernel and remove the certificate setup which is a substantial timing hit here, but that's a big deal. I didn't see whether or not the EDID query was causing an issue or not but that's another known potential that you can use a workaround for.
In here where you mention "I would try this one because the dmesg output shows some chatter about irq tables, but a lot of the early acpi messages look fine. I would test acpi=noirq for sure."
Do you mean I should change this

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009' "
to this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq " or GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq acpi_osi='Windows 2009' "
I got a bit confused here :?
User avatar
zcot
Level 6
Level 6
Posts: 1384
Joined: Wed Oct 19, 2016 6:08 pm

Re: Linux Mint 20 takes a lot of time to load

Post by zcot »

I would try that one: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009' "

and I would try that: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq"

The first one would be an attempt to just correct the whole system overall in relation to how the kernel is trying to detect the acpi related hardware situation there, and that might do it, but you have to look at the messages, and test it, if there is no "bad" acpi message using that then it's a good sign, and so you test suspend and hibernate to see if it's all good.

In the second case, that one might be good, but same as above you have to manually check it all out.

If/when you get a good configuration, then you can "make it permanent", so you're not having to type out the parameters any time you boot.

It's all a big pain in the butt, and many times we don't have to go through this stuff, but sometimes we do. I actually have some acpi issues on this daily driver pc, but I never suspend/hibernate so I'm just leaving it alone. It's a desktop, and I am connected to the IRC support server daily so for me it's okay.


The main part of your delay here is using that nvidia proprietary driver though, and as you've mentioned it doesn't do that overly long delay when using nouveau.
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

zcot wrote:
Thu Sep 10, 2020 11:59 pm
I would try that one: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009' "

and I would try that: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq"

The first one would be an attempt to just correct the whole system overall in relation to how the kernel is trying to detect the acpi related hardware situation there, and that might do it, but you have to look at the messages, and test it, if there is no "bad" acpi message using that then it's a good sign, and so you test suspend and hibernate to see if it's all good.

In the second case, that one might be good, but same as above you have to manually check it all out.

If/when you get a good configuration, then you can "make it permanent", so you're not having to type out the parameters any time you boot.

It's all a big pain in the butt, and many times we don't have to go through this stuff, but sometimes we do. I actually have some acpi issues on this daily driver pc, but I never suspend/hibernate so I'm just leaving it alone. It's a desktop, and I am connected to the IRC support server daily so for me it's okay.


The main part of your delay here is using that nvidia proprietary driver though, and as you've mentioned it doesn't do that overly long delay when using nouveau.
I have tried that GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009' " but no difference.
Will try the second one and report soon.
1000
Level 4
Level 4
Posts: 245
Joined: Wed Jul 29, 2020 2:14 am

Re: Linux Mint 20 takes a lot of time to load

Post by 1000 »

I cannot understand what that means :?
Searching for a bit on the internet you will find some information

Code: Select all

Sep 11 09:01:32 PC kernel: random: 7 urandom warning(s) missed due to ratelimiting
From man urandom
DESCRIPTION
The character special files /dev/random and /dev/urandom (present since Linux 1.3.30) provide an interface to the
kernel's random number generator. The file /dev/random has major device number 1 and minor device number 8. The
file /dev/urandom has major device number 1 and minor device number 9.

The random number generator gathers environmental noise from device drivers and other sources into an entropy pool.
The generator also keeps an estimate of the number of bits of noise in the entropy pool. From this entropy pool,
random numbers are created.
If you can, show the whole log
Command to save log to File1.log.zip

Code: Select all

journalctl  > File1.log ; zip File1.zip File1.log
Or if you don't like .zip archive

Code: Select all

journalctl  | xz -c > file2.log.xz
Then search file in your own home directory /home/Your_User_Name/Here_Search
and send it here as an attachment.

Code: Select all

Sep 11 09:01:32 PC kernel: EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
I trust it is just only info about loaded option.
The grep command mentioned above only shows certain lines from log that contain certain words.

Code: Select all

Sep 11 09:01:39 PC systemd-udevd[475]: nvidia: Process '/bin/systemctl start --no-block nvidia-persistenced.service' failed with exit code 5.
Sep 11 09:01:39 PC systemd-udevd[479]: NVIDIA ACPI Video Driver: Process '/bin/systemctl start --no-block nvidia-persistenced.service' failed with exit code 5.
Sep 11 09:01:41 PC systemd-udevd[472]: NVIDIA ACPI Video Driver: Process '/bin/systemctl stop --no-block nvidia-persistenced' failed with exit code 5.
I checked own stastus this service.

Code: Select all

# sudo systemctl status  nvidia-persistenced.service
● nvidia-persistenced.service - NVIDIA Persistence Daemon
     Loaded: loaded (/lib/systemd/system/nvidia-persistenced.service; static; vendor preset: enabled)
     Active: active (running) since Fri 2020-09-11 09:27:30 CEST; 1h 17min ago
...
$ dpkg -S /lib/systemd/system/nvidia-persistenced.service
nvidia-compute-utils-440: /lib/systemd/system/nvidia-persistenced.service

Code: Select all

$ dpkg -s nvidia-compute-utils-440
...
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
...
Description: NVIDIA compute utilities
 This package provides utility binaries for paraller general purpose
 computing use cases with the NVIDIA driver.
So you can ask there or there https://github.com/NVIDIA/nvidia-persistenced/issues
You can also check this viewtopic.php?t=233113

Code: Select all

Sep 11 09:01:41 PC systemd-udevd[469]: controlC0: Process '/usr/sbin/alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime restore 0' failed with exit code 99.
Does the sound work?
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

Sorry for the late reply, yes sound works fine. Please find the attachment
File1.log.zip
The log, which was needed
(33.03 KiB) Downloaded 13 times
1000
Level 4
Level 4
Posts: 245
Joined: Wed Jul 29, 2020 2:14 am

Re: Linux Mint 20 takes a lot of time to load

Post by 1000 »

You can also upload file /var/log/Xorg.0.log
this log is from the nvidia driver only.
If you tested Nouveau driver, it will have output in journalctl.

I suggest you report it, ask the developers, and try to fix any bug. Each bug fix should improve system performance / loading speed.
Below is the address for the ubuntu developer.

Code: Select all

$ locate nvidia-persistenced.service
/lib/systemd/system/nvidia-persistenced.service

$ dpkg -S /lib/systemd/system/nvidia-persistenced.service
nvidia-compute-utils-440: /lib/systemd/system/nvidia-persistenced.service

$ dpkg -s nvidia-compute-utils-440
...
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
...
Based on your log I have built a command that filters suspicious lines better.

Code: Select all

grep -Ei 'error|warning|fail|segfault|not |no [a-Z]|bug|doesn.t|blocked|unstable|can.t |unable' File1.log
Probably irrelevant thing

Code: Select all

Sep 21 07:41:46 PC systemd[2560]: hddtemp.service: Failed to execute command: No such file or directory
Sep 21 07:41:46 PC systemd[2560]: hddtemp.service: Failed at step EXEC spawning /etc/init.d/hddtemp: No such file or directory
Sep 21 07:41:46 PC systemd[1]: hddtemp.service: Failed with result 'exit-code'.
I checked in my system, if I have and which package provide this file

Code: Select all

$ dpkg -S /etc/init.d/hddtemp
hddtemp: /etc/init.d/hddtemp
I tried search in repository, which package provide this file.

Code: Select all

$ apt-file search /etc/init.d/hddtemp
hddtemp: /etc/init.d/hddtemp   
Check if you have hddtemp installed. Check if file exists.
If package exist / you have installed and is not broken, but file not exist in your system,
try check in free time RAM, hard drive with GSmartControl and pendrive, and ISO from which you installed Linux Mint.
You can try reinstall hddtemp.
User avatar
Larry78723
Level 11
Level 11
Posts: 3536
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Linux Mint 20 takes a lot of time to load

Post by Larry78723 »

In checking his journalctl log entries, I found an almost 2 minute holdup caused by snapd:
Sep 21 07:42:28 PC snapd[939]: stateengine.go:150: state ensure error: cannot refresh snap-declaration for "core": Get https://api.snapcraft.io/api/v1/snaps/a ... x-format=4: dial tcp: lookup api.snapcraft.io on 127.0.0.53:53: server misbehaving
Sep 21 07:44:16 PC kernel: Monitor-Mwait will be used to enter C-2 state
Image
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

Larry78723 wrote:
Tue Sep 22, 2020 6:43 am
In checking his journalctl log entries, I found an almost 2 minute holdup caused by snapd:
Sep 21 07:42:28 PC snapd[939]: stateengine.go:150: state ensure error: cannot refresh snap-declaration for "core": Get https://api.snapcraft.io/api/v1/snaps/a ... x-format=4: dial tcp: lookup api.snapcraft.io on 127.0.0.53:53: server misbehaving
Sep 21 07:44:16 PC kernel: Monitor-Mwait will be used to enter C-2 state
So should I disable it? If yes how and will it affect anything?
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load

Post by Spectrum75 »

1000 wrote:
Tue Sep 22, 2020 4:57 am
You can also upload file /var/log/Xorg.0.log
this log is from the nvidia driver only.
If you tested Nouveau driver, it will have output in journalctl.

I suggest you report it, ask the developers, and try to fix any bug. Each bug fix should improve system performance / loading speed.
Below is the address for the ubuntu developer.

Code: Select all

$ locate nvidia-persistenced.service
/lib/systemd/system/nvidia-persistenced.service

$ dpkg -S /lib/systemd/system/nvidia-persistenced.service
nvidia-compute-utils-440: /lib/systemd/system/nvidia-persistenced.service

$ dpkg -s nvidia-compute-utils-440
...
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
...
Based on your log I have built a command that filters suspicious lines better.

Code: Select all

grep -Ei 'error|warning|fail|segfault|not |no [a-Z]|bug|doesn.t|blocked|unstable|can.t |unable' File1.log
Probably irrelevant thing

Code: Select all

Sep 21 07:41:46 PC systemd[2560]: hddtemp.service: Failed to execute command: No such file or directory
Sep 21 07:41:46 PC systemd[2560]: hddtemp.service: Failed at step EXEC spawning /etc/init.d/hddtemp: No such file or directory
Sep 21 07:41:46 PC systemd[1]: hddtemp.service: Failed with result 'exit-code'.
I checked in my system, if I have and which package provide this file

Code: Select all

$ dpkg -S /etc/init.d/hddtemp
hddtemp: /etc/init.d/hddtemp
I tried search in repository, which package provide this file.

Code: Select all

$ apt-file search /etc/init.d/hddtemp
hddtemp: /etc/init.d/hddtemp   
Check if you have hddtemp installed. Check if file exists.
If package exist / you have installed and is not broken, but file not exist in your system,
try check in free time RAM, hard drive with GSmartControl and pendrive, and ISO from which you installed Linux Mint.
You can try reinstall hddtemp.


Umm, I only understood a bit, can you please simplify it a bit. Sorry to ask again but as mentioned I am new to linux
1000
Level 4
Level 4
Posts: 245
Joined: Wed Jul 29, 2020 2:14 am

Re: Linux Mint 20 takes a lot of time to load

Post by 1000 »

Spectrum75 lack of time is slowing me down a bit and I can't write a guide.

Check if file /etc/init.d/hddtemp
Check if hddtemp installed.
If hddtemp installed, but file not exist, it is something wrong with this package.

If it is true
You can try fix package by reinstall.

Writing everything takes a long tutorial.
Try to search the internet for suspicious lines.

For example, from my log

Code: Select all

wrz 26 22:40:59 user fwupd[15913]: 20:40:59:0780 FuEngine             device e421b2fc248391f6fe3e55ddbb3c9043be068bd0 [SSDPR-CL100-480-G2] does not define a vendor-id!
From internet https://en.wikipedia.org/wiki/Fwupd#Lin ... re_Service
I know SSDPR-CL this is SSD disk.
And I see that it repeats itself with other disks, so it's just information, not a bug.
You can always ask the developers to be sure.

Useful links. For a novice user this may not be enough knowledge
1. https://wiki.ubuntu.com/DebuggingProcedures
2. https://linuxmint-troubleshooting-guide ... en/latest/
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Linux Mint 20 takes a lot of time to load [Abandoned]

Post by Spectrum75 »

All these instructions are a bit hard for me, so I will just stick with it :)
User avatar
Kadaitcha Man
Level 11
Level 11
Posts: 3655
Joined: Mon Aug 27, 2012 10:17 pm

Re: Linux Mint 20 takes a lot of time to load [Abandoned]

Post by Kadaitcha Man »

Spectrum75 wrote:
Tue Oct 13, 2020 7:13 am
All these instructions are a bit hard for me, so I will just stick with it :)
What on earth is difficult about copy/paste?
It's pronounced kad-eye-cha, not kada-itcha.
DAMIEN1307
Level 11
Level 11
Posts: 3728
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Linux Mint 20 takes a lot of time to load [Abandoned]

Post by DAMIEN1307 »

What on earth is difficult about copy/paste?
I dont think that was so much the problem as how complex it must look to the OP as well as the sheer amount of instructions from so many contributors that answered...Simplicity is much more elegant...DAMIEN
ORDO AB CHAO
"I refuse to be assimilated, I refuse to become one with the Borg Collective"
Post Reply

Return to “Newbie Questions”