High CPU usgae

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
keshav
Level 1
Level 1
Posts: 4
Joined: Wed Aug 12, 2020 1:55 pm

High CPU usgae

Post by keshav »

Hi I have Linux Mint Cinnamon 20 and the CPU usage is more 40% idle but in win 10 it is around 2-3% idle,
My system information:
CPU:
Topology: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP
arch: Skylake rev: 3 L2 cache: 3072 KiB
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
System:
Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
base: Ubuntu 20.04 focal
ensors:
System Temperatures: cpu: 40.5 C mobo: 29.8 C
Fan Speeds (RPM): N/A
Hoser Rob
Level 16
Level 16
Posts: 6788
Joined: Sat Dec 15, 2012 8:57 am

Re: High CPU usgae

Post by Hoser Rob »

Don't edit info like that, paste the complete text output of inxi -Fxz run in the terminal.
keshav
Level 1
Level 1
Posts: 4
Joined: Wed Aug 12, 2020 1:55 pm

Re: High CPU usgae

Post by keshav »

Output for inxi -Fxz

Code: Select all

System:
  Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: HP product: HP Laptop 15-bs0xx 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: HP model: 8328 v: 23.70 serial: <filter> UEFI: Insyde v: F.52 
  date: 03/04/2019 
Battery:
  ID-1: BAT1 charge: 26.8 Wh condition: 32.0/41.6 Wh (77%) 
  model: Hewlett-Packard PABAS0241231 status: Charging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard 
  charge: 55% (should be ignored) status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 15999 
  Speed: 500 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.4.0-42-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 01:00.0 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter 
  vendor: Hewlett-Packard driver: rtw_pci v: N/A port: 3000 bus ID: 02:00.0 
  IF: wlo1 state: up mac: <filter> 
  Device-3: Realtek 802.11n WLAN Adapter type: USB driver: btusb 
  bus ID: 1-4:3 
Drives:
  Local Storage: total: 931.51 GiB used: 68.58 GiB (7.4%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-60JC3T1 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 18.21 GiB used: 8.74 GiB (48.0%) fs: ext4 dev: /dev/sda8 
  ID-2: /home size: 78.43 GiB used: 3.93 GiB (5.0%) fs: ext4 dev: /dev/sda10 
  ID-3: swap-1 size: 3.73 GiB used: 9.0 MiB (0.2%) fs: swap dev: /dev/sda9 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 231 Uptime: 35m Memory: 3.76 GiB used: 1.36 GiB (36.0%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38 
Hoser Rob
Level 16
Level 16
Posts: 6788
Joined: Sat Dec 15, 2012 8:57 am

Re: High CPU usgae

Post by Hoser Rob »

I don't see anything particularly amiss (others may :wink: ), try running System Monitor and see what's at thetop of the CPU load list.
User avatar
antikythera
Level 9
Level 9
Posts: 2567
Joined: Thu Jul 02, 2020 12:52 pm

Re: High CPU usgae

Post by antikythera »

How long has Mint been installed? It may still be doing the first index of your drives so that searches work quicker.
Don't take life so seriously, nobody gets out alive anyway!
AMSTRAD CPC6128 - 128KB RAM, 3" Hitachi Floppy Diskette Drive, External Sony Cassette Recorder, Locomotive BASIC 1.1, CTM-644 Monitor
User avatar
I2k4
Level 5
Level 5
Posts: 686
Joined: Thu Feb 02, 2012 8:33 pm

Re: High CPU usgae

Post by I2k4 »

I happened to be running LM20 Cinnamon on a pendrive to pretest something, and found one core of the processor maxxing out persistently. (I use the Multi-core System panel applet for display.) Going into Session and Startup / Application Autostart and disabling useless stuff eliminated it - obviously what's useless to different users will vary, but a worthwhile exercise.
TRUST BUT VERIFY any advice from anybody, including me. Mint/Ubuntu user since 10.04 LTS. LM20 64 bit XFCE (Dell 1520). Dual booting LM20 XFCE / Win7 (Lenovo desktop and Acer netbook).
User avatar
Flemur
Level 18
Level 18
Posts: 8817
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: High CPU usgae

Post by Flemur »

keshav wrote:
Sun Aug 23, 2020 9:54 am
Hi I have Linux Mint Cinnamon 20 and the CPU usage is more 40% idle but in win 10 it is around 2-3% idle,
Which processes are using CPU?
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Post Reply

Return to “Newbie Questions”