Annoyance with dual-displays when waking up

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 3
Level 3
Posts: 154
Joined: Tue Jun 04, 2013 4:26 pm

Annoyance with dual-displays when waking up

Post by hpmc13 »

I've run two monitors for a long time, but until recently they were different makes/models/sizes/resolutions. Everything worked fine; it looked a little weird at times because of the differences, but it all worked as expected.

I recently acquired two of the exact same monitors. They are both hooked up through HDMI (0,1) on an RX 580, set to the same resolution, refresh rate, etc. The left monitor is primary, right is secondary. They work wonderfully except for when they wake up from going to sleep. I hope that I'm using the correct terminology: I mean when the monitors blank-out and go into low-power mode but the computer is still running. I have it set to happen after 15 minutes.

When I come back and move my mouse, most open windows on the left screen go to the right screen and some open windows on the right screen go to the left screen. Not all of them, and not all of the time, but more than 50% of the time this happens. I also have a Conky that should always appear on the far right-hand side of the right monitor. When the screens wake up it is on the far-right side of the left monitor. Also, the icon for Computer will jump down a few spaces, below any other icons below it (it's usually in the top-left corner of the primary screen.) None of the other icons will move. All of my panels will stay where they should.

I have tried swapping the monitors physically, changing the primary and secondary designations, buying new HDMI cables, and switching the HDMI cables on the GPU when that didn't work. The monitors have HDMI and VGA inputs, but my GPU does not support VGA.

None of this is dealbreaking, really, but annoying as I usually have the same open windows in the same place.

Any help is greatly appreciated.

Code: Select all

inxi -Fzx
System:    Kernel: 5.4.0-48-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 
           Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: Micro-Star model: B450-A PRO (MS-7B86) v: 2.0 serial: <filter> 
           UEFI [Legacy]: American Megatrends v: A.C0 date: 11/08/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86403 
           Speed: 2173 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2200 2: 2202 3: 2198 4: 2199 5: 2200 6: 2200 7: 2200 
           8: 2199 9: 2199 10: 2200 11: 2200 12: 2199 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus ID: 26:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.35.0 5.4.0-48-generic LLVM 10.0.0) v: 4.6 Mesa 20.0.8 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Sapphire Limited driver: snd_hda_intel 
           v: kernel bus ID: 26:00.1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 28:00.4 
           Sound Server: ALSA v: k5.4.0-48-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: f000 bus ID: 22:00.0 
           IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.31 TiB used: 825.56 GiB (61.5%) 
           ID-1: /dev/sda model: ZOTAC ZTSSD-A4P-120G size: 111.79 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-60WN4A0 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD3200AAJS-22B4A0 size: 298.09 GiB 
Partition: ID-1: / size: 29.34 GiB used: 16.96 GiB (57.8%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 28.84 GiB used: 14.91 GiB (51.7%) fs: ext4 dev: /dev/sda2 
           ID-3: swap-1 size: 1.99 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 43.6 C mobo: 34.0 C gpu: amdgpu temp: 41 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 817 fan-3: 689 fan-4: 0 fan-5: 901 fan-6: 0 gpu: amdgpu fan: 841 
Info:      Processes: 313 Uptime: 4h 13m Memory: 15.65 GiB used: 1.98 GiB (12.7%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38
Running LM 20 Cinnamon
Level 3
Level 3
Posts: 154
Joined: Tue Jun 04, 2013 4:26 pm

Re: Annoyance with dual-displays when waking up

Post by hpmc13 »

Bumping myself to see if anyone has any ideas.

This problem still persists and I'm getting to my wits' end.

Thank you in advance.
Running LM 20 Cinnamon
User avatar
Level 9
Level 9
Posts: 2948
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Annoyance with dual-displays when waking up

Post by SMG »

Usually I see complaints of everything moving to the other screen and not some do and others do not type of issue. I'm not sure what might be different about those specific apps/icons/windows that they move.

In the chance that this somehow might be in how the RX580 is managing memory and ports, there is a newer driver available for your card that you could try Radeon™ RX 580 Drivers & Support.

Take a Timeshift snapshot and then try the driver is the only idea I currently have. (Read the release notes for the driver because they mention an issue with a specific kernel version. Not sure if it applies to later versions.)
LM20.1 Cinnamon
Post Reply

Return to “Newbie Questions”