Printer Help HP mfp m477fdw

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
bluesky509
Level 1
Level 1
Posts: 28
Joined: Fri Jun 05, 2015 11:32 am

Printer Help HP mfp m477fdw

Post by bluesky509 »

Hello everyone

I'm hoping to get some help getting my printer/scanner working correctly. It worked on previous versions of LM but it's not working on LM20.

Doing sudo apt install hplip-gui ---> Then HPLip won't open/start
Tried to manually download the latest file but it seems to not work as it won't download the dependencies "pyqt5".

Doing hp-check I get the following:

Code: Select all

hp-check[17314]: info: :
hp-check[17314]: info: :[01mHP Linux Imaging and Printing System (ver. 3.20.6)[0m
hp-check[17314]: info: :[01mDependency/Version Check Utility ver. 15.1[0m
hp-check[17314]: info: :
hp-check[17314]: info: :Copyright (c) 2001-18 HP Development Company, LP
hp-check[17314]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[17314]: info: :This is free software, and you are welcome to distribute it
hp-check[17314]: info: :under certain conditions. See COPYING file for more details.
hp-check[17314]: info: :
hp-check[17314]: info: :[01mNote: hp-check can be run in three modes:[0m
hp-check[17314]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[17314]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[17314]: info: :are installed to successfully compile HPLIP.                                    
hp-check[17314]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
hp-check[17314]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
hp-check[17314]: info: :has the proper dependencies installed to successfully run.                      
hp-check[17314]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
hp-check[17314]: info: :will check both of the above cases (both compile- and run-time dependencies).   
hp-check[17314]: info: :
hp-check[17314]: info: :Check types:                                                                    
hp-check[17314]: info: :a. EXTERNALDEP - External Dependencies                                          
hp-check[17314]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)    
hp-check[17314]: info: :c. COMPILEDEP - Compile time Dependencies                                       
hp-check[17314]: info: :d. [All are run-time checks]                                                    
hp-check[17314]: info: :PYEXT SCANCONF QUEUES PERMISSION                                                
hp-check[17314]: info: :
hp-check[17314]: info: :Status Types:
hp-check[17314]: info: :    OK
hp-check[17314]: info: :    MISSING       - Missing Dependency or Permission or Plug-in
hp-check[17314]: info: :    INCOMPAT      - Incompatible dependency-version or Plugin-version
hp-check[17314]: info: :
warning: [01m22-20 version is not supported. Using 22-19.3 versions dependencies to verify and install...[0m
hp-check[17314]: info: :
hp-check[17314]: info: :---------------
hp-check[17314]: info: :| SYSTEM INFO |
hp-check[17314]: info: :---------------
hp-check[17314]: info: :
hp-check[17314]: info: : Kernel: 5.4.0-51-generic #56-Ubuntu SMP Mon Oct 5 14:28:49 UTC 2020 GNU/Linux
 Host: workstation
 Proc: 5.4.0-51-generic #56-Ubuntu SMP Mon Oct 5 14:28:49 UTC 2020 GNU/Linux
 Distribution: 22 20
hp-check[17314]: info: : Bitness: 64 bit

hp-check[17314]: info: :
hp-check[17314]: info: :-----------------------
hp-check[17314]: info: :| HPLIP CONFIGURATION |
hp-check[17314]: info: :-----------------------
hp-check[17314]: info: :
hp-check[17314]: info: :HPLIP-Version: HPLIP 3.20.6
hp-check[17314]: info: :HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 22 distro  20 version 
hp-check[17314]: info: :
hp-check[17314]: info: :[01mCurrent contents of '/etc/hp/hplip.conf' file:[0m
hp-check[17314]: info: :# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-3.20.6
html=/usr/share/doc/hplip-3.20.6
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=no
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.6
restricted-build=no
ui-toolkit=no
qt3=no
qt4=no
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

hp-check[17314]: info: :
hp-check[17314]: info: :[01mCurrent contents of '/var/lib/hp/hplip.state' file:[0m
hp-check[17314]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[17314]: info: :
hp-check[17314]: info: :[01mCurrent contents of '~/.hplip/hplip.conf' file:[0m
hp-check[17314]: info: :[upgrade]
notify_upgrade = true
last_upgraded_time = 1593770936
pending_upgrade_time = 0

[installation]
date_time = 10/19/20 16:18:15
version = 3.20.6

[last_used]
device_uri = hpfax:/net/HP_Color_LaserJet_MFP_M477fdw?hostname=NPICB1335.local


hp-check[17314]: info: : <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
hp-check[17314]: info: :
hp-check[17314]: info: :--------------
hp-check[17314]: info: :| COMPILEDEP |
hp-check[17314]: info: :--------------
hp-check[17314]: info: :
hp-check[17314]: info: : gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           OK         -
hp-check[17314]: info: : make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -
hp-check[17314]: info: : libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
hp-check[17314]: info: :
hp-check[17314]: info: :------------------------
hp-check[17314]: info: :| General Dependencies |
hp-check[17314]: info: :------------------------
hp-check[17314]: info: :
hp-check[17314]: info: : libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
hp-check[17314]: info: : python-xml           Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
hp-check[17314]: info: : libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
hp-check[17314]: info: : sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
hp-check[17314]: info: : pil                  PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               6.2.1           OK         -
hp-check[17314]: info: :[31;01m error: pyqt4-dbus    PyQt 4 DBus - DBus Support for PyQt4                         REQUIRED        4.0             -               MISSING    'pyqt4-dbus needs to be installed'[0m
hp-check[17314]: info: : libpthread           libpthread - POSIX threads library                           REQUIRED        -               2.31            OK         -
hp-check[17314]: info: : python-devel         Python devel - Python development files                      REQUIRED        2.2             2.7.18          OK         -
hp-check[17314]: info: : cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.3.1           OK         -
hp-check[17314]: info: : python-dbus          Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
hp-check[17314]: info: : cups-ddk             CUPS DDK - CUPS driver development kit                       OPTIONAL        -               -               OK         -
hp-check[17314]: info: :[31;01m error: reportlab     Reportlab - PDF library for Python                           OPTIONAL        2.0             -               MISSING    'reportlab needs to be installed'[0m
hp-check[17314]: info: :[31;01m error: pyqt4         PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    -[0m
hp-check[17314]: info: : libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
hp-check[17314]: info: : cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.3.1           OK         -
hp-check[17314]: info: : python2X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             2.7.18          OK         -
hp-check[17314]: info: :[31;01m error: python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python-notify needs to be installed'[0m
hp-check[17314]: info: : libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
hp-check[17314]: info: : sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
hp-check[17314]: info: :
hp-check[17314]: info: :----------------------
hp-check[17314]: info: :| Scan Configuration |
hp-check[17314]: info: :----------------------
hp-check[17314]: info: :
hp-check[17314]: info: : scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.6          OK         -
hp-check[17314]: info: : hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.6          OK         'hpaio found in /etc/sane.d/dll.conf'
hp-check[17314]: info: :
hp-check[17314]: info: :-------------------------
hp-check[17314]: info: :| External Dependencies |
hp-check[17314]: info: :-------------------------
hp-check[17314]: info: :
hp-check[17314]: info: : gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
hp-check[17314]: info: : scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
hp-check[17314]: info: : cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.3.1           OK         'CUPS Scheduler is running'
hp-check[17314]: info: : network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
hp-check[17314]: info: : policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
hp-check[17314]: info: : xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
hp-check[17314]: info: : dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.16         OK         -
hp-check[17314]: info: : avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -
hp-check[17314]: info: :
hp-check[17314]: info: :---------------------
hp-check[17314]: info: :| Python Extentions |
hp-check[17314]: info: :---------------------
hp-check[17314]: info: :
hp-check[17314]: info: : hpmudext             IO-Extension                                                 REQUIRED        -               3.20.6          OK         -
hp-check[17314]: info: : cupsext              CUPS-Extension                                               REQUIRED        -               3.20.6          OK         -
hp-check[17314]: info: :
hp-check[17314]: info: :------------------------------
hp-check[17314]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[17314]: info: :------------------------------
hp-check[17314]: info: :
hp-check[17314]: info: :device `hpaio:/net/hp_color_laserjet_mfp_m477fdw?ip=192.168.1.212&queue=false' is a Hewlett-Packard hp_color_laserjet_mfp_m477fdw all-in-one
device `escl:http://192.168.1.212:8080' is a ESCL HP Color LaserJet MFP M477fdw (CB1335) flatbed scanner

hp-check[17314]: info: :
hp-check[17314]: info: :--------------------------
hp-check[17314]: info: :| DISCOVERED USB DEVICES |
hp-check[17314]: info: :--------------------------
hp-check[17314]: info: :
hp-check[17314]: info: :No devices found.
hp-check[17314]: info: :
hp-check[17314]: info: :---------------------------------
hp-check[17314]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[17314]: info: :---------------------------------
hp-check[17314]: info: :
hp-check[17314]: info: :
hp-check[17314]: info: :[01mHP_Color_LaserJet_MFP_M477fdw_CB1335_[0m
hp-check[17314]: info: :[01m-------------------------------------[0m
hp-check[17314]: info: :Type: Unknown
hp-check[17314]: info: :Device URI: implicitclass://HP_Color_LaserJet_MFP_M477fdw_CB1335_/
hp-check[17314]: info: :PPD: /etc/cups/ppd/HP_Color_LaserJet_MFP_M477fdw_CB1335_.ppd
warning: Failed to read /etc/cups/ppd/HP_Color_LaserJet_MFP_M477fdw_CB1335_.ppd ppd file
hp-check[17314]: info: :PPD Description: 
hp-check[17314]: info: :Printer status: printer HP_Color_LaserJet_MFP_M477fdw_CB1335_ is idle.  enabled since Mon 19 Oct 2020 04:03:02 PM CDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
hp-check[17314]: info: :
hp-check[17314]: info: :
hp-check[17314]: info: :--------------
hp-check[17314]: info: :| PERMISSION |
hp-check[17314]: info: :--------------
hp-check[17314]: info: :
hp-check[17314]: info: :
hp-check[17314]: info: :-----------
hp-check[17314]: info: :| SUMMARY |
hp-check[17314]: info: :-----------
hp-check[17314]: info: :
hp-check[17314]: info: :[01mMissing Required Dependencies[0m
hp-check[17314]: info: :[01m-----------------------------[0m
error: 'python-qt4-dbus' package is missing/incompatible 
error: 'python-qt4' package is missing/incompatible 
hp-check[17314]: info: :
hp-check[17314]: info: :[01mMissing Optional Dependencies[0m
hp-check[17314]: info: :[01m-----------------------------[0m
error: 'python-reportlab' package is missing/incompatible 
error: 'python-notify' package is missing/incompatible 
hp-check[17314]: info: :
hp-check[17314]: info: :Total Errors: 4
hp-check[17314]: info: :Total Warnings: 1
hp-check[17314]: info: :
hp-check[17314]: info: :
hp-check[17314]: info: :Done.
Could someone advice on what I should do to get both print and full scanning features working?
At the moment I can print but I really need to scan.

Thank you


OS Info:

Code: Select all

System:    Kernel: 5.4.0-51-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 wm: muffin dm: LightDM 
           Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: Gigabyte model: Z97M-D3H v: x.x serial: <filter> BIOS: American Megatrends v: F5 
           date: 05/30/2014 
CPU:       Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 63999 
           Speed: 1867 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 3167 2: 3801 3: 2381 4: 4047 5: 2501 6: 3001 7: 3840 
           8: 4287 
Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics vendor: Gigabyte driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0412 
           Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: eVga.com. driver: nvidia v: 450.80.02 bus ID: 01:00.0 
           chip ID: 10de:1c03 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 3440x1440~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0c0c 
           Device-2: Intel 9 Series Family HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8ca0 
           Device-3: NVIDIA GP106 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f1 
           Sound Server: ALSA v: k5.4.0-51-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Ralink RT3062 Wireless 802.11n 2T/2R vendor: Edimax driver: rt2800pci v: 2.3.0 port: d000 bus ID: 05:01.0 
           chip ID: 1814:3062 
           IF: wlp5s1 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 100.42 GiB (8.6%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00BN5A0 size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 227.74 GiB used: 50.21 GiB (22.0%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 44 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 45% 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/appimagelauncher-team-stable-focal.list 
           1: deb http://ppa.launchpad.net/appimagelauncher-team/stable/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/home:ungoogled_chromium.list 
           1: deb http://download.opensuse.org/repositories/home:/ungoogled_chromium/Ubuntu_Focal/ /
           Active apt repos in: /etc/apt/sources.list.d/numix-ppa-focal.list 
           1: deb http://ppa.launchpad.net/numix/ppa/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 280 Uptime: 34m Memory: 15.48 GiB used: 2.55 GiB (16.5%) Init: systemd v: 245 runlevel: 5 Compilers: 
           gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 

linux newbie
User avatar
LanceM
Level 10
Level 10
Posts: 3288
Joined: Sun Jul 08, 2018 11:50 pm

Re: Printer Help HP mfp m477fdw

Post by LanceM »

Here's a link that might work. It uses commands to install hplip-gui: https://zoomadmin.com/HowToInstall/Ubun ... /hplip-gui
You should uninstall what you have 1st. Also go the your home and enable seeing hidden files with ctrl+h and search hplip. Delete all instances. Then try the installation.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
hayden
Level 2
Level 2
Posts: 78
Joined: Thu Apr 07, 2011 7:59 am
Location: Texas, USA

Re: Printer Help HP mfp m477fdw

Post by hayden »

Hello, is scan-to-email an option vs scan-to-computer? This is how I scan on my HP laserjet at home.
bluesky509
Level 1
Level 1
Posts: 28
Joined: Fri Jun 05, 2015 11:32 am

Re: Printer Help HP mfp m477fdw

Post by bluesky509 »

EDIT / POST MAY BE DELETED

Could not get this working and really needed to scan/print so I downgraded to 19.3. :(

Seems to me that hplip is just not compatible with LM20.
LM19.3 is working with a simple apt install hplip, prompted to download needed plugin and everything worked.

I found this link which thinking maybe it was a python issue.

Checked: ls -lrth python*
Checked: python --version
Output was python2.7

I tried the following

Code: Select all

: sudo unlink python
: sudo ln -s /usr/bin/python3.8 python
: python --version
: python --version
New Output = 3.8.5

I removed all traces of hiplip. Re-Ran sudo apt install hplip-gui. I showed up in the start menu but will not open even after restarting.

Removed it again. Downloaded the most recent hplip [hplip-3.20.9.run].
Now I am getting the following errors I cannot fix:
..../.local/lib/python3.8/site-packages/PyQt5/QtWidgets.so: failed to map segment from shared object
error: hp-setup failed. Please run hp-setup manually.

error: /home/.../.local/lib/python3.8/site-packages/PyQt5/QtCore.so: failed to map segment from shared object
error: Unable to load Qt4/Qt5 support. Is it installed?
Also getting:
warning: Missing OPTIONAL dependency for option 'gui_qt5': python3-notify2 (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing OPTIONAL dependency for option 'gui_qt5': python3-pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
I am so close to giving up and going back to Linux Mint 19.

hp-check -r:

Code: Select all

HP Linux Imaging and Printing System (ver. 3.20.9)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                    
2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                      
3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                    
a. EXTERNALDEP - External Dependencies                                          
b. GENERALDEP - General Dependencies (required both at compile and run time)    
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                    
PYEXT SCANCONF QUEUES PERMISSION                                                

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

[b]warning: linuxmint-20 version is not supported. Using linuxmint-19.3 versions dependencies to verify and install...[/b]

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.4.0-52-generic #57-Ubuntu SMP Thu Oct 15 10:57:00 UTC 2020 GNU/Linux
 Host: workstation
 Proc: 5.4.0-52-generic #57-Ubuntu SMP Thu Oct 15 10:57:00 UTC 2020 GNU/Linux
 Distribution: linuxmint 20
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.9
HPLIP-Home: /usr/share/hplip
[b]warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  20 version [/b]

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.9

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-3.20.9
html=/usr/share/doc/hplip-3.20.9
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=no
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=no
fax-build=no
dbus-build=no
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.9
restricted-build=no
ui-toolkit=no
[b]qt3=no
qt4=no
qt5=no[/b]
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=yes


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
warning: Could not access file: No such file or directory
 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

[b] error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'[/b]
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.16         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               -               OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.5           OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
[b] error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'[/b]
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.8.5           OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               7.0.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.34          OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.9          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.9          OK         -

----------------------
| Scan Configuration |
----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.9          OK         -

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP_Color_LaserJet_MFP_M477fdw_CB1335_
-------------------------------------
Type: Unknown
Device URI: implicitclass://HP_Color_LaserJet_MFP_M477fdw_CB1335_/
PPD: /etc/cups/ppd/HP_Color_LaserJet_MFP_M477fdw_CB1335_.ppd
PPD Description: HP Color LaserJet MFP M477fdw, driverless, cups-filters 1.27.4
Printer status: printer HP_Color_LaserJet_MFP_M477fdw_CB1335_ is idle.  enabled since Tue 20 Oct 2020 08:30:16 PM CDT
[b]warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.[/b]


--------------
| PERMISSION |
--------------

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
[b]error: 'libcups2' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
[/b]
Missing Optional Dependencies
-----------------------------
[b]error: 'python3-dbus.mainloop.qt' package is missing/incompatible [/b]

Total Errors: 3
Total Warnings: 2

Done.
linux newbie
brian_p
Level 6
Level 6
Posts: 1411
Joined: Thu Jan 17, 2019 9:20 am

Re: Printer Help HP mfp m477fdw

Post by brian_p »

I am so close to giving up and going back to Linux Mint 19.
  • HPLIP in LM20 supports your device. Why mess with HPLIP 3.20.6?
  • HPLIP is not needed on LM20 for printing or scanning. Use driverless printing and sane-airscan.
  • In the time you have struggled with python and HPLIP 3.20.6 you could have set up a driverless print queue.
  • Actually, a driverless print queue has been auto-setup for you. You do not say whether it works.
--
Brian.
bluesky509
Level 1
Level 1
Posts: 28
Joined: Fri Jun 05, 2015 11:32 am

Re: Printer Help HP mfp m477fdw

Post by bluesky509 »

brian_p wrote:
Wed Oct 21, 2020 6:09 am
I am so close to giving up and going back to Linux Mint 19.
  • HPLIP in LM20 supports your device. Why mess with HPLIP 3.20.6?
  • HPLIP is not needed on LM20 for printing or scanning. Use driverless printing and sane-airscan.
  • In the time you have struggled with python and HPLIP 3.20.6 you could have set up a driverless print queue.
  • Actually, a driverless print queue has been auto-setup for you. You do not say whether it works.
I'm unfamiliar with how "driverless printing and sane-airscan" is supposed to work... Is this meant to work out-of-the-box because it was not working for me thus resorting to other methods that had previously worked on LM19. The only thing LM20 did automatically was add the printer the the printer list. I could print but it was the scanning feature that would not work and that I really needed... I tried the default scanner app or xsane.
linux newbie
brian_p
Level 6
Level 6
Posts: 1411
Joined: Thu Jan 17, 2019 9:20 am

Re: Printer Help HP mfp m477fdw

Post by brian_p »

bluesky509 wrote:
Wed Oct 21, 2020 7:33 pm

I'm unfamiliar with how "driverless printing and sane-airscan" is supposed to work...
Then become familiar with it :). Read the Printers and Scanners forum and

https://wiki.debian.org/CUPSDriverlessPrinting
Is this meant to work out-of-the-box because it was not working for me thus resorting to other methods that had previously worked on LM19. The only thing LM20 did automatically was add the printer the the printer list. I could print but it was the scanning feature that would not work and that I really needed... I tried the default scanner app or xsane.
You can print but not scan? Say whether you are USB connected or not. Give the output of

Code: Select all

scanimage -L
--
Brian.
fermat
Level 1
Level 1
Posts: 6
Joined: Tue Mar 10, 2020 11:19 am

Re: Printer Help HP mfp m477fdw

Post by fermat »

Many users are reporting problems with scanning on LM20. see
viewtopic.php?f=51&t=329760&p=1881829&h ... r#p1881829

I had problems getting my HP 6960 to work when I upgraded to LM20. Managed to sort of fix it for printing, but not reliably. And scanning was a no-go.
Eventually in desperation I wiped out all references I could find to it as a USB printer. Then plugged it into my router as a networked printer. After a minute or so, LM20 recognised it and I could configure the printing options I needed. After experimenting, I found that XSane (from Software Manager) could happily drive its scanning function. (XSane is vastly over-featured for my needs, but so what?).

One slight hiccup I encountered. If the printer was powered on when I booted, LM seem to get confused in trying to sort out the internet and printer connections. So I now turn off the printer at end of day, and turn it on when I first need it next day after booting.

It might be worth you trying that.
hayden
Level 2
Level 2
Posts: 78
Joined: Thu Apr 07, 2011 7:59 am
Location: Texas, USA

Re: Printer Help HP mfp m477fdw

Post by hayden »

or scan-to-email
brian_p
Level 6
Level 6
Posts: 1411
Joined: Thu Jan 17, 2019 9:20 am

Re: Printer Help HP mfp m477fdw

Post by brian_p »

fermat wrote:
Thu Oct 22, 2020 11:05 am
Many users are reporting problems with scanning on LM20. see
viewtopic.php?f=51&t=329760&p=1881829&h ... r#p1881829
That is partly (if not wholly) because neither Ubuntu nor LM provided anything to document changes in the printing system. Users were left completely in the dark.
I had problems getting my HP 6960 to work when I upgraded to LM20. Managed to sort of fix it for printing, but not reliably. And scanning was a no-go.
That is what it is like when a user is in the dark.
Eventually in desperation I wiped out all references I could find to it as a USB printer. Then plugged it into my router as a networked printer. After a minute or so, LM20 recognised it and I could configure the printing options I needed.
You have discovered that a network connection works differently from a USB connection on LM20.
After experimenting, I found that XSane (from Software Manager) could happily drive its scanning function. (XSane is vastly over-featured for my needs, but so what?).
This is a misconception. Xsane does not do any driving. It is a SANE frontend,
--
Brian.
bluesky509
Level 1
Level 1
Posts: 28
Joined: Fri Jun 05, 2015 11:32 am

Re: Printer Help HP mfp m477fdw

Post by bluesky509 »

fermat wrote:
Thu Oct 22, 2020 11:05 am
Many users are reporting problems with scanning on LM20. see
viewtopic.php?f=51&t=329760&p=1881829&h ... r#p1881829
...
Unfortunately, the printer is big and heavy and nowhere near an Ethernet plug... WiFi was part of the reason I choose this printer. But thanks for the suggestions. I also came up on several reports of similar issues with LM20/Focal Fossa. Just hoped someone had figured things out.

brian_p wrote:
Thu Oct 22, 2020 6:02 am

Then become familiar with it :). Read the Printers and Scanners forum and

https://wiki.debian.org/CUPSDriverlessPrinting
Is this meant to work out-of-the-box because it was not working for me thus resorting to other methods that had previously worked on LM19. The only thing LM20 did automatically was add the printer the the printer list. I could print but it was the scanning feature that would not work and that I really needed... I tried the default scanner app or xsane.
You can print but not scan? Say whether you are USB connected or not. Give the output of

Code: Select all

scanimage -L
At the time of my original post I had a deadline to scan docs and hoped someone had an easy fix. I did spend some time searching around and tried a few things before posting. I assume the issues began with LM20 but I had not tried printing/scanning so may have not noticed. Learning about print protocols wasn't really an option so I tried what worked in the past.

I am now currently on LM19.3 and debating trying to upgrade again.

The printer is on WiFi and not close enough to where I could run a USB to it.

scanimage -L:

Code: Select all

 device `hpaio:/net/HP_Color_LaserJet_MFP_M477fdw?ip=192.168.1.212' is a Hewlett-Packard HP_Color_LaserJet_MFP_M477fdw all-in-one
linux newbie
brian_p
Level 6
Level 6
Posts: 1411
Joined: Thu Jan 17, 2019 9:20 am

Re: Printer Help HP mfp m477fdw

Post by brian_p »

bluesky509 wrote:
Thu Oct 22, 2020 7:35 pm

The printer is on WiFi and not close enough to where I could run a USB to it.
Being on WiFi the best :D. Keep it there!

Download and install sane-airscan:

https://github.com/alexpevzner/sane-airscan

The Printers and Scanners forum has lots of success stories from users who did precisely that. Your device is supported.
--
Brian.
bluesky509
Level 1
Level 1
Posts: 28
Joined: Fri Jun 05, 2015 11:32 am

Re: Printer Help HP mfp m477fdw

Post by bluesky509 »

brian_p wrote:
Fri Oct 23, 2020 6:21 am
bluesky509 wrote:
Thu Oct 22, 2020 7:35 pm

The printer is on WiFi and not close enough to where I could run a USB to it.
Being on WiFi the best :D. Keep it there!

Download and install sane-airscan:

https://github.com/alexpevzner/sane-airscan

The Printers and Scanners forum has lots of success stories from users who did precisely that. Your device is supported.
Thanks. I'll upgrade to LM20 and give that a shot and report back.
linux newbie
Post Reply

Return to “Newbie Questions”