19.3 XFCE broken after suspend. How to fix?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Statik
Level 2
Level 2
Posts: 81
Joined: Sat Jan 14, 2012 9:27 pm

19.3 XFCE broken after suspend. How to fix?

Post by Statik »

Hi all,
I installed Linux Mint 19.3 XFCE on an old laptop to use as a nextcloud server. Once I had everything setup, I went into power management and told it to blank the screen when the cover was closed, and thats it. Then I closed to cover. To my horror, it went into sleep mode. When I opened the cover back up, the screen did not come back. I tried several things to get it to reboot to no avail so I ended up doing a hard shutdown.
On powering the unit back up, the menu bar complained about wisker and menu apps failing and I had no application menu. The unit shows the available networks but fails to connect to wifi or ethernet.
How can I fix this install without doing a full reinstall?

thanks!
Statik
sleeper12
Level 15
Level 15
Posts: 5685
Joined: Thu May 25, 2017 3:22 pm

Re: 19.3 XFCE broken after suspend. How to fix?

Post by sleeper12 »

Open a live session of Mint & see if Timeshift will fix things.
Statik
Level 2
Level 2
Posts: 81
Joined: Sat Jan 14, 2012 9:27 pm

Re: 19.3 XFCE broken after suspend. How to fix?

Post by Statik »

Unfortunately, timeshift was not yet setup. The install was only a day old. It is possible for me to do a full reinstall without losing much but I'd rather fix it. :(
Hoser Rob
Level 17
Level 17
Posts: 7059
Joined: Sat Dec 15, 2012 8:57 am

Re: 19.3 XFCE broken after suspend. How to fix?

Post by Hoser Rob »

If it's an old laptop you may be better off doing a clean reinstall of Mint 19.2. 19.3 ships with the 5.0 series kernel in which a lot of support for old hardware was lopped off. 19.2 uses the 4.15 kernel which is better for old hardware and is also LTS .
Post Reply

Return to “Newbie Questions”