Page 1 of 1

No EFI system partition found

Posted: Wed Jan 13, 2021 1:23 pm
by redcarrot
Trying to install linuxmint 20 cinnamon on my desktop.

Configuration: Intel core i3(3rd gen), Motherboard: Gigabyte H61M-WW, 4 GB DDR3 RAM, 320 GB SATA Hard disk (NEW-Nothing installed)

UEFI BIOS version F1. Flash Type/Size : Winbond 25X/Q Series 4MB

Created bootable USB using RUFUS portable version 3.13. Partition Scheme: GPT. Target system: UEFI (NON CSM). File System: FAT32

Tried installing using the "Something Else" option. Installation proceeds ok creating partitions but it gives the following message:

"No EFI System Partition was found. The system will likely not be able to boot successfully, and the insallation process may fail.
Please go back and add an EFI System Partition, or continue at your own risk.


I am kind of new to this. Kindly advice on how to proceed.

Thanks.

Re: No EFI system partition found

Posted: Wed Jan 13, 2021 1:58 pm
by Larry78723
Using the "Something Else" option to install in UEFI mode, you need to create a 500Mb partition and set the flags to boot, efi and set the mount point to /boot/efi.

Re: No EFI system partition found

Posted: Wed Jan 13, 2021 2:41 pm
by redcarrot
Hi Larry

Thanks for your reply. Sorry. I do not understand so well.
Do I need to change the UEFI/legacy option? I think currently it s UEFI and legacy

Also what does 'Set the flags to boot, efi mean?

I was trying the following partition scheme(320 GB hard drive)
/boot – 10 GB (ext4 file system)
/ – 90 GB (ext4 file system)
/home – 200 GB (ext4 file system)
Swap – Rest of the space

Help!

Regards...

Re: No EFI system partition found

Posted: Fri Jan 15, 2021 6:40 am
by redcarrot
Hi

Thanks for your reply. I just did a basic install with the erase disk option. Its working fine.

Thanks

Re: No EFI system partition found

Posted: Fri Jan 15, 2021 6:47 am
by Pierre
sometimes, the LinuxMint Installer can work better,
if the Actual Installation is done Off-line ..

this can negate any trouble with an Secure Boot issue,
as well as any efiBoot issue.
:o